Affichage des résultats 1 à 9 sur 9
  1. #1
    Jeune membre Avatar de akeix
    Date d'inscription
    janvier 2007
    Localisation
    France, Bourges (18000)
    Messages
    26
    Remerciements
    0
    Remercié 0 fois
    dans 0 messages

    Par défaut CKForms : Ne peut instancier la fonction mail.

    Bonjour,

    J'utilise Joomla 1.5.15. J'arrive à envoyer des mails via Joomla (pour contacter un membre par exemple) avec la fonction mail PHP.

    J'ai installé pour la 1ere fois CKForms (v1.3.3). J'ai réuni à créer le formulaire et le publier dans un article.

    Par contre, quand j'appuie sur le bouton "envoyé", j'obtiens le message "Ne peut instancier la fonction mail." et je ne reçoit pas de mail.

    Avez-vous une idée sur le problème ?

    Merci d'avance

    Cordialement

    Jérôme

    MAJ du 1/03/2010 :
    En distant chez FREE, CKForms fonctionne très bien.
    Le problème demeure toujours quand j'utilise mon site local !

    Sachant que mon site local me sert de test et que mon site distant est prioritaire, je considère le problème réglé dans mon cas.
    Dernière modification par akeix ; 01/03/2010 à 22h58.

  2. #2
    Membre régulier
    Date d'inscription
    février 2010
    Messages
    130
    Remerciements
    14
    Remercié 1 fois dans 1 message

    Par défaut

    J'ai un peu la même chose sauf que je suis en localhost avec qcontact. J ai essayé en smtp et la je n'ai pas de message, en php mail j avais phpmailer failed avec l adresse de l expediteur, et en sendmail ne peut instancier la fonction mail. Peut importe le composant je pense que l on a le meme probleme. j ai cherché sur la toile une réponse face a la page blanche ou aux autres messages et quenini.

  3. #3
    Membre
    Date d'inscription
    juillet 2009
    Messages
    91
    Remerciements
    4
    Remercié 0 fois
    dans 0 messages

    Par défaut

    Bonjour,
    Moi aussi j'ai le message: Ne peut instancier la fonction mail. lorsque j'essaye d'envoyer le formulaire. Je suis en locahost avec joomla 1.5.15 et CKForms.
    Si quelqu'un à la solution ce serait sympa de nous éclairer.
    Cordialement

  4. #4
    Jeune membre
    Date d'inscription
    mai 2009
    Localisation
    Leucate
    Messages
    17
    Remerciements
    0
    Remercié 1 fois dans 1 message

    Par défaut CKforms : ne peut instancier la fonction mail sur serveur LWS

    Pour ma part c'est sur mon site que j'ai l'erreur et j'ai tout essayé mais je n'arrive pas à trouver pourquoi.
    le formulaire de contact de base de joomla marche très bien, mais oimpossible de recevoir les mails à partir du formulaire de devis créé avec CKforms version 1.3.3
    j'ai vérifié tous mes paramétrages, demandé à mon hébergeur si le sendmail était bien à l'endroit que j'avais spécifié,... etc
    j'en suis à mon 5ème site joomla et c'est la première fois que CKforms ne marcha pas.
    Le message est bien stocké dans la base de donnée, le client reçoit bien la confirmation de l'envoi du devis au prestataire mais moi et le prestataire nous ne recevons rien, vous comprendrez qu'en plus je me suis fait tapé sur les doigts car les clients avait l'impression que leur demande avait été proise en compte puisqu'ils recoivent leur mail de confirmation.
    j'ai vraiment besoin de votre aide
    Merci

  5. #5
    Membre régulier Avatar de Lannigh
    Date d'inscription
    janvier 2009
    Localisation
    Puisaye / Yonne
    Messages
    321
    Remerciements
    16
    Remercié 7 fois
    dans 5 messages

    Par défaut

    Même problème pour moi

    tout semble fonctionner correctement , mais le mail n'est pas envoyé aux destinataire ...

    Sous serveur perso , un composant Linux à rajouter ?

    A+
    Bill ... mon petit, je ne voudrais pas te paraitre vieux jeu, ni encore moins grossier, l'homme de la pampa parfois rude reste toujours courtois.... mais là, la vérité m'oblige à te dire que ... ton Windows Vista commence à me les briser menu !!

  6. #6
    Membre régulier
    Date d'inscription
    août 2006
    Messages
    185
    Remerciements
    3
    Remercié 3 fois
    dans 3 messages

    Par défaut

    Bonjour,

    J'ai eu le même problème.
    Je suis allé dans la configuration générale du site > Onglet Serveur > Réglages email >
    Serveur de mail : j'ai mis "Serveur SMTP" en lieu et place de "Fonction mail PHP" et tout baigne.

    Voilà,

    Alain

  7. #7
    Membre Avatar de Orangina
    Date d'inscription
    novembre 2008
    Messages
    97
    Remerciements
    4
    Remercié 7 fois
    dans 6 messages

    Par défaut

    Bonjour

    Pour que PHP Mailer fonctionne il faut que vous ayez un serveur de courrier (serveur smtp) sur votre PC, ce qui n'est généralement pas le cas en local.
    En local, vous devez choisir serveur smtp, et mettre le serveur SMTP de votre FAI (smtp.free.fr, smtp.orange.fr, ...), sans identification.

  8. Les 2 membres suivants remercient Orangina pour ce message :

    bea22 (06/08/2010), infostar (13/02/2011)

  9. #8
    Membre
    Date d'inscription
    juin 2010
    Localisation
    Laon (Picardie)
    Messages
    67
    Remerciements
    3
    Remercié 0 fois
    dans 0 messages

    Par défaut

    Citation Envoyé par Orangina Voir le message
    Bonjour

    En local, vous devez choisir serveur smtp, et mettre le serveur SMTP de votre FAI (smtp.free.fr, smtp.orange.fr, ...), sans identification.
    merci bcp, j'ai enfin réussi après lecture de xxx posts à ce sujet

  10. #9
    Jeune membre
    Date d'inscription
    mai 2009
    Localisation
    Leucate
    Messages
    17
    Remerciements
    0
    Remercié 1 fois dans 1 message

    Par défaut

    bonjour,
    pour ma part le site est en ligne : thermicien-confort.com et mon formulaire de demande de devis enregistre bien la demande de devis sur ma base de données, mais je n'ai aucun mail d'envoyé, le pire c'est que le client reçoit bien lui la confirmation que sa demande a été envoyé alors qu'en fait elle est juste enregistré mais pas envoyé par email.
    Personne n'a de solution à ce problème, sachant que j'ai essayé avec serveur smtp et là rien ne marche, même pas l'enregistrement de la demande de devis, ni le siomple formulaire de demande de contact de joomla qui lui marche par contre sans aucun problème.
    Merci de votre aide

Discussions similaires

  1. [Problème] probleme avec la fonction mail dans hyperion
    Par legoline dans le forum Questions générales
    Réponses: 1
    Dernier message: 18/02/2010, 18h17
  2. [Problème] Sendmail, Fonction mail php et SMTP ne marchant pas
    Par Jarode888 dans le forum Questions générales
    Réponses: 3
    Dernier message: 03/05/2009, 19h09
  3. Impossible d'instancier la fonction mail
    Par benjamin7924 dans le forum Questions générales
    Réponses: 2
    Dernier message: 21/08/2008, 15h25
  4. Comment gérer activer la fonction mail chez un hébergeur gratuit
    Par didrissi dans le forum Questions générales
    Réponses: 0
    Dernier message: 29/04/2008, 04h53
  5. facileforms envoyer un mail en fonction des choix
    Par francoisdt dans le forum Générateurs de formulaires
    Réponses: 3
    Dernier message: 14/02/2008, 12h46

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •