Affichage des résultats 1 à 6 sur 6
  1. #1
    Jeune membre
    Date d'inscription
    novembre 2009
    Messages
    6
    Remerciements
    2
    Remercié 0 fois
    dans 0 messages

    Par défaut site en français mais date en anglais en affichage blog

    Bonjour,

    Je viens de refaire le site de mon association sous joomla 2.5, hébergé chez 1and1.fr, le tout avec le template jf_texturia. Jusque là tout va bien, sauf que je me casse les dents sur un bête problème.

    Tout est en français sur mon site, sauf l'affichage en haut à gauche de l'article qui se mets en anglais lors que je suis en affichage d'une catégorie sous forme de blog. voir ici pour l'exemple : http://photoclub-lecreusot.fr/

    J'ai regardé sur le net pour trouver une solution, rien à faire, j'ai fouiné dans énormément de fichiers du site, je ne trouve rien de particulier dans les fichiers du template, j'ai même passé les mois en français dans le fichier de langue anglaise, mais rien n'y fait, cette fichue date reste en anglais.

    J'avoue ne plus rien y comprendre. Vous n'auriez pas une piste car là je sèche
    Dernière modification par kiwi_r ; 15/03/2012 à 21h30. Motif: correction du titre

  2. #2
    Membre régulier
    Avatar de RobertG
    Date d'inscription
    février 2007
    Localisation
    Saint-Félicien (Ardèche)
    Messages
    18 185
    Remerciements
    6
    Remercié 1 447 fois
    dans 1 422 messages

    Par défaut Re : site en français mais date en anglais en affichage blog

    Compte tenu du nom de la classe à ce niveau, c'est le template qui est en cause.
    Il faut que tu regardes dans son répertoire "html" où est forcée cette date.
    Dernière modification par RobertG ; 15/03/2012 à 21h21.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

  3. #3
    Jeune membre
    Date d'inscription
    novembre 2009
    Messages
    6
    Remerciements
    2
    Remercié 0 fois
    dans 0 messages

    Par défaut Re : site en français mais date en anglais en affichage blog

    Ok, mais dans ce dossier HTML, je n'ai que des fichiers PHP et nulle part un fichier où apparait le mois en clair.

    Parceque le truc bizarre c'est que si j'affiche la date de création au dessus de l'article (le "écrit par xxx le ...), là, la date est bien écrite avec le mois en français, je n'arrive donc pas du tout à comprendre où est-ce qu'il va chercher le terme anglais. J'ai regardé tous les fichiers ini dans language, nulle part les mois n'apparaissent en anglais

    par exemple dans le code source de la page ce "march", il va le chercher où?
    <td class="contentheading" width="100%">
    <span class="jf-date-content">12<span>March</span></span>
    Dernière modification par RobertG ; 15/03/2012 à 21h21.

  4. #4
    Membre régulier
    Avatar de RobertG
    Date d'inscription
    février 2007
    Localisation
    Saint-Félicien (Ardèche)
    Messages
    18 185
    Remerciements
    6
    Remercié 1 447 fois
    dans 1 422 messages

    Par défaut Re : site en français mais date en anglais en affichage blog

    J'ai eu du mal à trouver, mais dans les fichiers blog_item_lead.php (pour categories et featured) le mois est renvoyé en anglais par
    $month = date("M",strtotime($created_date));
    Il faut donc remplacer la ligne
    <span class="jf-date-content"><?php echo $day; ?><span><?php echo $month; ?></span></span>
    par
    <span class="jf-date-content"><?php echo $day; ?><span><?php echo JTEXT::_($month); ?></span></span>
    Il faudra ensuite voir si tu conserves les noms des mois tout en minuscules ou si tu fais une substitution de langue pour avoir l'initiale en majuscules.
    Dernière modification par RobertG ; 15/03/2012 à 21h21.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

  5. Les 2 membres suivants remercient RobertG pour ce message :

    archangel (10/04/2012), kiwi_r (15/03/2012)

  6. #5
    Jeune membre
    Date d'inscription
    novembre 2009
    Messages
    6
    Remerciements
    2
    Remercié 0 fois
    dans 0 messages

    Par défaut Re : site en français mais date en anglais en affichage blog

    ça marche!!
    Merci beaucoup, franchement, ça m'enlève une épine du pied car mes adhérents n'arrêtaient pas de me faire la remarque !

    Mmm et comment je fais cette subsitution pour avoir les majuscules? (désolé je débute )
    Edit : c'est bon j'ai trouvé
    Dernière modification par kiwi_r ; 15/03/2012 à 21h29.

  7. #6
    Modérateur

    Avatar de lesoutier
    Date d'inscription
    octobre 2006
    Localisation
    Cévennes méridionales
    Messages
    5 091
    Remerciements
    4
    Remercié 305 fois
    dans 299 messages

    Par défaut Re : site en français mais date en anglais en affichage blog

    Mmm et comment je fais cette subsitution pour avoir les majuscules? (désolé je débute )
    Edit : c'est bon j'ai trouvé
    Normalement, en français les noms des mois, comme ceux des jours ne prennent pas de majuscules.
    Dernière modification par lesoutier ; 16/03/2012 à 16h02.
    De quand date la dernière sauvegarde de votre site ? Il est vrai que les problèmes n'arrivent qu'aux autres, mais en cas de crash, rien ne remplace une sauvegarde récente (Site + Base de données)

Discussions similaires

  1. [Problème] Affichage des articles en blog - ajouter la condition de la date du jour ?
    Par gregdefauconval dans le forum Questions générales
    Réponses: 3
    Dernier message: 28/11/2011, 08h59
  2. [RÉGLÉ] Affichage de la date mais sans l'heure dans un article ?
    Par olostar dans le forum Questions générales
    Réponses: 9
    Dernier message: 19/12/2010, 20h42
  3. De l'anglais dans com_user (version française) !
    Par cirem dans le forum Questions générales
    Réponses: 9
    Dernier message: 13/02/2010, 12h53
  4. [Problème] Date reste en anglais sur la version française
    Par mum-djin dans le forum Gestion multilingue
    Réponses: 0
    Dernier message: 02/02/2009, 23h15
  5. [Problème] Installation OK mais site totalement en anglais...
    Par doryan dans le forum Installation et mise à jour de Joomla! 1.5.x
    Réponses: 4
    Dernier message: 23/12/2008, 10h09

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •