Affichage des résultats 1 à 2 sur 2
  1. #1
    Membre régulier
    Avatar de Hatshepsout
    Date d'inscription
    février 2008
    Localisation
    100% Brionnais
    Messages
    514
    Remerciements
    14
    Remercié 9 fois
    dans 9 messages

    Par défaut Non prise en compte des fichiers langue

    Bonjour à toutes et tous,

    Ne trouvant pas exactement ce que je voulais, je me suis lancé dans la réalisation de mon premier module.
    Après avoir cherché (principalement ici) et sur un fameux moteur de recherche, je me tourne vers vous pour entrevoir une solution à ce problème qui me chamboule le Golliwog depuis de nombreuses heures.

    Voici d'abord le fichier XML de mon module (J!1.7.0) :
    Code:
              <files>
    		<filename module="mod_mon-module">mod_mon-module.php</filename>
    		<filename>index.html</filename>
        	        <filename>helper.php</filename>
    		<filename>mod_mon-module.xml</filename>
    		<folder>tmpl</folder>
                    <folder>css</folder>
                    <folder>images</folder>
    		<folder>language</folder>
    	 </files>
    	
    	 <languages folder="language">
                     <language tag="fr-FR">fr-FR/fr-FR.mod_mon-module.ini</language>
                     <language tag="fr-FR">fr-FR/fr-FR.mod_mon-module.sys.ini</language>
                     <language tag="en-GB">en-GB/en-GB.mod_mon-module.ini</language>
                     <language tag="en-GB">en-GB/en-GB.mod_mon-module.sys.ini</language>
             </languages>
    A l'installation (je suis en local), tout est ok : pas de message d'erreur et les fichiers "langue" sont bien présents dans les sous-dossiers respectifs. Seulement, cela se gâte sérieusement à l'affichage du module en back-end puisque les label ne sont pas remplacés par les caractères correspondants.

    Code:
    MOD_MON-MODULE_FIELD_PRE_TEXT="Pre-text"
    MOD_MON-MODULE_FIELD_PRE_TEXT_DESCRIPTION="Enter your pre-text message"
    Aucun des fichiers "langue" n'est pris en compte ...

    D'où pourrait bien venir cette erreur, selon vous ?

    Merci par avance pour votre aide et vos réponses.
    Dernière modification par Hatshepsout ; 02/05/2012 à 11h07. Motif: problème réglé
    web-eau.net www.web-eau.net
    Responsive Tables Responsive Tables

  2. #2
    Membre régulier
    Avatar de Hatshepsout
    Date d'inscription
    février 2008
    Localisation
    100% Brionnais
    Messages
    514
    Remerciements
    14
    Remercié 9 fois
    dans 9 messages

    Par défaut Re : Non prise en compte des fichiers langue

    Affaire réglée, il y avait une erreur de syntaxe dans les fichiers .ini
    web-eau.net www.web-eau.net
    Responsive Tables Responsive Tables

Discussions similaires

  1. [RÉGLÉ] Pas de prise en compte du vote et si prise en compte article altéré joomla 2.50
    Par folamour dans le forum Questions générales
    Réponses: 0
    Dernier message: 02/03/2012, 15h29
  2. [RÉGLÉ] class css non prise en compte
    Par laurent00 dans le forum Gestion des templates, design et CSS
    Réponses: 4
    Dernier message: 21/02/2012, 20h20
  3. [RÉGLÉ] Modification dans fichier de langue .ini non prise en compte
    Par ridlery dans le forum Questions générales
    Réponses: 2
    Dernier message: 04/11/2011, 15h41
  4. Soucis prise en compte TVA
    Par eric67 dans le forum E-commerce
    Réponses: 0
    Dernier message: 23/06/2010, 11h27
  5. non prise en compte des remises
    Par ephie dans le forum E-commerce
    Réponses: 3
    Dernier message: 17/04/2008, 19h17

Les tags pour cette discussion

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •