TinyMCE, Pas de source HTML et création de lien bizarre.

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • TinyMCE, Pas de source HTML et création de lien bizarre.

    Bonjour,

    J’utilise TinyMCE 2.0.6.1 livré par défaut avec joomla 1.0.10 pour édité mes articles.

    Mais si je clique sur le bouton « Edit HTML Source » il m’ouvre un fenêtre vide sans code html.

    D’autre par si j’utilise la fonction « Incert / Edit link) avec comme lien www.google.com, il me cré un lien du genre http://www.monsite.fr/index.php?opti...9#mce_temp_url

    Qui ne marche pas bien sure.

    quelqu’un a-t-il une explication a ces deux problèmes.

    Merci

    jcs
    Dernière édition par tristana à 20/08/2006, 23h57 Raison: [Réglé]
    Amateur de plantes sauvages et comestibles de la région méditerranéenne.
    http://garrigue-gourmande.fr

  • #2
    J'avais le même problème que toi et j'ai juste changé, dans "configuration.php", la ligne

    $mosConfig_live_site = 'http://monsite.info';

    par:

    $mosConfig_live_site = 'http://www.monsite.info/';

    et ça a marché.

    Voila a+
    http://www.marc-dugas.fr

    Commentaire


    • #3
      Merci, ca marche nickel. D’une pierre deux coups. Je vais m’empresser d’ébruiter la solution dans un autre post où j’avais contourné le problème en installant FCK Editor.

      Je mets donc le post sur REGLER. Aaaah, ca fait du bien quand un problème est prompt réglé aussi efficacement.
      Amateur de plantes sauvages et comestibles de la région méditerranéenne.
      http://garrigue-gourmande.fr

      Commentaire


      • #4
        Bonjour,

        je débute sur Joomla, et je rencontre le même problème. Cependant j'utilise Joomla en local pour me faire la main. Dans le fichier config.php, j'ai modifié la valeur $mosConfig_live_site en mettant le nom de mon PC comme indiqué dans tutoriel sur wiki. Mais ça n'arrange rien bien au contraire, puisque je perd les icones de la page administrator et la barre de menu. J'ai également essayé de mettre 'http://www.monsite.com', pour le même résultat.

        Donc, si vos pouviez m'aider, ça m'arrangerais car j'y comprend rien.

        Merci

        Commentaire


        • #5
          Je crois qu’il est important que tu mettes un slash à la fin du nom de ton site.

          Donc

          'http://www.monsite.com/'

          Ou

          'http://nom_du_pc/'

          Ou

          'http://localhost/'
          Amateur de plantes sauvages et comestibles de la région méditerranéenne.
          http://garrigue-gourmande.fr

          Commentaire


          • #6
            J'ai essayé tes diverses solutions mais sans succès. A chaque fois je perd tout le design du site lorsque je suis en page d'accueil.

            Que faire??

            Commentaire


            • #7
              Pour cela il serait utile que tu nous dises quelle est la configuration que tu utilises pour travailler en local.
              Et pourquoi ne pas essayer en ligne chez un hébergeur si tu en a la possibilité ?
              Au moins tu auras une configuration sure du serveur web.
              Amateur de plantes sauvages et comestibles de la région méditerranéenne.
              http://garrigue-gourmande.fr

              Commentaire


              • #8
                j'ai le même problème, impossible à résoudre... le '/' ou le 'www' n'y faisant rien.

                Commentaire


                • #9
                  Il faut aussi faire attention à l'url avec lequelle on accède au répertoire administrator.

                  Si elle est de la forme:
                  http://www.monsite.com/administrator/index.php
                  il faut dans configuration.php
                  $mosConfig_live_site = 'http://www.monsite.com';

                  Si elle est de la forme:
                  http://monsite.com/administrator/index.php
                  il faut dans configuration.php
                  $mosConfig_live_site = 'http://monsite.com';

                  En ce qui concerne le '/' a la fin tu peut essayer avec ou sans. Chez moi je l'ai mis et ça me donne des fois une url du genre www.monsite.com//index.php mais ça gène pas beaucoup

                  a+
                  http://www.marc-dugas.fr

                  Commentaire


                  • #10
                    TinyMCE, même problème que les copains !

                    Salut à tous,

                    J'ai lu les différents posts et j'ai essayé les propals, cela ne change rien
                    Je suis sur Joomla! 1.0.11 Stable.

                    Commentaire


                    • #11
                      TinyMCE

                      Salut à tous,

                      Toujours le même soucis avec TinyMCE... même pire.
                      Utiliser avec Joomla 1.0.12 fr stable sur PC XP pro.

                      Sous Firefox 2.0.0.3 :
                      1- Les popups (tableau, image, lien, etc.) ne s'ouvrent qu'a moitié ? donc impossible de les utiliser.
                      2 - le popup "HTML Source Editor" s'ouvre en entier mais impossible de voir le code HTML.
                      3 - Mieux... impossible de changer d'éditeur malgré le fait d'avoir dépublier le mambot TinyMCE, d'avoir publier JCE et d'avoir choisi JCE ou même un autre éditeur dans la configuration du site ???

                      Comme il est impossible de désinstaller TinyMCE via le "com_installer" et que si je désinstalle physiquement TinyMCE depuis le serveur FTP, les articles disparaissent, je ne sais quoi faire

                      Par contre avec IE7, Netscape 7.1 et Opera 8.52 no problemo ???

                      Cela fait iech car j'aime vraiment bien Firefox.

                      @+

                      Commentaire


                      • #12
                        3. change l'éditeur non pas dans la config globale mais dans la gestion des éditeurs.

                        sinon même probleme que toi sous FF
                        cours de SVT - infos scientifiques : www.nicolas-ogier.fr
                        pas de demandes d'aide par mp, elles seront systématiquement refusées !

                        Commentaire


                        • #13
                          Salut Opware2000,

                          Merci pour l'info, que j'avais déjà lu cette nuit dans un autre fil. Depuis, je suis passé sur FCKeditor. Pour l'instant il n'y a pas de problème.

                          @+

                          Commentaire


                          • #14
                            Envoyé par tristana Voir le message
                            Bonjour,


                            Mais si je clique sur le bouton « Edit HTML Source » il m’ouvre un fenêtre vide sans code html.

                            jcs
                            Bonjour,
                            j ai la version 1.0.12.
                            j avais le meme probleme avec firefox, maintenant j'utilise slimbroser et ca marche, mais j'ai un autre probleme :
                            >>> Le pop up s'ouvre > > je colle mon code html >> j'update > je reviens a mon article et je sauvegarde.

                            et j'ai rien dans mon article ? il est vide.
                            j'ai oublié qq chose ?

                            voici le code :

                            <script language="JavaScript" src="http://www.evene.org/citajoursanspicto.js"></script>
                            <noscript><a href="http://www.evene.fr">www.evene.fr</a></noscript>

                            Merci
                            Merci.

                            débutant parisien qui a découvert Joomla depuis juin 2007.
                            Hébergeur 1and1
                            version 1.0.13. Template : rhuk_solarflare_ii

                            en cours d'install le pack ecommerceEdition 1.0.12

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X