Joomladay francophone 2018 à Paris 18 et 19 mai

JCE et l'effet LightBOx

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • JCE et l'effet LightBOx

    BOnjour à tous...

    Je suis allé me procurer moyennant finance les plug's supplémentaire pour faire des affichages façon LightBox avec JCE

    Voici ce que j'ai installé :

    JCE 1.1.1
    JCE Utilities 1.3.0
    JCE BOT : 1.1.8

    et les plug's suivant :
    Image Manager Extended
    Advanced Link Extended
    Joomla Bots Plugin

    Sachant que j'ai coupé Image Manager et AdvLink fourni avec la version gratuite 1.3.0 pour laisser libre cours aux extended.

    Pourtant lorsque je me met sur l'onglet Pop-Up il m'affiche bien l'image en connectant simplement dessus mais pas avec l'effet slim ou lightbox... faut il aller chercher les javascript ou sont il fourni avec JCEUtilities ?

    ça devient critique pour moi, je comptais sur l'achat des plug'in supplémentaires et pour l'instant je n'arrive à rien


    au sicouuuur !!!!

    -------------- EDIT ------------------

    Dommage que personne me réponde... niiif !!!

    J'ai beau fouiller le forum, mais bon avec un peu de temps j'ai réussi à à peu près faire marcher le lightbox... sur FireFox ou Opéra... par contre sur tous les navigateurs tournant sur le moteur IE, ça ne marche pas...

    Y'a t'il une raison ou une solution, sachant que j'ai nettoyé tous les autres modules (datso par exemple) qui fonctionne avec Mootools. Il ne reste plus que JCEUtilities 1.3.0 et pourtant ça ne marche à moitié, faut il que je l'enlève et utilises multithumb ou y'a t'il moyen de le faire fonctionner correctement..

    Merci à tous de vos réponses.
    Dernière édition par Trep à 26/12/2007, 20h26
    Un con qui marche va plus loin qu'un intello assis.

  • #2
    Je me permet de faire un Up... si quelqu'un aurai une réponse, cela m'aiderait vraiment beaucoup !

    merci et joyeux noël !

    Un con qui marche va plus loin qu'un intello assis.

    Commentaire


    • #3
      Je vois que mon Post ne fait hélas pas d'intérêt...

      Mais quoi qu'il en soit, j'ai enfin trouver la réponse et le but d'une communauté est de faire profiter chacun.

      Lorsque j'ai construit mon template, la bannière allait être en flash. IE provoquant une demande d'autorisation d'activation ActiveX, bloquant mon anime flash (ou tout ce qui était en flash dans le site) j'avais cherché un Javascript permettant de bloquer cette demande.

      Seulement ce javascript rentrait en conflit avec le JCEUtilities 1.3.0 UNIQUEMENT pour les navigateurs tournant sous moteur IE.

      J'ai donc supprimé pour l'instant ce code et tout refonctionne.

      Je vous donne donc le code fautif nommé "ieplug.js", qu'il ne faut donc ne plus utiliser en cas d'insertion de bibliothèque Mootools ou JQuery...

      Code:
      // IE JavaScript Deleted ActiveX
      
      theObjects = document.getElementsByTagName("object");
      for (var i = 0; i < theObjects.length; i++) {
      theObjects[i].outerHTML = theObjects[i].outerHTML;
      }
      J'espère que cela fera avancer le Schimilili, le schimilimili... argh !
      Un con qui marche va plus loin qu'un intello assis.

      Commentaire


      • #4
        Si tu veux que les gens réponde, il ne faut pas mettre en [Réglé] ça veut dire que ton soucis n'y est plus.

        Pour revenir a ton problème
        j'ai coupé Image Manager et AdvLink fourni avec la version gratuite 1.3.0
        Sache que ce n'est pas nécessaire, le nouveau c'est met par dessus!

        Communauté FR http://www.sarki.ch/jce
        Règlement du forum : http://forum.joomla.fr/faq.php
        Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
        Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
        http://www.iwannaclick.org

        Commentaire


        • #5
          déjà oui pas [réglé] quand ca ne l'est pas.

          commet fais tu ton appel au lightbox ?
          insères tu bien tes appels aux javascripts dans l'header de ton template ?
          formates tu correctement le paramètre rel de la balise img ?
          cours de SVT - infos scientifiques : www.nicolas-ogier.fr
          pas de demandes d'aide par mp, elles seront systématiquement refusées !

          Commentaire


          • #6
            Dans JCE adérant c'est intégrer

            1. il faut aussi installer et publier le Mambot JCE Utilities
            @opware2000 c'est là que c'est appeler
            et aussi là qu'il peut avoir des conflits si c'est déjà dans le template
            info : http://www.sarki.ch/jce/component/op...ileinfo/id,12/

            2 les miniatures ne ce font pas automatiquement, par contre il y a la possibilité de les faire directement dans l'imagemanager
            lire ça : http://www.sarki.ch/jce/component/op...ileinfo/id,13/
            Règlement du forum : http://forum.joomla.fr/faq.php
            Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
            Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
            http://www.iwannaclick.org

            Commentaire


            • #7
              désolé sharky, moi j'en étais resté au bon vieil appel dans le template (qui marche )
              cours de SVT - infos scientifiques : www.nicolas-ogier.fr
              pas de demandes d'aide par mp, elles seront systématiquement refusées !

              Commentaire


              • #8
                Merci pour les infos,

                Si j'ai mis [réglé], c'est que j'ai résolu le problème... tant qu'il était en [problème], je n'avais pas de réponse, tout simplement parce que je pensais que personne n'avais eu ce genre de soucis.

                Ne vous en faite pas, étant aussi Modo et concepteur de site et forum, je sais comment ça tourne et fais en sorte de bien suivre les règles dans ceux ou je traine mes guêtres. Maintenant si je me fais sermonner, bon ben tant pis.

                Relisez bien le dernier post, je vous explique la raison pour laquelle j'avais un conflit avec JCEUtilities. Un simple script permettant d'empêcher la protection activeX.

                En vous souhaitant d'excellentes fêtes de fin d'année.
                Un con qui marche va plus loin qu'un intello assis.

                Commentaire


                • #9
                  J'y ai pensée ...
                  des fois on répond trop vite sans tout lire
                  Règlement du forum : http://forum.joomla.fr/faq.php
                  Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
                  Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
                  http://www.iwannaclick.org

                  Commentaire


                  • #10
                    Loul !!!

                    No soucis, le tout de d'avoir trouvé la solution et d'en faire profiter tout le monde...

                    Un con qui marche va plus loin qu'un intello assis.

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X