Pb version mosCE 104

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Pb version mosCE 104

    Ryan a publié le 2 février dernier la version mosCE 104 comprenant TinyMCE202.

    J'ai :
    1 - désinstallé la verion précédente mosCE103_Final,
    2 - vérifié que tous les fichiers de la version précédente étaient bien supprimés,
    3 - installé la version mosCE104
    4- déclaré dans Global_Configuration la nouvelle version de l'éditeur,
    5 - actualisé mon site pour que les nouveaux liens soient bien activés,
    6 - et là patratra je peux pas visualiser mes articles.

    Après avoir fait de multiples essais d'écriture et de lecture d'articles je constate qu'il n'y a ni lecture ni écriture dans la base de données.
    Donc en attendant je reviens à la version précédente mosCE103 final avec TinyMCE 145.
    Dommage car cet éditeur mosCE comprenant TinyMCE est vraiment ce que j'ai trouvé de mieux en terme de fonctionnalités (Liens URL directs de fichiers photo, flash, pdf ../.. Publication du site local chez le provider sans être obliger de refaire les liens URL .../...)!!!

    Est ce que quelqu'un a déjà eu ce problème et qu'est ce que j'ai bien pu faire comme erreur ???

    Bon week end

    Téophile
    Dernière édition par Téophile à 10/02/2006, 04h59

  • #2
    Je viens de trouver que ce problème n'existe pas sous Firefox 1.5 mais uniquement sous IE6

    Vraiment IE 6 devient capricieux ou .../...

    Donc mosCE104 et Tiny202 fonctionnent bien sous Firefox1.05 mais pas du tout sous IE6

    Que ceux qui parlent aglais transmettent à Ryan

    Bon week end

    Téophile

    Commentaire


    • #3
      mosce1.04 test et autres!!!!

      Bijour, je test actuellement mosCE 1.04 sur un joomla 1.0.7, je suis chez OVH donc installation manuelle via ftp, (je créer ensuite un new mambots qui s'appelle mosCE dans la catégorie éditeur avec le fichier mosce.php), je le valide par défaut dans la configuration globale. Et j'ai les même soucis que la v1.03 final, impossible d'écrire, erreur sur la page (accès refusé au niveau de index2.php dans administrator), aucun éditeur ne fonctionne chez moi c'est bien dommage, je ne sais plus quoi faire, et dès fois a force de bidouiller de changer d'éditeur j'arrive à avoir spawn en entier (c'est à dire que tout est ok que je peux écrire insérer tout ce que je veux) mais ca dure le temps d'un article ( dés que j'ai sauvegardé mon article ensuite je peux rien faire). J'ai 4 rédacteur en ligne qui sont bloqués dont moi ( 3 managers et un administrateur) j'ai l'impression qu'il y a un problème de droit d'écriture (est ce que cela ne viendrait pas du faites que j'ai des personnes qui sont managers et et d'autre qui sont administrateur)???.
      J'ai testé tous les éditeurs et y a toujours quelque chose qui fonctionne pas, y a que No WYSIWYG Editor qui marche (celui intégré à Joomla) mais il est pas pratique pour mes managers (il faut que ce soit le plus ismple possible pour eux).
      Que faire???????????????

      J'attends vos suggestions!!!!

      @+

      Erwan
      Admin CB

      Commentaire


      • #4
        Si tu es en local tu utise :
        - firefox1.5 avec mosCE104 ou 103 + Joomla107 (Pour moi ca marche)
        - ou d'après certains sites sous IE6 tu enlève www dans ton adresse (je n'ai pas vérifié)
        Voilà mais je pense nécessaire de faire un email en anglias pour ceux qui maitrisent aux éditeurs de Joomla 107, de TinyMCE, de mosCE, de FCKeditor et de les inviter à remédier dans les plus brefs délais à solutionner ce Problème majeure pour ces éditeurs qui ne lisent ni n'écrivent (Et pour un éditeur c'est un comble !!!)

        Téophile

        Commentaire


        • #5
          editeurs ...

          Je ne suis pas en local, je suis chez hébergeur OVH et mosce 1.0.3 et 1.0.4 sur un joomla 1.0.7 ne fonctionne pas sous IE et Firefox (aucun icone n'apparait dans la creation d'articles). Par contre spaw marche très bien sous IE et non sous firefox mais a condition que les "www" apparaissent bien dans l'URL.

          @+

          Erwan

          PS : et pour l'email en anglais ca peut être une idée mais je suis pas un fortich de l'english
          Admin CB

          Commentaire


          • #6
            Solution mosCE104

            Voici une solution qui fonctionne pour IE6 et Firefox151 (sauf Opera85)
            Voici le lien sur le site de l'éditeur de mosCE (Ryan)

            Il s'agit tout simplement :
            1 - d'ouvrir le fichier votresite/mambots/mosce.php
            2 - d'aller à la ligne 192
            3 - de modifier comme suit :
            Ligne 192 avant modif
            "$$plugins, preview, advimage, paste, fullscreen, directionality, mambo, contextmenu" ,
            Ligne 192 après modif :
            "$$plugins, preview, advimage, paste, fullscreen, directionality, mambo" ,
            4 - De relancer et pour moi ca marche en local sur IE6 et Firefox15

            D'après Ryan (développeur du superbe éditeur mosCE qui ajoute des fonctions à l'éditeur TinyMCE 2.0.2 de MaxiCode) il s'agit d'un conflit avec la bibliothèque d'overlib utilisée dans Joomla et le menu de contexte avec IE.
            There is a conflict with the overlib library used in Joomla and the context menu with IE
            Et voilà ca à l'air de rentrer dans l'ordre !!!

            Attendons voir encore un peu avant de mettre régler

            Téophile

            Commentaire


            • #7
              arggggggg

              Merci pour cette solution, mais qui ne fonctionne pas chez moi (chez mon hébergeur OVH), j'ai toujours le même type d'erreur :
              pièces jointes à l'appui.

              Que faire nom d'une pipe en bois???

              Erwan
              Fichiers joints
              Admin CB

              Commentaire


              • #8
                Contacte OVH qui connaisse Joomla 107 et vérifie avec eux les paramétrages relatifs aux pages de codes soit:
                - Automatque
                - ISO 8859-1
                - INICODE UFT-8

                D'autre part j'ai vu quelque part que :
                - tu peux faire un essai en supprimant le www de ton adresse de site bizarre, bizarre,
                - tu doit vérifier le résultat avec monsite/sous-répartoire/joomla. C'est à dire que si tu fais plusieurs sites en les placant dans différents sous-répertoires il semblerait qu'il y a problème

                Voilà toutes les solutions que j'ai identifiées

                On ne met toujours pas régler tant qu'il y a autant de problèmes sur une fonction technique fondamentale.
                Téophile

                Commentaire


                • #9
                  ontacte OVH qui connaisse Joomla 107 et vérifie avec eux les paramétrages relatifs aux pages de codes soit:
                  - Automatque
                  - ISO 8859-1
                  - INICODE UFT-8

                  D'autre part j'ai vu quelque part que :
                  - tu peux faire un essai en supprimant le www de ton adresse de site bizarre, bizarre,
                  - tu doit vérifier le résultat avec monsite/sous-répartoire/joomla. C'est à dire que si tu fais plusieurs sites en les placant dans différents sous-répertoires il semblerait qu'il y a problème

                  Voilà toutes les solutions que j'ai identifiées

                  On ne met toujours pas régler tant qu'il y a autant de problèmes sur une fonction technique fondamentale.
                  Téophile

                  Ok j'ai testé sans le www et avec le www ca change rien sous IE et sous firefox
                  En effet j'avais plusieurs sites Joomla à la racine de mon www ché ovh ( 2 exactement le vrai et un pour les tests) j'ai shooté le joomla test et ca ne change strictement rien.
                  Donc je vais contatcer ovh expliquer mon problème et je vous tiens au courant.

                  @+

                  Erwan
                  Admin CB

                  Commentaire


                  • #10
                    Inicode Uft-8

                    Bon je viens de téléphoner à ovh, et je ne suis pas le seul à rencontrer ce type de problème avec joomla et ca viendrait très certainement du "INICODE UFT-8", ils doivent faire la mise à jour très prochainement, il me contact via email dès que c'est ok au niveau de leur mise à jour pour que je puisse me rendre compte du changement ou pas!!!

                    Affaire à suivre dans les jours qui viennent.

                    Je vous tiens au courant dès que j'ai des news

                    @+

                    Erwan
                    Admin CB

                    Commentaire


                    • #11
                      Autre problème, lorsque j'insère des liens URL dans le contenu, avant l'enregistrement de l'article tous les liens sont supprimés et c'est la galère !!!!
                      Vraiment un mauvais passage avec Joomla et ses éditeurs.
                      A tous ceux qui ont un peu de savoir et de pouvoir faites quelque chose !!!
                      Téophile

                      Commentaire


                      • #12
                        J'ai décidé de n'utiliser que la version de l'éditeur d'origine intégré à Joomla107 soit Version: 2.0 (2005-12-01) et tout rentre dans l'ordre.
                        Dommage je perd ce que j'avais avec mosCE soit :
                        - FilesManager . Alors pour le remplacer je suis obligé de saisir des chemins relatifs en saisissant.
                        - La saisie avancée de chemins pour les articles Section/catégories/Items ..../...
                        - .../...

                        Tout est OK sous IE6 et sous Firefox sauf sous Opera 8.5 l'éditeur naparait toujours pas.

                        Sujet réglé

                        Bonne journée

                        Téophile

                        Commentaire


                        • #13
                          Overlib et TinyMCE

                          Concernant l'utilsation de overlib et tinymce avec le plugin contextmenu :
                          Le problème est identifié sur le forum de moxiecode http://tinymce.moxiecode.com/punbb/v...ic.php?id=1336
                          La solution dans overlib.js remplacer "createPopup" with "createOverlibPopup"
                          Le context menu continuera à fonctionner.
                          J'ai testé sur monsite non-mambo et ça fonctionne.
                          Aparemment d'après la personne qui à débuggé overlib override la méthode window.createPopup de tinymce.
                          Attention pour tester bien vider le cache ou changer le nom de la bibliothèque overlib.js en overlib2.js
                          Dernière édition par jeanlouis238 à 23/02/2006, 12h57

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X