JCE : Liens statiques ne fonctionnent pas

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • JCE : Liens statiques ne fonctionnent pas

    Bonjour,
    J'ai monté 2 sites joomla version 1.08 indentiques, un sur Free,
    l'autre sur un serveur Windows 2003+ IIS+ php 4.1+ MYSQL 4.
    Sur free pas de pb.

    Par contre sur le serveur local, j'ai actuellement un pb avec l'utilisation des liens vers des pages statiques

    Je tiens à utiliser JCE, car il fonctionne partout très bien en FrontEnd.

    Cependant, lorsque je crée des liens vers des Pages statiques, FckEditor me donne
    (dans le code HTML) des liens comme celui-ci
    http://www.monsite/index.php?option=content&task=view&id=20&Itemid=9
    Et ça fonctionne.

    Par contre JCE , pour le même lien vers la même page, remplace "option=content" par "option=com_content"
    comme ci-dessous:
    http://www.monsite/index.php?option=com_content&task=view&id=20&Itemid=9
    Tant que je suis loggé en administrateur en front-end, le lien fonctionne, mais que je me délogge, je tombe sur une page me disant:
    Vous n'êtes pas autorisé à accéder à cette ressource.
    (A noter que sur free, ces liens fonctionnent dans tous les cas)

    La seule chose que j'ai faite pour résoudre le pb ,c'est de modifier le fichier link.php de JCE afin qu'il me donne
    des liens avec "option=content" au lieu de "option=com_content". Mais c'est pas très normal ni élégant, d'autant que sur les forums de JCE, personne ne rapporte ce pb, donc , il n'est sûrement pas dû à JCE, et se trouve ailleurs.


    Il y a sûrement un problème d'autorisation, mais je ne trouve pas.
    Quelqu'un aurait-il une idée ? Peut-être dans le mambot com_content !!!

    Lingole
    Dernière édition par lingole à 23/04/2006, 17h11

  • #2
    Salut,

    Si je comprend bien tu as des problèmes en local et en ligne chez free cela fonctionne?

    J'utilise toujours JCE depuis les versions antérieures et j'ai jamais eu de problème avec les liens vers les contenus statiques.

    Je suppose que tu as la dernière version du composant-modules et mambot.
    D'après-moi le problème vient de IIS.

    A+
    Lenamtl

    Commentaire


    • #3
      IIS :Effectivement, j'y ai pensé

      Salut,
      Merci pour ta réponse
      IIS :Effectivement, j'y ai pensé, mais en relisant le code de JCE, il n'y a
      pas d'appel à l'API du serveur WEB (Apache ou IIS).Et tous les autres modules fonctionnent correctement.
      Autre info : Si je lie chaque page statique à un item de menu (que je ne fais pas
      apparaître en frontEnd), à ce moment là, le lien que me donne JCE fonctionne.
      C'est donc, je pense, propre à Joomla, mais où !!!
      Ce soir, j'en ai perdu tout mon latin, enfin, le peu qu'il me restait.
      @+

      Lingole
      (lingole : en occitan, c'est un joli petit lézard qui se chauffe au soleil)

      Commentaire

      Annonce

      Réduire
      1 sur 2 < >

      C'est [Réglé] et on n'en parle plus ?

      A quoi ça sert ?
      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
      Comment ajouter la mention [Réglé] à votre discussion ?
      1 - Aller sur votre discussion et éditer votre premier message :


      2 - Cliquer sur la liste déroulante Préfixe.

      3 - Choisir le préfixe [Réglé].


      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

      2 sur 2 < >

      Assistance au forum - Outil de publication d'infos de votre site

      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

      UTILISER À VOS PROPRES RISQUES :
      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

      Problèmes connus :
      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

      Installation :

      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

      Archive zip : https://github.com/AFUJ/FPA/zipball/master

      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
      et remplacer www. votresite .com par votre nom de domaine


      Exemples:
      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
      Télécharger le script fpa-fr.php dans: /public_html/
      Pour executer le script: http://www..com/fpa-fr.php

      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
      Télécharger le script fpa-fr.php dans: /public_html/cms/
      Pour executer le script: http://www..com/cms/fpa-fr.php

      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
      Voir plus
      Voir moins
      Travaille ...
      X