Joomladay francophone 2018 à Paris 18 et 19 mai

Effects - Offre un nouveau Bots pour les articles

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Effects - Offre un nouveau Bots pour les articles

    Salut,

    alors voilà je vous mets ces plugins (Mambots) qui n’apportent pas
    grand chose de nouveau, puisque c’est tout simplement des Mambots retravaillés.

    Le premier Effects v1.0.0 est l’assemblage de :
    • Xtypo
    • Jogadgets
    • ReflectionJP


    Le second Effects – Pack de boutons v1.0.0 est la reprise du Mambot « VisualClinic JoGadgets Image Editor Buttons Pack » et est donc un pack de boutons pour Effects.

    Effects comprend donc 26 effets (d’où le pack de boutons) à apporter à vos textes en passant de l’insertion d’images (avec ou sans reflet) au lecteur vidéo jusqu'au petit effet Web 2.0 apporté les balises Xtypo.

    Pourquoi ce mambot ?
    • Tout simplement parce que j’utilise tous ces mambots et que j’en ai marre d’en avoir 15 à installer à chaque fois que j’installe un Joomla.
    • Mais tout cela est venu d’une discussion (brève) avec Opware2000 au sujet « Easy eXtended Gallery », où je lui demandais la différence avec Jogadgets. Sa réponse fût que son mambot n’était pas une usine à gaz. Et c’est là que je me suis dis que moi j’aimais les usines à gaz où l’on a tout à portée de la main. Voilà vous avez toute l’histoire.


    Bref ce serait vraiment cool si vous pouviez tester et faire le retour des bugs (ce qui n’est pas facile à repérer seul).

    Merci d’avance pour votre participation et aide.

    Les liens :
    Effects v1.0.0
    Effects – Pack de boutons v1.0.0
    Dernière édition par basileusxp à 13/07/2007, 15h09

  • #2
    Envoyé par basileusxp Voir le message
    Salut,

    alors voilà je vous mets ces plugins (Mambots) qui n’apportent pas
    grand chose de nouveau, puisque c’est tout simplement des Mambots retravaillés.

    Le premier Effects v1.0.0 est l’assemblage de :
    • Xtypo
    • Jogadgets
    • ReflectionJP

    Le second Effects – Pack de boutons v1.0.0 est la reprise du Mambot « VisualClinic JoGadgets Image Editor Buttons Pack » et est donc un pack de boutons pour Effects.

    Effects comprend donc 26 effets (d’où le pack de boutons) à apporter à vos textes en passant de l’insertion d’images (avec ou sans reflet) au lecteur vidéo jusqu'au petit effet Web 2.0 apporté les balises Xtypo.

    Pourquoi ce mambot ?
    • Tout simplement parce que j’utilise tous ces mambots et que j’en ai marre d’en avoir 15 à installer à chaque fois que j’installe un Joomla.
    • Mais tout cela est venu d’une discussion (brève) avec Opware2000 au sujet « Easy eXtended Gallery », où je lui demandais la différence avec Jogadgets. Sa réponse fût que son mambot n’était pas une usine à gaz. Et c’est là que je me suis dis que moi j’aimais les usines à gaz où l’on a tout à portée de la main. Voilà vous avez toute l’histoire.

    Bref ce serait vraiment cool si vous pouviez tester et faire le retour des bugs (ce qui n’est pas facile à repérer seul).

    Merci d’avance pour votre participation et aide.

    Les liens :
    Effects v1.0.0
    Effects – Pack de boutons v1.0.0
    Salut,

    merci pour ce travail, certains membres vont pouvoir tester ces bots et sans doute donner en retour les résultats de tests.
    Proposes ton travail à cet endroit http://www.joomla.fr/contact/Equipe_Joomla.fr.html

    bye
    j!lm
    http://www.joomlabox.com

    Commentaire


    • #3
      Merci Pyor,

      J'ai fait ce que tu m'as dis de faire.

      Commentaire


      • #4
        salut chouette initiative en tout cas je teste toute suite
        Témoignages, Formations, sur la pratique du logiciel libre sur : http://www.aveclelibre.info

        Commentaire


        • #5
          @helloz

          lorsque j'insere une balise {rjp monimage.gif}, celle ci apparaît bien, mais j'ai droit à un message au dessus du post:
          Notice: Undefined variable: mosConfig_live_site in /var/www/monsite/mambots/content/effects.php on line 252

          alors j'ai essayé d'écrire directement la variable qui va bien dans la fonction, et pareil...

          d'où cela pourrait-il bien venir ?

          P.S: joomla 1.0.13 fr.
          merci
          Joomla powered Domino:DomimoD
          Un emploi en Lorraine ?:www.adh.fr
          Geek ?:BlueGeek

          Commentaire


          • #6
            bon, je viens de passer le register global sur on et ca a fonctionné, mais l'image n'a pas du tout de reflet !

            j'ai repassé sur off le register global et l'image reste bien là, mais toujours pas de reflet...
            Joomla powered Domino:DomimoD
            Un emploi en Lorraine ?:www.adh.fr
            Geek ?:BlueGeek

            Commentaire


            • #7
              Oups en "effects"

              J'avais fait une petite erreur de frappe mais ceci est réparé dans cette mise à jour disponible ici :

              http://downloads.joomlacode.org/frsr..._v1.0.1_fr.zip

              Pour cette nouvelle version deux possibilités :

              Mise à jour :

              Pour n'effectuer qu'une mise à jour il faut télécharger le nouveau package à l'adresse ci dessus. Il faut prendre le fichier effects.php et le mettre dans le dossier "/mambot/content/" et remplacer l'ancien : soit en utilisant un logiciel ftp soit en utilisant JoomlaXplorer (ou extplorer).

              Nouvelle installation :
              pour une nouvelle installation il vous suffit de dés installer l'ancienne puis de réinstaller cette version.

              Dans les deux cas le Mambot "Effects - Pack de boutons V1.0.0" reste utilisable car il n'y a pas de nouvelle balise, mais simplement la correction de ce petit bug.

              Merci Kerozen pour ce retour.

              NB : en principe d'ici la fin de la semaine devrais sortir la version 1.1.0 de "Effects" avec l'intégration notamment de Icontent, mais aussi de une ou deux autres petites fonctions bien sympathique. Ce qui entrainera alors obligatoirement la mise à jour du pack de bouton qui passera en 1.1.0 lui aussi.

              Voila n'hésitez pas à vraiment me dire s'il y a des problèmes.

              Commentaire


              • #8
                Whouaaa, quelle réactivité dis donc...si mon équipe pouvait réagir comme ca, je partirai en vacances plus tôt...

                tiens, tu veux pas te mettre à développer gmaccess par hasard ? ;-)
                Joomla powered Domino:DomimoD
                Un emploi en Lorraine ?:www.adh.fr
                Geek ?:BlueGeek

                Commentaire


                • #9
                  Alors, je viens de remplacer le fichier effect.php et l'image a bien sa reflection maintenant...

                  mais, parce qu'il y a un mais....je me retrouve de nouveau avec le message d'erreur comme quoi la variable mos_config_live_site est indefinie ligne 252.

                  bref, j'ai ajouté ca dans effect.php:

                  Code:
                  function botreflectionjp_replacer ( &$matches ) {
                  	global $mosConfig_absolute_path, $mosConfig_live_site, $database;
                  	$thisParams = explode("|",$matches[1]);
                       //parameters instructions
                  	 // if (sizeof($thisParams) != 2) return "Not enough parameters! You must have 3 parameters separated by \"|\" : e.g. {rjp image|300px}";
                      //parameters
                  	$img = $thisParams[0];
                  	$float = $thisParams[1];
                  	//$width = $thisParams[2];
                  	
                  	$img = "$mosConfig_live_site/images/stories/$img";
                  	$imgurl = "<img style=\"float:$float;margin:5px;\" class=\"reflect\" src=\"$img\" alt=\"image\"  hspace=\"5\" vspace=\"5\" />";
                  	return $imgurl;
                  	}
                  puis fermé la session ouverte sur mon site, vidé les caches des navigateurs et rouvert le site...

                  dadadammmm , tout est ok !
                  Joomla powered Domino:DomimoD
                  Un emploi en Lorraine ?:www.adh.fr
                  Geek ?:BlueGeek

                  Commentaire


                  • #10
                    OK OK Kerozen

                    tu me conseil donc d'insérer ca dans mon code moi je veux bien mais pourquoi faire stp?

                    "global $mosConfig_absolute_path, $mosConfig_live_site, $database;" cette ligne a a définir les variables de joomla?

                    Quand à ma réactivité (merci) elle ne demande qu'a être exploitée (c'est les vacances)...

                    Commentaire


                    • #11
                      non, je te demande pas d'ajouter ca, je suis pas assez doué en php ni même sur la config joomla en général pour te demander ça.

                      sur mon site, ça semble fonctionner si je rajoute cette ligne (dailleurs, seule la variable $mosConfig_live_site serait utile), mais ce n'est peut être qu'un hasard.

                      peut être que le simple fait de vider le cache de mon navi suffit, mais j'en suis pas sûr.

                      la variable est définie dans la config de joomla et tu appele bien les variables dans ton script, mais bizarrement, chez moi ca merdouille (et juste sur cette fonction en plus, les autres, pas encore essayé...)
                      Joomla powered Domino:DomimoD
                      Un emploi en Lorraine ?:www.adh.fr
                      Geek ?:BlueGeek

                      Commentaire


                      • #12
                        Dernière version intégrant l'ajout de Kerozen c'est là :
                        http://downloads.joomlacode.org/frsr..._v1.0.3_fr.zip

                        Commentaire


                        • #13
                          C'est uniquement pour dire que la version 1.1.2 de Effects est sortie ainsi qu'un nouveau pack de boutons le tout est disponible ici :

                          http://joomlacode.org/gf/project/effects/frs/

                          Commentaire


                          • #14
                            balises ne fonctionnant pas sous IE

                            Bonjour,

                            Je viens de tomber sur ce post... et j'espère être tombée sur les bonnes personnes pour avoir une réponse à ma question postée

                            Merci d'avance pour votre aide
                            ClickOnCollies

                            Commentaire


                            • #15
                              reflet image

                              yep
                              quand je met le bot pour afficher le reflet d'une image, l'image n'apparait pas entièrement ...
                              une fois la page rafraichie tout est ok...

                              des infos ... ?

                              Merci
                              Ciao

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X