Editer un article : aperçu

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Editer un article : aperçu

    j'ai le message suivant :
    Notice: Undefined variable: basePath in c:\program files\easyphp1-8\www\administrator\includes\auth.php on line 21

    Warning: main(/../../configuration.php): failed to open stream: No such file or directory in c:\program files\easyphp1-8\www\administrator\includes\auth.php on line 21

    Fatal error: main(): Failed opening required '/../../configuration.php' (include_path='.;C:\PROGRA~1\EASYPH~1\\php\pear\') in c:\program files\easyphp1-8\www\administrator\includes\auth.php on line 21


    Merci de me dépanner

  • #2
    Notice: Undefined variable: basePath in c:\program files\easyphp1-8\...

    Salut William.

    Pareil pour moi lors de l'upload d'une image dans un article....
    Un message identique apparaît dans le popup qui devrait me permettre de browser....

    Bon ok, celà ne t'aide pas,... mais dis toi déjà que tu n'est pas le seul

    Commentaire


    • #3
      pareil pour moi

      Hello tout le monde,

      je decouvre le monde joomla et voici mes premiers messages d'erreurs lorsque je cliques sur apercu ou upload d'un article!

      Code:
      Warning: require() [function.require]: open_basedir restriction in effect. File(/../../configuration.php) is not within the allowed path(s): (/home/httpd/vhosts/teamsas.net/subdomains/pascal/httpdocs:/tmp) in /home/httpd/vhosts/teamsas.net/subdomains/pascal/httpdocs/administrator/includes/auth.php on line 21
      
      Warning: require(/../../configuration.php) [function.require]: failed to open stream: Operation not permitted in /home/httpd/vhosts/teamsas.net/subdomains/pascal/httpdocs/administrator/includes/auth.php on line 21
      
      Fatal error: require() [function.require]: Failed opening required '/../../configuration.php' (include_path='.:/usr/share/pear') in /home/httpd/vhosts/teamsas.net/subdomains/pascal/httpdocs/administrator/includes/auth.php on line 21
      J'espere que vous pourrez m'aider,

      merci!

      Commentaire


      • #4
        Alors j'ai cherché partout, forums, faq's des different sites et rien..

        Quelqu'un de competent pourrait il nous aider svp ce serait gentil car actuellement je ne peux profiter de ce portail...


        Merciiiii

        Pour + de details je viens regulierement voir si une reponse est postée ou bien sur msn: sasdarkange@hotmail.com

        Commentaire


        • #5
          Une solution ?

          Une solution possible :

          Editez le fichier :

          /administrator/includes/auth.php

          vers la ligne 20 vous avez :

          Code PHP:
          //$basePath     = dirname( __FILE__ );
          require( $basePath '/../../configuration.php' ); 
          il suffit de supprimer la mise en commentaire de la premiere ligne, et avoir :

          Code PHP:
          $basePath     dirname__FILE__ );
          require( 
          $basePath '/../../configuration.php' ); 
          Cette modification est basée sur la revision 4801 du 28 Aout 2006 du fichier auth.php
          qui est dispo sur la forge

          http://forge.joomla.org/integration/...y1002&view=log

          Commentaire


          • #6
            Merci très efficace

            Commentaire


            • #7
              apparemment l'astuce fonctionne, merci bcp!

              Mais j'ai un autre probleme, j'ai inserer dans l'article une image assez grande...quand je publie l'article, cette image ne devrait elle pas etre reduite automatiquement?

              pour ceux qui veulent voir: http://pascal.teamsas.net/

              Merci de votre aide!

              Commentaire


              • #8
                help

                Personne n'a une petite idee?

                Merci à vous...
                Dernière édition par Pascal28 à 16/09/2006, 14h07

                Commentaire


                • #9
                  merci a toi lexel, j'ai cherché cette réponse durant longtemps

                  Commentaire


                  • #10
                    Salut,
                    y a du mieux, mais maintenant j'ai ça :
                    Code:
                    Vous n'êtes pas autorisé(e) à accéder à cette ressource.
                    Vous devez vous connecter.
                    @ +
                    Snoopy44

                    Commentaire


                    • #11
                      Bonsoir,

                      merci Snoopy44 de m'avoir aiguillé ici!!! Etant débutant avec joomla, j'ai beau chercher mais je trouve pas

                      "Editez le fichier :

                      /administrator/includes/auth.php"



                      Merci de votre aide!

                      @+

                      Commentaire


                      • #12
                        meme soucis

                        après correction du fichier auth.php j'arrive au même affichage
                        "Vous n'êtes pas autorisé(e) à accéder à cette ressource.
                        Vous devez vous connecter"
                        qq'un aurait il la solution?, j'ai de plus un soucis avec l'affichage des bannieres, est ce que ça peut être lié?

                        merci
                        www.casamape.info
                        Dernière édition par casamap à 14/10/2006, 11h58
                        Ma-Caravane, Le Portail du caravaning

                        Commentaire


                        • #13
                          Salut,

                          Il y a deux sujet qui abordent le même probleme (upload & Aperçu d'un article), mais la solution possible été postée ici par Lexel.
                          Je ne l'avais pas encore signalé, mais j'avais aussi ce problème.

                          La solution proposée par Lexel, fonctionne en partie chez moi.
                          C'est à dire que lorsque je suis dans la backend et que j'edite un article déjà existant, le popup "Upload" s'affiche et je peux voir aussi l'Aperçu de l'article
                          Par contre pour la création d'un Nouvel Article, là tout comme vous, j'ai le message (pour l'aperçu et/ou l'upload):
                          Vous n'êtes pas autorisé(e) à accéder à cette ressource.
                          Vous devez vous connecter.
                          Dernière édition par Thalyn à 22/10/2006, 16h52

                          Commentaire


                          • #14
                            Salut à tous,

                            J'ai eu le même pb après la modif de auth.php a savoir le message suivant :

                            Code:
                            Vous n'êtes pas autorisé(e) à accéder à cette ressource.
                            Vous devez vous connecter.
                            En fait je me suis aperçu que mon hebergeur acceptait l'accès au site de 2 facons : avec ou sans les www

                            Le probème venait du fait que j'etais connecté en admin avec l'adresse avec "www" et que l'adresse de mon site que j'avais enregistré lors de l'install était sans "www".

                            Donc en me connectant à la page d'admin sans "www" tout a fonctionné correctement.

                            A+

                            Commentaire


                            • #15
                              Envoyé par Thalyn Voir le message
                              Salut,

                              Il y a deux sujet qui abordent le même probleme (upload & Aperçu d'un article), mais la solution possible été postée ici par Lexel.
                              Je ne l'avais pas encore signalé, mais j'avais aussi ce problème.

                              La solution proposée par Lexel, fonctionne en partie chez moi.
                              C'est à dire que lorsque je suis dans la backend et que j'edite un article déjà existant, le popup "Upload" s'affiche et je peux voir aussi l'Aperçu de l'article
                              Par contre pour la création d'un Nouvel Article, là tout comme vous, j'ai le message (pour l'aperçu et/ou l'upload):
                              Une solution temporaire qui a marché pour moi avec la solution de lexel... lors de la création du nouvel article cliquez sur appliquer et ensuite la fonction upload marche....
                              Dernière édition par AlphaDesign à 16/11/2006, 14h29
                              Templates Joomla sur mesure & responsive http://alphadesign.fr/creation-de-sites-templates-joomla-responsive.html
                              Formations Joomla http://alphadesign.fr/services/formations-joomla.html
                              Formations Joomla conventionnées: DIF et autres formations continues.
                              Checklist SEO pour Joomla http://alphadesign.fr/joomla/checklist-seo-pour-joomla-referencement-joomla.html

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X