Un lien interne dans un article

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Un lien interne dans un article

    Salut,

    Voila mon problème; tout d'abord j'aimerais que les liens de mon site apparaissent comme suit:
    http://127.0.0.1/section/categorie/mon_article.html
    Seulement chez moi c'est sous cette forme:
    http://127.0.0.1/index.php?option=co...d=41&Itemid=49

    J'ai entendu dire qu'il y avait une manipulation à faire pour arriver au résultat que j'attend, seulement je n'arrive pas à mettre la main dessus.

    Ah en fait, pour l'instant je travail en local.

    J'aimerais aussi creer un lien interne depuis un article qui menne vers un autre article, mais j'ai une question:
    Une fois que j'aurais éffectué les changements necessaire pour avoir du .html, mon lien sera changer lui aussi automatiquement ou dois je le faire manuellement après.

    Je ne sais pas si j'étais claire .

    En tout cas merci à vous tous pour vos efforts.

    Electra.
    Les secrets d'Adsense révélés

  • #2
    Alors ce que tu veux c'est réecrire tes urls, pour qu'elle soit plus joli. il y a des composants qui font ca. genre OpenSEF et bien d'autre.

    Apres pour créer ton lien vers un autre article, il me semble qu'il te faudra mettre l'url, que tu avais avant la réecriture d'url.

    Commentaire


    • #3
      Merci Schum encore une fois .
      Est ce que openSEF fonctionne en local?
      Les secrets d'Adsense révélés

      Commentaire


      • #4
        Open SEF devrait marcher en local je pense !!! (Il existe aussi ARTIO JoomSEF)

        Sinon pour tes liens internes essaye de voir avec l'éditeur d'article JCE Editor et avec le plugin Advanced Link comme ca tu pourras insérer un lien vers n'importe quel article de ton site !!!

        Je te file le lien :

        http://www.cellardoor.za.net/

        Prends la version 1.0.4 !!!


        ++
        JoomlaSite Integrateur

        Commentaire


        • #5
          Merci Gonado pour ta réponse.
          Je viens de telecharger et installer OpenSEF, seulement ca ne marche pas en plus c'est anglais. Ca me donne des liens sous cette forme, http://127.0.0.1/content/category/45/32/ qui menne nulle part .
          En plus il y a beaucoup de truc que je ne comprend pas dans la configuration.
          Il n'y a pas de composant moins compliqué que OpenSEF?
          En fait Gonado, est ce que ARTIO JoomSEF est en francais et moins compliqué??

          Merci enore une fois.
          Les secrets d'Adsense révélés

          Commentaire


          • #6
            Artio JoomSEF est en anglais dans l'administration !!!
            Est ce que tu as bien activé le SEF de Joomla (Dans site->configuration du site -> SEO) URLs Explicites (SEF) sur Oui ???

            Et ensuite as tu bien renommé ton htaccess.txt en .htaccess à la racine de ton site ?

            Sinon perso je préfére Artio JoomSEF !!! Simple à mettre en place !!!

            ++
            JoomlaSite Integrateur

            Commentaire


            • #7
              Envoyé par gonado Voir le message
              Et ensuite as tu bien renommé ton htaccess.txt en .htaccess à la racine de ton site ?
              Je n'arrive pas a rennomer htaccess.txt en .htaccess car je suis en local et windows ne le permet pas. Une solution?
              Les secrets d'Adsense révélés

              Commentaire


              • #8
                Bon , j'ai rèussis à renommer le htaccess.txt mais maintenant quand je veut entrer dans mon site ou dans la console d'admin ca me donne un message d'erreur "500 internal server error" .
                Dernière édition par Electra à 19/11/2006, 15h04
                Les secrets d'Adsense révélés

                Commentaire


                • #9
                  Aucune idée??
                  Les secrets d'Adsense révélés

                  Commentaire


                  • #10
                    C'est normal il faut que tu renommes ton htaccess.txt en .htaccess et la ca devrait marcher.

                    Si ca ne marche pas il y a beaucoup de post qui traite de ce problème, fait une recherche avec htaccess et tu devrais trouver les réponses a tes questions.

                    Voila bonne continuation.

                    Commentaire


                    • #11
                      C'est bien ce que j'ai fait mais j'ai une erreur "500 Internal error" .
                      J'ai cherché et j'ai trouvé quelques réponses seulement je n'arrive pas a comprendre.
                      SVP aidez moi.
                      Dernière édition par Electra à 19/11/2006, 16h51
                      Les secrets d'Adsense révélés

                      Commentaire


                      • #12
                        SVP si quelqu'un a une solution à me donner je lui en serai très reconnaissante.
                        J'en ai les larmes au yeus, j'ai essayé toutes les possibilitées mais le resultat reste toujours le même.
                        Si quelequ'un est en local et utilse joomsef avec success, pourrait il me filer son .htaccess pour voir si sa fonctionne chez moi et comme ca ecarter cette piste et voir ailleur.
                        SVP je suis vraiment bloqué, je ne peu pas passer à autre chose si je ne résoud pas ce problème. Heeeeeeeeeeeeeeeeelp

                        Merci et désolé pour le dérangement.
                        Dernière édition par Electra à 19/11/2006, 20h42
                        Les secrets d'Adsense révélés

                        Commentaire


                        • #13
                          Ha oui ca peut aussi venir de ton apache. Pour regler ton problème, si tu as EASYPHP 1.8 :
                          tu click droit sur le E : tu va dans configuration => apache et tu decommente ces 2 lignes la :

                          AddModule mod_rewrite.c

                          LoadModule rewrite_module modules/mod_rewrite.so

                          Pour decommenter tu retire le # devant.

                          Sur Wamp, ca doit etre a peu pres similaire sauf que c'est directement des lignes à cliquer. J'ai jamais tester.

                          Commentaire


                          • #14
                            Bon beih là on avance, effectivement ces modifications m'ont permis de ne plus avoir de message d'erreur. Cependant il reste un autre problème. Quand je clique par exemple sur accueil ou tout autre lien dans ma page d'accueil ca ne mênne null part, par exemple http://127.0.0.1/section/3.html ménne vers "http 404 page non trouvé".
                            Dois je encore faire une autre manip?
                            En tout cas merci Schum pour la petit astuce .
                            Les secrets d'Adsense révélés

                            Commentaire


                            • #15
                              Est-ce que tu as bien mis dans la configuration général du site => SEO => URLs explicites (SEF): mettre oui ? c'est bon.

                              Sinon je n'ai jamais eu de problème comme ca, ca me parrait bizarre. Peut etre des problèmes de chemin. Moi j'utilisais OpenSEF, mais ca devrait pas venir de ca.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X