Joomladay francophone 2018 à Paris 18 et 19 mai

Tri et affichage des articles

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Tri et affichage des articles

    Bonjour,

    J'utilise Joomla 1.5
    J'ai un soucis pour organiser une des pages du site que je suis en train de monter:
    Je voudrais que cette page affiche, façon blog, tous les articles d'une certaine catégorie ("nouvelles" par exemple).
    J'ai donc paramétré le lien dans mon menu en "Articles d'une catégorie donnée en blog", je sélectionne la bonne section/catégorie dans le panneau "Paramètres Basiques", je règle les paramètres #Principal, #intro, colones, #liens, me semble-t-il correctement d'apres tous les posts que j'ai consulté sur le sujet (à savoir 1, 2, 2, 10 pour afficher un article sur la largeur de ma page, puis 2 sur 2 colonnes et les 10 suivants en liens).
    J'ai aussi modifié les options dans "Paramètres avancés" et "Paramètres de composant" pour enlever tout ce qui m'est inutile.

    Le problème est que lorsque je vais sur la page en question, les articles sont les uns à la suite des autres sur toute la largeur de la page. Ils ne respectent pas les paramètres que j'ai saisi.
    Cette page se trouve dans un sous menu, je me suis dit que ce sous menu devait hériter des propriétés de son parent, mais son parent est réglé sur "Un article" et je n'ai pas les mêmes options....

    Quelqu'un pourrait-il éclairer ma lanterne, merci d'avance à la bonne âme qui me fera partager son savoir
    Dernière édition par Tarto à 02/10/2008, 14h08

  • #2
    La solution est en toi

    Tu as en fait déjà exprimé la solution.
    Il n’y a pas d’héritage d’un menu vers un sous-menu.

    Le raisonnement est le suivant. On applique les paramètres globaux exceptés ceux exprimés dans le menu (ou sous-menu) traité.

    Bonne continuation.

    Commentaire


    • #3
      Merci Allbuster,
      Je viens de comprendre comment fonctionnaient les paramètres globaux (et surtout où les trouver.... bref), mais ç'a n'arrange pas mon petit soucis.. les articles s'affichent toujours les uns en dessous des autres sans respecter les paramètres rentrés dans #principal, #intro et #liens..
      Merci d'avance pour votre aide!

      Commentaire


      • #4
        vérification

        Pour l’hypothèse suivante :

        Menu1
        Sous-menu1
        Sous-menu2


        Tes réglages de « sous-menu1 » sont corrects avec « 1, 2, 2, 10 » pour obtenir ce que tu veux.

        Etant donné que tu parles d’héritage, je subodore que tu as placé ces réglages ailleurs (peut-être en Menu1).

        Après vérification, si tes paramètres sont corrects et au bon endroit, peux-tu nous donner l’url d’exemple ?

        Commentaire


        • #5
          Alors, je suis désolé mais c'est un site que je développe en local et qui ne sera pas en ligne avant d'être terminé..
          Par contre ce que je peux te dire, c'est que les articles sont bien placés dans des balises <div> qui ont une classe qui correspondraient à leur placement sur la page (c'est du style <div class="columnleft_row1"> je ne me rapelle pas très bien et je ne suis pas au boulot pour te mettre le code exact) ce qui voudrait dire que la feuille de style qui est censée faire la mise en page n'est pas liée.
          Saurais tu par le plus grand des hasards pourquoi?
          Dans le pire des cas je referai le fichier css pour replacer tout ça......
          Merci encore pour ton aide!

          PS:
          Le menu est fait comme ceci:
          Menu1 Menu2 Menu3
          sousMenu1
          sousMenu2
          sousMenu3
          et c'est dans Menu3 sousMenu1 que doit se trouver la page avec le "blog". La page liée directement au lien Menu3 (sans sélectionner dans les sous-menus) est en lien avec un article statique (je ne peux donc pas avoir d'héritage de paramètres de l'une sur l'autre, enfin je pense...).
          Je sais pas bien si je suis très clair là..... (et je ne sais pas si ce PS a vraiment une importance..)
          Dernière édition par Tarto à 01/10/2008, 19h59

          Commentaire


          • #6
            Bon et bien c'est réglé, c'était bien ça, j'avais un peu trop modifié le template à la hache et j'avais fait sauter les lien vers la feuille de style qui gérait l'affichage des articles... tout bête...

            Commentaire


            • #7
              C'est réglé... c'est réglé... c'est vite dit!
              J'ai bien l'affichage des articles qui s'adapte aux différentes colonnes, par contre ça ne respecte absolument pas les paramètres rentrés dans #principal, #intro, colonnes et #liens.... je conserve les réglages "par défaut" (à savoir 1,4,2,xxx) alors que je voudrais 1,2,2,10....
              Il y a quelque chose qui m'échappe, pour sur!
              Je suis dans un sous menu, j'ai essayé cet affichage façon blog dans d'autres endroits de l'arborescence du site et ça fait la même chose... sauf sur la page d'accueil où ça se met bien en forme mais avec de drôles de bugs..(plus de menu, plus de description de catégorie...).
              Help me please!

              Commentaire


              • #8
                recommençons par des choses simples...

                Envoyé par Tarto Voir le message
                ... j'avais un peu trop modifié le template à la hache et j'avais fait sauter les lien vers la feuille de style qui gérait l'affichage des articles... tout bête...
                Juste pour le test: Mettre un des templates Joomla non modifié et voir comment cela se comporte.

                On serait parfois surpris.

                Courage.

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X