Installation LightBox

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Installation LightBox

    Je viens d'installer le mambot lightbox :

    http://www.joomlafrance.org/telechar.../LightBox.html


    Deux petits soucis... ca ne marche pas avec IE (l'image s'ouvre dans un nouvelle fenetre et non en overlay) et l'image de fond (le png qui affiche le gris foncé...) ne s'affiche pas... le site reste donc totalement visible.

    Quelqu'un a des idées sur les raisons?

    Merci beaucoup!
    Frack

  • #2
    Petite maj suite au dernier mambot envoyé plus tard dans la journée...
    Après avoir suivi attention la journée "light box" de joomla.fr, je dirai à premiere vue du dernier mambot envoyé : Magnifique!!

    Par contre je ne saisis pas certaines choses...
    J'installe le mambot, le publie, vérifie quelques réglages et valides.
    Je retourne sur ma home, et OH surprise, la lightbox marche avec les news déjà publiées!! Pas besoin de tag spécial ou autres réglages lors de la publication de news!!

    Sauf que... non!
    En fait, seuls 2 des mes 4 articles publiés en accueil marchent... et seules 2 des images sont redimensionnées...

    Je ne comprends pas pourquoi, j'ai tout essayé (enlever les bordures, ne mettre que des images à partir des URL, etc...) rien à faire.

    Quelqu'un à une idée...? Merci beaucoup!

    Commentaire


    • #3
      Multithumb

      Salut,
      Ben chez moi tout fonctionne sur toutes les images de mes articles, mais bon les images sont en liens externes et pas dans stories, mais je préfère ne l'appliquer que sur certains articles tagués avec {multithumb}.
      Par contre j'arrive pas à trouver comment lui faire afficher toute une série de photos en imagettes et agrandies par la suite....
      J'ai mis une série d'images dans un répertoire...il n'affiche que la première.
      Quelqu'un a une idée du code à insérer...
      Merci pour votre aide et bonne soirée.
      Patrick

      Commentaire


      • #4
        Pour le faire avec plusieurs images depuis un répertoire, pour une gallerie par exemple, j'utilise Joogadgets.

        Tu penses que mon prob provient du répertoire stories ?

        Commentaire


        • #5
          prob. lightbox

          Effectivement je pense que le problème vient peut-être de là, car j'ai essayé avec une image que j'avais mis dans un sous-répertoire dans stories et là cela fonctionne de manière aléatoire.
          Essaie avec un {multithumb}<img src="http://www." /><p> pour voir.Avec dans les réglages du mambot, display only taged contents.
          Désolé de pas pouvoir te donner LA solution mais j'ai pas tout compris.
          Bonne journée.
          Patrick
          Dernière édition par icaro à 02/08/2006, 07h30

          Commentaire


          • #6
            Après quelques échanges avec l'auteur (au passage très gentil et très dispo) nous savons enfin d'ou vient le probleme.
            Le systeme ne va miniaturuser (et donc afficher avec la light box) que les images plus grandes que la taille paramétrée dans la mambot.

            Dans mon cas, j'avais demandé des miniatures de 150 pixels max.
            Or les quelques news qui contenaient des images inférieures à 150 pixels max ne marchaient donc pas!!!

            Pareil pour ceux qui utilisent JA SUbmit. Les news envoyées depuis le frontend, doivent miniaturiser les images à une taille supérieure à celle définie dans la mambot.
            J'avais choisi de redimensionner les images upladés par les membres à 150 pixels, du coup, toutes leurs news n'etaient pas prises en compte par le mambot.

            J'ai passé les réglages du bot à 149 et tout marche!

            PS : Apparemment les news copiées collées depuis Word ne marchent pas.
            Frack

            Commentaire


            • #7
              Bonjour,

              j'ai telechargé Multithumb ici > http://www.joomlafrance.org/Les_News...ur_Joomla.html

              je l'ai installé sur mon site et j'ai mis les codes d'activation dans head (avant </head>) comme ecrit dans la page de l'auteur ici > http://www.huddletogether.com/projects/lightbox2/


              Part 1 - Setup

              1. Lightbox 2 uses the Prototype Framework and Scriptaculous Effects Library. You will need to include these three Javascript files in your header (in this order).

              <script type="text/javascript" src="js/prototype.js"></script>
              <script type="text/javascript" src="js/scriptaculous.js?load=effects"></script>
              <script type="text/javascript" src="js/lightbox.js"></script>

              2. Include the Lightbox CSS file (or append your active stylesheet with the Lightbox styles).

              <link rel="stylesheet" href="css/lightbox.css" type="text/css" media="screen" />

              3. Check the CSS and make sure the referenced prev.gif and next.gif files are in the right location. Also, make sure the loading.gif and close.gif files as referenced near the top of the lightbox.js file are in the right location.



              mais l'effet LightBox ne marche pas

              j'ai hesité ou mettre cette ligne car mon template utilise le template_css.css et style1.css du coup je l'ai mis dans les deux et meme dans /template/index.php

              j'ai suivi la methode de Frack et de ce site http://www.kreacom.dk/mambots/multithumb.html

              mais tjr rien

              ya quand meme un style qui marche : Thumbnail expansion : il agrandit l'image dans la même page, ce qui prouve les paramètres sont bons, mais pour quoi le lightBox ne marche pas ?

              Aidez-moi s'il vous plait. ou indiquez moi un com ou mod joomla qui utilise cet effet.

              je n'ai pas besoin d'une galerie d'image mais juste agrandir les images de mes articles avec cet effet.

              merci à la communauté

              Commentaire


              • #8
                salut à tous,

                pour vous aider, j'ai moi aussi galéré à l'installer (je suis novice ds joomla), enfin surtout à le faire marcher !

                ce qu'il faut savoir - multithumb ne marche pas quand :
                • -les images sont déjà présentes ds vos articles AVANT l'installation de Multithumb, remettez vos images d'artices à jour (mosimages)
                • -le grand problème que Frack a eu : certaines images marchent, d'autres s'affichent en grandes - 2 choses :
                1. le format mini de votre miniature (preferences du mambot multithumb), expliqué plus haut par Frack
                1. le NOM de votre image ! ni accents, ni espaces, ni MAJUSCULES (pourtant normalement les MAJ ça pose pas de soucis, mais là si !!!), donc vérifier que votre image est bien écrite et ça ira !!


                voilà après tout ça de bien vérifié ça devrait marcher !


                Sinon, moi j'ai un soucis, mais je suis en train de chercher sur le net actuellement, j'espère trouver, mais si qqun passe par là et qu'il a la soluce... je n'arrive pas à mettre de Légende/Titre a mon pop-up lightbox, il me met soit 'image 2 of 6' par exemple, soit rien (si l'image ne fait pas partie d'un groupe) ... pourtant je remplis le champ Alt et Title dans le {mosimage} de l'article ... ça marche pour la légende DANS mon site, mais pas l'image cliquée... http://candarchitectes.net/architect...=41&Itemid=130

                mon mail : olivier.lolmede [at] gmail.com

                merci je vous kiffe

                Commentaire


                • #9
                  it's ok !

                  Bon en fait, j'ai installé une version plus récente (2.0 qqch) et ça marche niquel.
                  J'avais la version téléchargeable depuis le site Joomla, mais en fait sur le site du créateur du Multithumb, des version splus récentes sont dispos, voilà qui est fait ! merci quand même

                  Commentaire


                  • #10
                    Lighbox Joomla

                    Bonjour, je suis vraiment novice dans l'utilisation de joomla, et je suis un peu perdu quand à l'utilisation de ce plugin. J'ai réussi à l'installer sur Joomla, mais pour l'utiliser dans un article, c'est une autre histoire. Si quelqu'un pouvait me décrire brièvement étape par étape comment l'insérer dans un article joomla, cela me serait d'une grande aide !

                    Merci à tous.

                    Chaf'

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X