Image devant le lien d'un menu

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Image devant le lien d'un menu

    Bonjours à vous,


    Je suis en train (ou du moins j'éssaye) de créer un site avec des divers tutorials & co.
    Je suis débutant dans le monde de joomla et j'ai un petit probleme (pour moi s'en et un gros ) donc je m'explique :


    Je viens de réaliser un menu avec divers catégories et je souhaiterais y affiché une image différente devant chaque lien de ceux-ci.


    Donc pour cela, (par rapport à mon image) je vais dans le "Gestionnaire de Modules [ Site ]" => "Les tutoriaux" => et enfin j'active "Afficher Icone"

    Ensuite, apres avoir définie une image par "catégories" j'ai ce petit probleme : je voudrait que chaque image s'affiche devant le lien et non pas au dessus (est-ce un "bug" ?)
    J'ai bien sélectionné "Gauche" afin que l'image s'affiche sur la gauche mais au lieux de ça cela me l'affiche au dessus (et si je sélectionne droite cela me l'affiche en dessous )

    Quelq'un serait t'il me dire comment résoudre ce probleme ? faut t'il faire une modification dans mon thème ou est-ce un réglage à faire dans la partie admin ?
    (que je n'ai toujours pas trouvé au bout de 3 heures malgrés de nombreuses recherches)




    Merci beaucoups d'avance, Romain

  • #2
    Tu regarde la partie de ton template, qui gère tes boutons, et tu mets a cet endroit ton image en background. ca devrait fonctionner.

    Commentaire


    • #3
      Salut, je voie ce que tu veut dire mais cela me permetrait de mettre qu'une seul image dans mon menu mais le soucie c'est que j'aimerais avoir des images différentes devant chaque liens (dreamweaver = image dreamweaver, image photoshop = ... )


      Bref la partie admin a l'air de gérer ça mais j'en revient donc au probleme de positionnement de l'image gérée dans la partie admin (ce n'est pas une image que j'ai placé dans mon fichier theme.php)

      Commentaire


      • #4
        Re, Bon en fin de compte c'est peu etre moi qui t'ai pas comprit (je patoge, je patoge... )

        J'ai cherché dans le fichier "splitmenu.php" et "index.php" s'il y aurait pas quelque chose du style <br> en trop sans succes :-(

        quelqu'un pourait m'expliquer en langage newbie ce que je doit / essayer de faire s'il vous plait ?

        Commentaire


        • #5
          tu pourrais mettre ton template et ton index.php s'il te plait que l'on puisse regarde. pasque dire comme ca, on va un peu repondre au hasard.

          Commentaire


          • #6
            Alors, voila le lien du template complet original : http://www.rokin-zone.info/lazone/247shock_blue_452.zip

            (http://www.mamboteam.com)


            Fichier Index.php
            Code:
            <?php defined( "_VALID_MOS" ) or die( "Direct Access to this location is not allowed." );$iso = split( '=', _ISO );echo '<?xml version="1.0" encoding="'. $iso[1] .'"?' .'>';?>
            
            
            <head>
            
            <?php mosShowHead(); ?>
            
            <meta http-equiv="Content-Type" content="text/html;><?php echo _ISO; ?>" />
            
            <?php if ( $my->id ) { initEditor(); } ?>
            
            <?php include($GLOBALS['mosConfig_absolute_path']."/templates/247shock_blue_452/splitmenu.php"); ?>
            
            <?php echo "<link rel=\"stylesheet\" href=\"$GLOBALS[mosConfig_live_site]/templates/$GLOBALS[cur_template]/css/template_css.css\" type=\"text/css\"/>" ; ?><?php echo "<link rel=\"shortcut icon\" href=\"$GLOBALS[mosConfig_live_site]/<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/favicon.ico\" />" ; ?>
            
            <link rel="alternate" title="<?php echo $mosConfig_sitename; ?>" href="<?php echo $GLOBALS['mosConfig_live_site']; ?>/index2.php?option=com_rss&no_html=1" type="application/rss+xml" />
            
            </head>
            
            
            
            <body background="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/back.png">
            
            <a name="up" id="up"></a></div>
            
            <table width="774" border="0" align="center" cellpadding="0" cellspacing="0">
            
              <tr>
            
                <td valign="top"><table width="774" height="0" border="0" cellpadding="0" cellspacing="0">
            
                  <tr>
            
                    <td rowspan="2" align="left" valign="top"><img src="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/head_left.jpg" /></td>
            
                    <td valign="top"><table width="718" height="39" border="0" cellpadding="0" cellspacing="0" background="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/head.png">
            
                      <tr>
            
                        <td valign="top"><div align="left" class="date"><?php echo mosCurrentDate(); ?></div></td>
            
                        <td align="right" valign="top"><?php if (mosCountModules('user3')) { ?><table border="0" cellpadding="0" cellspacing="0" style="margin-top: 7px; margin-right: 5px;">
            
                          <tr>
            
                            <td width="8"><div style=" background-image:url(<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/top_left.gif); text-align:right">
            
            				<img src="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/top_left.png" style="filter:Alpha(opacity=55, finishopacity=6, style=2)" width="8" height="26" border="0"></div>
            
            				</td>
            
                            <td valign="top" style="background-image: url(<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/top_back.png); background-position: right;"><?php mosLoadModules ( 'user3' ); ?></td>
            
                            <td width="8"><img src="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/top_right.png" width="8" height="26" /></td>
            
                          </tr>
            
                        </table><?php } ?></td>
            
                      </tr>
            
                    </table></td>
            
                    <td rowspan="2" align="right" valign="top"><img src="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/head_right.jpg" /></td>
            
                  </tr>
            
                  <tr>
            
                    <td valign="top"><table width="718" height="152"  border="0" cellpadding="0" cellspacing="0" background="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/head_center.jpg">
            
                      <tr>
            
                        <td valign="top"><table width="718" border="0" cellpadding="0" cellspacing="0">
            
                          <tr>
            
                            <td width="234" height="100" style="padding-left: 8px;" class="title" ><a href="<?php echo $mosConfig_live_site;?>" title="<?php echo $mosConfig_sitename; ?>"><?php echo $mosConfig_sitename; ?></a></td>
            
                            <td width="468" align="right" style="padding-right: 8px;"><table width="468" border="0" align="right" cellpadding="0" cellspacing="4">
            
                              <tr>
            
                                <td><?php mosLoadComponent( "banners" ); ?>
            </td>
            
                              </tr>
            
                            </table></td>
            
                          </tr>
            
                          <tr>
            
                            <td colspan="2">
            
            
            
            <!-- BEGIN MENU -->
            
            			<div><?php echo $mycssPSPLITmenu_content; ?></div>
            
            <!-- END MENU -->
            
            			<div class="pathway"><?php mosPathWay(); ?></div>
            
            				</td>
            
                          </tr>
            
                        </table></td>
            
                      </tr>
            
                    </table></td>
            
                    </tr>
            
                </table></td>
            
              </tr>
            
              <tr>
            
                <td valign="top"><table width="774" border="0" cellpadding="0" cellspacing="0" background="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/back_content.png">
            
                  <tr>
            
                    <td align="left" valign="top"><img src="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/left_line.png" width="8" height="141" /><br /></td>
            
                    <td width="758" valign="top"><table width="100%"  border="0" cellspacing="0" cellpadding="0" style="padding-left: 15px; padding-right: 15px;">
            
                      <tr>
            
                        <td><table width="100%"  border="0" align="center" cellpadding="0" cellspacing="0">
            
                          <tr>
            
                            <td valign="top" style="border-right: 1px solid #DADDD0;"><?php if (mosCountModules('left')) { ?>
            
                                <table width="180"  border="0" cellpadding="0" cellspacing="0">
            
                                  <tr>
            
                                    <td style="padding:5px;"><?php mosLoadModules ( 'left' ); ?></td>
            
                                  </tr>
            
                                </table>
            
                                <?php } ?></td>
            
                            <td style="padding-left: 5px; padding-right: 5px; padding-top:5px; border-left: 1px solid #FFF; border-right: 1px solid #FFF;" width="100%" valign="top"><table width="100%"  border="0" cellspacing="0" cellpadding="0">
            
                                <tr valign="top">
            
                                  <?php if (mosCountModules('top')) { ?>
            
                                  <td colspan="3">
            
                                    <div>
            
                                      <?php mosLoadModules ( 'top' ); ?>
            
                                      
            
            </div></td>
            
                                  <?php } ?>
            
                                </tr>
            
                                <tr>
            
                                  <?php if (mosCountModules('user1')) { ?>
            
                                  <td valign="top"><div>
            
                                      <?php mosLoadModules ( 'user1' ); ?>
            
                                  </div></td>
            
                                  <td width="2" valign="top">
            
                                    <?php } ?>
            
                                    <?php if (mosCountModules('user2')) { ?>
            
                                  </td>
            
                                  <td valign="top"><div>
            
                                      <?php mosLoadModules ( 'user2' ); ?>
            
                                  </div></td>
            
                                  <?php } ?>
            
                                </tr>
            
                                <tr>
            
                                  <td height="4" colspan="3"><table width="100%"  border="0" cellspacing="0" cellpadding="0">
            
                                      <tr>
            
                                        <td><img src="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/space.gif"  width="100" height="4" /></td>
            
                                      </tr>
            
                                  </table></td>
            
                                </tr>
            
                                <tr align="left" valign="top">
            
                                  <td colspan="3"><?php mosMainBody(); ?></td>
            
                                </tr>
            
                                <tr>
            
                                  <td colspan="3"><table width="100%"  border="0" cellspacing="0" cellpadding="0">
            
                                      <tr>
            
                                        <td><img src="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/space.gif"  width="100" height="4" /></td>
            
                                      </tr>
            
                                  </table></td>
            
                                </tr>
            
                                <tr valign="top">
            
                                  <?php if (mosCountModules('user6')) { ?>
            
                                  <td colspan="3">
            
                                    <div>
            
                                      <?php mosLoadModules ( 'user6' ); ?>
            
                                  </div></td>
            
                                  <?php } ?>
            
                                </tr>
            
                              </table>
            
                                </td>
            
                            <td valign="top" style="border-left: 1px solid #DADDD0;"><?php if (mosCountModules('right')) { ?>
            
                                <table width="180"  border="0" cellpadding="0" cellspacing="0">
            
                                  <tr>
            
                                    <td style="padding: 5px;"><?php mosLoadModules ( 'right' ); ?></td>
            
                                  </tr>
            
                                </table>
            
                                <?php } ?></td>
            
                          </tr>
            
                        </table></td>
            
                      </tr>
            
                    </table></td>
            
                    <td align="right" valign="top"><img src="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/right_line.png" width="8" height="141" /></td>
            
                  </tr>
            
                </table></td>
            
              </tr>
            
              <tr>
            
                <td valign="top"><table width="774" height="46" border="0" cellpadding="0" cellspacing="0" background="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/bottom.png">
            
                  <tr>
            
                    <td align="center" valign="top"><img src="<?php echo $mosConfig_live_site;?>/templates/247shock_blue_452/images/space.gif"  width="46" height="46" border="0" usemap="#Map" /></td>
            
                  </tr>
            
                </table>
            
                  <table width="774" border="0" cellpadding="0" cellspacing="10" class="footer">
            
                    <tr>
            
                      <td valign="top">            <div align="center">
            
                            <?php include_once('includes/footer.php'); ?>
                      </div></td>
            
                    </tr>
            
                  </table></td>
            
              </tr>
            
            </table>
            
            <br />
            
            <map name="Map" id="Map">
            
              <area shape="circle" coords="25,23,12" href="#up" alt="Top!" />
            
            </map>
            
            </body>
            
            </html>
            Dernière édition par rokin-k à 23/10/2006, 22h15

            Commentaire


            • #7
              Image devant le lien du menu

              Hello !

              J'ai le même souci.
              L'image s'affiche sur la ligne qui précède l'item du menu et non pas directement devant ...

              Serait-il possible de savoir comment le problème a été résolu ?

              MERCI BCP !
              Ciao

              Commentaire


              • #8
                UP !!
                Le meme probleme !
                c'est dans le mod_mainmenu qu'on peut corriger ce problème mais jais pas trouver encore la solution. je tien a précisé que ce problème existe dans tous les templates par-défaut dans joomla.

                voila en plus clair :
                le menu affiche toujours les icones comme suite :

                au lieu de ça :



                pourriez vous nous aider ?
                Fichiers joints

                Commentaire


                • #9
                  Problème résolue.
                  voila la solution :
                  dans le fichier modules\mod_mainmenu\helper.php
                  Ligne 297
                  ajouter ce qui est en rouge :
                  Code:
                  if ($params->get('menu_images') && $iParams->get('menu_image') && $iParams->get('menu_image') != -1) {
                  $image = '<img src="'.JURI::base(true).'/images/stories/'.$iParams->get('menu_image').'" alt="'.$item->alias.'" align="middle" />';
                  if($tmp->ionly){
                   $tmp->name = null;
                  }

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X