Joomladay francophone 2018 à Paris 18 et 19 mai

Plus de menus dans l'admin

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Plus de menus dans l'admin

    Bonjour à tous,

    Dans la partie admin, je n'ai plus de menu en haut de la page.

    Cela n'est vraiment pas pratique. Je dois présenter ce site en fin de semaine et je ne peux plus travailler. SVP aider moi...

    Comment retrouver mes menus en admin?

    Merci d'avance
    Dernière édition par nextoo à 05/10/2007, 14h21 Raison: La solution a été trouvée par Doyle

  • #2
    Regarde dans ton fichier configuration.php s'il n'y a pas d'erreur notemment dans le chemin absolu ($mosConfig_absolute_path) et le reste.

    J'ai eu ce problème il y a quelques jours et c'étaient là

    Commentaire


    • #3
      Envoyé par nextoo Voir le message
      Bonjour à tous,

      Dans la partie admin, je n'ai plus de menu en haut de la page.

      Cela n'est vraiment pas pratique. Je dois présenter ce site en fin de semaine et je ne peux plus travailler. SVP aider moi...

      Comment retrouver mes menus en admin?

      Merci d'avance
      Vide les caches et autres cookies de ton navigateur, ça m'est déjà arrivé !

      Commentaire


      • #4
        Envoyé par lelensois2000 Voir le message
        Vide les caches et autres cookies de ton navigateur, ça m'est déjà arrivé !
        Cela n'a rien changé. Mais merci quand même c'est cool d'essayer de m'aider.

        Commentaire


        • #5
          Envoyé par webart Voir le message
          Regarde dans ton fichier configuration.php s'il n'y a pas d'erreur notemment dans le chemin absolu ($mosConfig_absolute_path) et le reste.

          J'ai eu ce problème il y a quelques jours et c'étaient là
          Ok je vais essayer ça se soir la c'est la bourre...

          Merci pour le conseil.

          A +++

          Commentaire


          • #6
            J'ai regarder dans configuration.php mais tout à l'air correct... Merci quand même.

            Une autre idée???

            Commentaire


            • #7
              Bonjour,
              je relance ce topic (qui me semble être le plus récent traitant de ce problème de menu fantôme) car je rencontre moi même ce souci : la barre de menu déroulant du menu admin s'est volatilisée.
              J'ai tenté les solutions proposées sur le forum, sans succès à savoir :
              -vider les caches.
              -vider puis restaurer les données initiales de la table components dans MySql.
              -vérifier le path dans le fichier de configuration.

              Quelqu'un aurait-il une idée relative à ce bug plutot handicapant ?

              d'avance merci.
              Doyle.

              Commentaire


              • #8
                Okay. C'est bon pour moi, plus la peine de s'arracher le cuir chevelu (il m'aura tout de même fallu deux jours).

                Le problème est le suivant : le code de Joomla! ne supporte pas la présence de quotes ' dans les titres des catégories ou des sections, car il n'y a aucun dispositif mis en place pour déspécialiser les caractères spéciaux dans les champs issus de la base : résultat des courses, une chaine comme "Dossier de l'\urbanisme" est vue dans le code comme 'Dossier de l' urbanisme. la chaine se retrouve incomplète et le tableau dans lequel sont rangé les titres de sections (et qui sert notamment à mettre en place le menu) s'en retrouve tronqué et inutilisable. Le menu n'apparait plus. CQFD.
                Il serait utile de mettre en place une fonction de contôle de la saisie, qui prévient l'utilisateur que l'usage de caractères spéciaux est impossible, lorsqu'il saisit son titre de section (ou toute autre information susceptible de causer ce genre de bug dailleurs). le temps de développement n'est pas très conséquent (allez, 1h si je suis très large) et ça éviterait à certains menus de se faire la malle en pleine utilisation.

                Note : le dump que j'avais effectué aurait du résoudre le problème, il s'est avéré qu'il était trop récent et contenait donc déjà des informations non compatibles

                Commentaire


                • #9
                  Plus de main menu dans l'admin

                  Bonjour à tous,

                  J'ai voulu mettre un article directement en lien dans le main menu et plouf, plus rien ne s'affiche ! Quand je clique sur mainmenu la page est desesperement vide !

                  J'ai carrément viré l'article en question, la section et la catégorie...
                  Mais rien n'y a fait.

                  Merci d'avance pour votre aide !

                  Commentaire


                  • #10
                    Résolution du problème

                    Ok
                    Ayant carrément flippé de la disparition du gestionnaire du menu, j'ai emplyé les grands moyens.

                    J'ai été dans phpmyadmin et j'ai jeter les liens qui posaient problème.

                    Du coup le gestionnaire est réapparu.

                    J'ai pas l'explication. Mais j'ai trouvé une solution, c'est déjà ça !

                    Commentaire


                    • #11
                      Salut

                      Je me permets de revenir à mon problème. lol

                      J'arrive toujours pas à retrouver la barre de menu dans le template d'administration.

                      SVP aider moi... Merci

                      Commentaire


                      • #12
                        L'explication à cette disparition de menu est simple : l'une des lignes que vous avez saisie dans la base de données n'est pas supportée par vtiger.
                        La solution la plus radicale à ton problème : réinitialiser la Bdd. Mais c'est un peu dommage tu perdras toutes tes données.

                        Va dans la table "components" et vérifie que ce n'est pas un composant que tu as installé qui n'a pas supporté une mise à jour, n'hésite pas à supprimer les lignes avec des caractères un peu glauques (se méfier des quote). procède bien entendu à une sauvegarde de ta base telle quelle avant toute manipulation douteuse et restaure les anciens paramètres en cas de problème.
                        Si tu ne trouves rien de probant, vérifie les titres de toutes tes catégories/sections et procède de la même manière.

                        Le plus sur moyen d'identifier le problème est d'installer FireBug, et de charger la page d'accueil du menu d'administration. Si quelque chose ne va pas dans le chargement de ce menu (comme dans mon propre cas, voir mon post précédent), il te le signalera et t'indiqueras la ligne à problème, tu pourras alors aller corriger le tout dans la base de données sans plus de dégat.

                        M'est avis que la prochaine version de Joomla! devrait se pencher sur le problème, d'autant qu'il est techniquement très simple à résoudre

                        Commentaire


                        • #13
                          Super merci pour la réponse détaillé et précise. Ca c'est du bon...

                          Je vais tester tout ca...

                          Commentaire


                          • #14
                            Mon problème venait d'une catégorie. Pourquoi une catégorie bloque-t-elle les menus de l'admin??? No sais...

                            Se qui compte, c'est que ca marche.

                            Merci à tous

                            Commentaire


                            • #15
                              J'ajoute ma contribution :

                              Après avoir copieusement rammé pour trouver d'où venait le problème en tenant compte de vos pistes, je me suis rendu compte (par comparaison avec un autre site en Joomla totalement fonctionnel) qu'il me manquait une table dans ma base de donnée (54 aux lieux de 55). Il s'agissait de jos_components.


                              Vive le code qui marche ;-)

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X