Transmenu

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Transmenu

    Bonjour à tous

    J'utilise Transmenu...

    Mais j'ai trois problèmes avec...

    1: Les menus déroulants ne s'affiche pas dans IE...
    2: Les menus lorsque qu'il passe sur une zone d'input. Le imput masque le texte...
    3: Peut on avoir un css de menu par template...

    Ou si aucune solution command avoir des menus déroulants sur les menus standard qui eux ne me pose aucun problème de look selon le template utilisé!

    Merci de m'aider...
    Dernière édition par fraise à 11/04/2006, 15h38 Raison: compléments d'information
    Kung roland rené

  • #2
    Suite

    j'ai trouver cela en allemand pour le probleme avec IE malheureusement cela reste du chinois pour moi...

    MBT Transmenu: Internet Explorer zeigt keine Submenus
    Moin Moin,

    ich hab da auf einer neuen Homepage ein Problem mit dem Transmenu Modul:
    In Firefox werden die Submenüs richtig angezeigt (schließen sich zwar nicht wieder, aber das ist ein anderes, hier schon diskutiertes Thema), aber im Internet Explorer kommt gar nichts. Kein Fehler, keine Zuckung, rein gar nichts. Die Seite lautet:
    http://jtest.myleibniz.de/

    Ich wäre euch dankbar, wenn ihr mir bestätigen könntet, dass es auch mit euren Internet Explorern nicht geht (oder aber mich korrigieren). Und natürlich wäre ich dankbar, wenn einer mir Hilfestellungen geben kann ;-)

    Die wichtigsten Transmenu-Dateien habe ich angehängt.

    EDIT: Diesen Hinweis hier habe ich gefunden, aber ich werde nicht schlau daraus. Falls einer weiß, was damit gemeint ist, bitte sagen ;-)
    Zitat:
    TRANSMENU HORIZONTAL NOT EXPANDING IN INTERNET EXPLORER (IE) BUT IN FIREFOX IT DOES:

    SOlution: I had to play around for a couple of hours but then I found the reason why TRANSMENU was not expanding in Internet Explorer.

    I put out every ""ALIGN"" HTML Command of my table-data, behind the "

    Merci de m'aider....
    Kung roland rené

    Commentaire


    • #3
      essaye deja de traduire avec l'outil linguistique de google,
      c'est certe pas parfait, mais peut te permetre de trouver un début de réponse
      ROMERO Pascal
      http://www.as-hainneville.fr/ (avec entre autre SportingEvents)

      Commentaire


      • #4
        pas un iota

        La traduction de google n'a pas le mérite de clarifier la situation...

        Déjà que lorsque l'on parle en français on se comprend pas toujours, alors là?

        Kung roland rené

        Commentaire


        • #5
          Le probleme de transmenu qui ne s'affiche pas avec IE , peut venir de ton template.

          J'ai eu le meme probleme avec mon site. j'ai du bidouiller dans le template pour que sa fonctionne.

          Tu peut regarder la j'ai mis la soluce
          http://forum.joomla.fr/showthread.ph...ight=transmenu
          mais si tu n'a pas le meme template que moi?????
          kidney beans version joomla 1.0.8
          Composants:Akobook plus + Sécurity images , BBclone , Ponygallery , Remository , Silex Vidéo.
          Modules: Ja-Transmenu. Mambots: Dynamic image , Nicetitles.

          Commentaire


          • #6
            Un merci de taille!

            Ton lien à été trés utile, comme quoi on est plusieurs à ramer avec le même type de problème...

            Effectivement la simple supression left_outer et wihth 165 px est suffisant pour que IE si retrouve...

            Bien, bien, bien...

            Voilà pour le problème le plus enbètant! Un GRand Merci...

            Maintenant je peux penser à mon second problème majeur...

            Le input qui masque mon menu lorsque celui lui passe dessus...

            Et le problème numéro 3 le plus important...

            Je voudrais changer de couleur à mes menus lorsque je change de template...

            En bref j'ai mis dans mon site plusieurs template de couleur différents un peu comme le site JOOMLA

            Est je veux faire correspondre la couleur de mon menu avec mon template...

            Deux piste possible avoir plusieurs template pour transmenu...
            Ou alors définir quelle image affilié avec transmenu selon le templates sélectionné...

            Quelqu'un de capable en PHP pourrait-il me répondre svp..!
            Dernière édition par fraise à 12/04/2006, 13h41
            Kung roland rené

            Commentaire


            • #7
              La ca va un peu trop loin pour moi.

              Moi en Codage PHP
              kidney beans version joomla 1.0.8
              Composants:Akobook plus + Sécurity images , BBclone , Ponygallery , Remository , Silex Vidéo.
              Modules: Ja-Transmenu. Mambots: Dynamic image , Nicetitles.

              Commentaire


              • #8
                Suite



                Merci tous de même, je sais c'est être exigeant, mais je crois que cela est bien pour la communuté...

                En attends une réponse à mes autres questions en voilà une qui devrait pas être trop difficile...

                Toujours dans transmenuv.css

                J'ai #wrap { color: #FFFF00; } c'est à dire mes séparateurs de menus en jaune... standard...

                Trés bien sous Mozilla et sous IE cela ne fonctionne pas et je retrouve mes séparateur dans la couleur du texte de mon body; c'est à dire noiir! Sur fond noir ca c'est pas sympa pour la lecture...

                Quesqu' y foire...??? HELP HELP HELP
                Dernière édition par fraise à 12/04/2006, 13h42
                Kung roland rené

                Commentaire


                • #9
                  J'ai également un paramètre du CSS qui est interprété que par Mozilla et pas par IE.

                  C'est la couleur du texte d'un sous-menu lorsque le pointeur passe dessus...

                  Je ne sais pas d'où ça vient.

                  J'ai aussi essayé de mettre de l'opacité lorsque que le pointeur est sur un sous-menu et là des fois l'item disparait carrément !

                  Commentaire


                  • #10
                    Well

                    Je souffre pour toi...

                    Le gros problème que je constate, depuis que je fonctionne sous Joomla... avec la découverte du PHP, je vois aujourd'hui de quel manière microsoft à pourri ces développements...

                    Dans Mozilla et par conséquent Firefox, on à semble t'il respecter un cahier des charges précis en programmation... Alors que tu passe un paramêtre à ces browsers ils y répondent instantanément et sans surprise... Alors que dans IE et je te promets que même pour simplement redimensionner les menus c'est aux petits bohneur la chance, tant les paramêtres que je passe ne veulent rien dire... Le tatonnement et une possibilité, mais en terme de temps c'est du délire... Moi, pour m'en sortir j'ai une copie de la version original de mon css... et lorsque je modifie un élément, je le commente dans le css, afin de voir quel influence il a réellement, et c'est vrai que sur IE cela ne correspont souvant à rien et que sur mozilla à chaque modif, j'ai un résultats instantané et je ne doute pas qu'il en soit de même sur mac...

                    Alors que faire, une bonne dose de patience, et l'espoir que de plus malin que nous nous aide à nous en sortir et en attendant un peu de méthodologie et beaucoup de courage...

                    Salut et bonne chance... Mais n'abandonne pas car je crois que transmenu en vaut la peine... En tous cas trés joli et pratique sous Mozilla... Plus on sera à s'accrocher, plus de solutions apparaîtrons!!!


                    P.s.: Imagine aussi que pour moi l'anglais et comme lire l'arabe... Donc sans doc francaise, je touche je regarde... Si on parle de communauté francaise, ceux qui parle anglais, ceux qui parle informatique oublie souvant, que certain son limité... Et cela n'aide en rien de nous parler comme à des êtres intelligents, quand vaut mieux un exemple, qu'un long discourt! Comme moi en ce moment!
                    Dernière édition par fraise à 13/04/2006, 09h29
                    Kung roland rené

                    Commentaire


                    • #11
                      salut à tous,

                      bon, pour ce qui est de Transmenu j'avais mis un bout de temps pour le configuré et enfin de compte je l'avais viré, trop de bug/incompatibilité

                      j'en ai trouvé un autre qui marche bien, en tout cas pour l'instant il est ici http://www.swonline.biz/index.php?op...electcat&cat=3

                      note : vous allez voir la différence tout de suite, la configuration se fait en 2 sec

                      en ce que concerne 1 menu par template qui serait en accord avec le template en question, le seul moyen à ma connaissance c'est de le faire avec les moyens de bord de joomla (mainmenu + css), ça prends plus de temps certe mais c'est possible

                      cordialement
                      Agence web Joomla www.nartconcept.fr spécialisée en création de sites Joomla professionnels http://www.nartconcept.fr/services.html
                      RT3 Framework : www.rt3.fr pour Joomla 1.7.x & 2.5

                      Commentaire


                      • #12
                        Envoyé par nart
                        salut à tous,

                        bon, pour ce qui est de Transmenu j'avais mis un bout de temps pour le configuré et enfin de compte je l'avais viré, trop de bug/incompatibilité

                        j'en ai trouvé un autre qui marche bien, en tout cas pour l'instant il est ici http://www.swonline.biz/index.php?op...electcat&cat=3

                        note : vous allez voir la différence tout de suite, la configuration se fait en 2 sec

                        cordialement
                        Il a l'air vraiment bien ce composant !

                        Mais pourquoi, quand je le mets dans le top, j'ai 2 menus qui s'affichent.... ??
                        Dernière édition par crevaille à 13/04/2006, 11h45

                        Commentaire


                        • #13
                          Je vais le tester

                          Merci à toi...

                          Pour ce lien, qui je l'espère tiendra ces promesses...

                          Pour ce qui est de mainmenu, je suis prêt avec des config différentes pour chaque template...

                          Mais je ne peux avoir de popup (ou je ne sais pas) et pour moi cela est essentielle...
                          Kung roland rené

                          Commentaire


                          • #14
                            salut,

                            pour la question de fraise :

                            le popup = nouvelle fenêtre? si oui c'est possible, cela se passe dans les paramètres de(s) lien(s), clique sur un lien dans la "gestion de menu" et tu verras

                            maintenant à toi crevaille :

                            faut dépublier "Top menu", pour ce faire faut aller dans "Modules - Modules du site -> Top menu"

                            cordialement
                            Agence web Joomla www.nartconcept.fr spécialisée en création de sites Joomla professionnels http://www.nartconcept.fr/services.html
                            RT3 Framework : www.rt3.fr pour Joomla 1.7.x & 2.5

                            Commentaire


                            • #15
                              Je suis newbee mais pas autant que ça...

                              Il est dépublié, mais ce qui est bizarre, c'est que publié ou non (Top Menu donc), j'ai un 2ème menu qui apparait !

                              J'ai donc traffiqué le code de mon template et j'ai mis en commentaire cette ligne

                              Code PHP:
                              echo "<td width='$tab_width%' align='center'><a class='buttonbar' href='$row->link&Itemid=$row->id'>$row->name</a></td>"
                              Je ne comprends pas pourquoi je dois modifié le code de mon template (mody_chrystal) !

                              Une idée ?
                              Dernière édition par crevaille à 13/04/2006, 12h32

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X