Joomladay francophone 2018 à Paris 18 et 19 mai

Menus déroulants ne voulant pas dérouler

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Menus déroulants ne voulant pas dérouler

    .

    Bon, j'ai vogué un moment sur le présent forum, j'ai été voir chez nos amis les allemands, j'ai aussi lu plein de messages en anglais (oui, je suis béni, je sais...) mais je ne parviens pas à trouver une réponse claire et unanime.

    Il s'agit des menus déroulants. Dans mon TOP-MENU j'ai bien les section qui sont arborifiées avec leurs catégories comme je le souhaite, mais sur le menu de la page les catégories ne se déroulent pas quand on effleure le bouton...

    Le template Artisteer 2 que j'utilise montre bien cette fonction lorsqu'on l'édite, mais sur le site : niet !

    Je me doute bien que c'est dans la gestion des menus ou similaire qu'il faut règler comme il faut. J'ai aussi cliqué sur dérouler, mais je ne sais plus où. Je cherche tellement que je crois que l'arbre me cache la forêt...

    Où peut-être y a-t-il une subtilité qui m'échappe ?

    Je continue à chercher en attendant une réponse...

    Merci par avance.

    El Do...
    Dernière édition par El Dominisuisso à 29/06/2009, 01h01

  • #2
    Bonjour,
    cherche du coté de :
    > paramètre style de menu (dans le module de menu)
    > suffixe de classe (fouille dans les css du template) si tu vois des _menu, des -nav...
    > un bug d'Artisteer
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Presque...

      Bonsoir Grand Schtroumpf...

      merci de ta réponse. J'ai bien trouvé la case "suffixe css" : tant dans les paramètres système de l'élément menu que dans le paramètres avancés du module "Top menu". Dans le second cas j'ai effectivement trouvé des extensions "_menu" et "-nav". Je les ai supprimé. Mais cela ne change rien...

      C'est d'ailleurs aussi dans les paramètres avancés du module que j'ai coché "oui" à "dérouler menu". D'après tout ce que j'ai pu lire c'est ce qu'il y a à faire.

      Chez les allemands ils semblaient dire qu'il fallait installer une extension (jpc ? jrc ??? je ne retrouve plus) mais je n'ai pas trouvé la suite.

      Maintenant si il y a des bugs qui se promènent je suis pas prêt de trouver. Mais dans 99,999% des cas c'est toujours et encore moi le bug... ha ha.

      Tiens, je te laisse une feuille de salsepareille pour demain matin. Moi je vais dormir...


      .

      Commentaire


      • #4
        .

        PAS SI VITE !!! JE VIENS DE TROUVER !!!


        J'allais cliquer sur "éteindre" quand... soudainement... LA LUMIERE !!

        Alors :

        Allez dans le menu principal "Extensions" - "Gestion des modules"

        Puis cherchez dans la liste des modules celui qui vous intéresse (en l'occurrence "Top Menu", les boutons du haut de page). Cliquez pour éditer le module.

        Dans la partie de droite, "Paramètres du module" vous devez cliquer "oui" pour l'option "Toujours afficher les sous-menus".

        Voilà. Je savais que c'était un arbre qui me cachait la forêt...

        Je vais de ce pas changer le statut du message : réglé !

        El Dominisuisso

        Commentaire


        • #5
          j'utilise JA Purity, et j'ai beau règlé les paramètres comme vous mo,n menu s'affiche verticalement et tous les sous menu affichés dès le départ?????

          Ça ménerffffffe
          "aide toi le forum t'aidera"
          laurentbony.com

          Commentaire


          • #6
            Bonjour,
            avec JA_purity, il faut le -nav dans le suffixe de classe...
            Schtroumpfe toi le Schtroumpf t'aidera.
            Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins
            Travaille ...
            X