Problème de caractères accentués avec Shoutbox

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Problème de caractères accentués avec Shoutbox

    Bonjour,

    Je tient à vous faire par d'un problème que je rencontre avec le pack shoutbox (COM et MOD) : Il n'est pas possible d'untiliser les caractères accentués, ils apparaissent ainsi dans la shoutbox :
    "c'était quel logiciel sur lequel nous avons réalisé des montages video? svp"

    Quelqu'un a-t-il déjà rencontré ce problème, et surtout comment le résoudre ? Je sais que les messages sont stocké dans une table jos_shoutbox de la base de donnée, mais il y sont stocké sous la forme ci-dessus ... Pourtant il me semble que la BDD à été créée correctement, et tous mes articles sont correctements accentués, même après avoir fini la migration sur le nouveau serveur.
    Pour les personnes qui voudraient tester le problème, l'adresse du site où se situe la shoutbox 'désaccentuante' est la suivante :http://www.projet-akira.info
    Merci d'avance pour votre aide
    Dernière édition par akira_kurosawa à 12/11/2005, 14h08

  • #2
    c'est pareil pour moi, si je trouve une solution je viendrai poster ici ^_^

    edit: dans ton fichier mod_shoutbox.php à la ligne 203, ils te proposent de faire une censure. Ce que tu peux faire, c'est de remplacer les mots à caractères bizarres style "é" par "é"


    Code:
    $jal_user_text = str_replace("é", "é", $jal_user_text);
    $jal_user_text = str_replace("ê", "ê", $jal_user_text);
    etc.. pour savoir ce que pourrais faire un "ü", tu le tapes dans ta shoutbox et ensuite tu copier/coller dans ta ligne de code..

    ps: j'ai pas encore testé mais je le fais ce soir

    edit: voilà j'ai testé avec les caractères "è" et "é"! ca marche maintenant il n'y a plus qu'à faire toute la liste -_-
    Bon je reposterai quand je l'aurai faites (pour les autres utilisateurs)

    edit2: voila! alors ca donne qqch comme ca pour que la shoutbox marche avec les accens J'ajoute que j'ai testé avec "@" et il n'y a pas besoin de l'ajouter ici car la shoutbox le comprend très bien
    Code:
    	$jal_user_text = str_replace("é", "é", $jal_user_text);
    	$jal_user_text = str_replace("è", "è", $jal_user_text);
    	$jal_user_text = str_replace("ü", "ü", $jal_user_text);
    	$jal_user_text = str_replace("ö", "ö", $jal_user_text);
    	$jal_user_text = str_replace("ä", "ä", $jal_user_text);
    	$jal_user_text = str_replace("€", "€", $jal_user_text);
    	$jal_user_text = str_replace("ë", "ë", $jal_user_text);
    	$jal_user_text = str_replace("ï", "ï", $jal_user_text);
    	$jal_user_text = str_replace("ê", "ê", $jal_user_text);
    	$jal_user_text = str_replace("â", "â", $jal_user_text);
    pour tester go ici
    Dernière édition par mayo à 15/12/2005, 17h12

    Commentaire


    • #3
      Je vous propose une autre solution bien plus confortable car il prendra vraiment tout les caractères spéciaux.

      Remplacez à la ligne 211:
      $conn = mysql_connect($host, $user, $pass);
      mysql_select_db($db, $conn);
      Par:
      $conn = mysql_connect($host, $user, $pass);
      mysql_query( "SET NAMES 'utf8'" );
      mysql_select_db($db, $conn);
      Tchao All!
      Les gens pressés sont déjà morts... (Proverbe Berbère)
      [Cl4n-wAw*W4nt 4n0Ther W0rLd*:` http://wAw-team.keewy.org *]

      Commentaire


      • #4
        Merci à vous tous pour ces astuces...
        Tout fonctionne sauf pour le "à"...
        Il apparait dans la shoutbox sous la chaine suivante "Ã ".
        J'ai tenté avec et sans espace après le "Ã", mais çà ne passe pas...
        Une idée ?

        PS : l'astuce du vagabond fonctionne aussi, mais encore une fois pas pour le "à"...

        Commentaire


        • #5
          Ce que tu peux faire alors dans ces cas là tu rajoute la ligne:

          $jal_user_text = str_replace("Ã ", "à", $jal_user_text);
          Les gens pressés sont déjà morts... (Proverbe Berbère)
          [Cl4n-wAw*W4nt 4n0Ther W0rLd*:` http://wAw-team.keewy.org *]

          Commentaire


          • #6
            Merci pour ta réponse ultra rapide Vagabond, mais j'avais déjà testé...
            C'est la seule fois où cette solution ne marche pas.
            Cà fonctionne avec pratiquement tous les autres caractères accentués...
            Bizarre

            Commentaire


            • #7
              J'ai moi aussi eu ce problème et il est résolu. J'ai fait part de mes recherches et des modification effectuées ici :
              http://forum.joomla.fr/showthread.ph...ghlight=accent

              Commentaire


              • #8
                bonjour
                j'ai un problème, inscrite sur le site "un jeu sur le couplé proposé par les rois du couplé".
                sur le forum shoutbox, depuis hier, je n'arrive plus a discuter avec les amis. A chaque fois que j'écris un message, un mot ou une phrase, j'ai un message d'alerte du site web disant: "merci de suprimer les espaces avant ou après" et donc je n'arrive plus a discuter sur ce forum.
                Merci pour ce que vous pouvez faire pour m'aider

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X