Probléme avec mes composants

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Probléme avec mes composants

    Je n'arrive pas a installer mes composants, et aucune autre chose d'ailleur, pourtant, tout et en vert (je veux dire marqué writeable).
    Je ne comprend pas trop pourquoi il ne veulent pas s'installer (j'indique bien le chemin de l'archive zip) ?
    Personne n'aurait une solution, merci d'avance.

    Je le rajoute puisque je l'avais oublié, l'erreur qu'il me met :

    Upload component - Upload Failed
    ERROR: Could not find an XML setup file in the package.
    [ Continue ... ]

    Upload component - Failed
    Installation file not found:
    /home/users/Deathangel/media/install_44467af547dce/
    [ Continue ... ]
    Dernière édition par Arkangel à 19/04/2006, 19h02

  • #2
    Bonjour,
    J'ai exactement le même problème je suis sur SIVIT mutualisé les seuls problèmes que j'ai pu remarquer ce sont les positionnement initiaux où j'ai :
    le safe mode = ON , le register globals = ON et Session save path=/home/tmp non writable
    J'ai donc créer un répertoir sessions mais rien n'y fait je suis incapable d'installer quoi que ce soit sur le site.
    Malgrès plusieurs recherche je n'arrive pas à trouver de réponse. En attendant la solution que j'ai trouvé pour installer quelque chose est de faire l'installation à la main mais c'est pas top
    Quelqu'un pourrait t'il aider
    Dernière édition par scotty à 20/04/2006, 07h06

    Commentaire


    • #3
      Envoyé par Arkangel
      Je n'arrive pas a installer mes composants, et aucune autre chose d'ailleur, pourtant, tout et en vert (je veux dire marqué writeable).
      Je ne comprend pas trop pourquoi il ne veulent pas s'installer (j'indique bien le chemin de l'archive zip) ?
      Personne n'aurait une solution, merci d'avance.

      Je le rajoute puisque je l'avais oublié, l'erreur qu'il me met :

      Upload component - Upload Failed
      ERROR: Could not find an XML setup file in the package.
      [ Continue ... ]

      Upload component - Failed
      Installation file not found:
      /home/users/Deathangel/media/install_44467af547dce/
      [ Continue ... ]
      Bonjour,

      Si tu veux une aide, il faudrait peut-être préciser quel est le composant que tu essaies d'installer (et éventuellement ouvrir le zip pour vérifier le contenu - en effet certains "composants" sont des packages qui doivent être dézippés avant de les uploader)
      ma société : http://pdrevon.xlphp.net

      Commentaire


      • #4
        Bonjour Picpus,
        Je ne sais pas pour Arkangel, mais pour ma part ce sont toutes les installations qui ne fonctionne pas ca marche sur mon pc en EasyPHP mais pas sur le site que j'essaye de gérer

        Commentaire


        • #5
          Merci pour les réponses, mais cela arrive avec tout les composant que je veux installer, je vais aller en essayer plusieur encore, on ne sais jamais, mais sa m'étonnerais.

          Commentaire


          • #6
            J'ai essayé plusieur autre chose, pas que des composants, et ruien n'y fait toujours le même message, personne n'a une solution ?

            Commentaire


            • #7
              salut,
              J'ai bien une solution. Pas belle, ni très pratique mais qui peut rendre temporairement service : tout rappatrier en local, installer ton composant et tout remettre sur le serveur

              A+

              Commentaire


              • #8
                une piste

                Re salut,

                une piste peut-etre, tout en bas ici.

                A+

                Commentaire


                • #9
                  Oula esque tu peux me dire suelque chose de légerement plus claire, et merci.

                  Commentaire


                  • #10
                    Well chuis pas un bon traducteur angliche mais je vais essayer :

                    Written by bogho on 2005-09-15 04:49:48
                    I solved this kind of problem by creating on site a directory "toinstall" and in this directory I copied the php and xml files.
                    That from the administration panel, on install new module i write the entire path to this directory ( /home/sites/my_site/toinstall/ )
                    "Install from directory" text field.
                    than click on the Install button and all its ok.
                    * Etape 1 : Creer un répertoire toinstall à la racine du site
                    * Etape 2 : Dézipper le composant dans ce répertoire
                    * Etape 3 : Dans l'admin, Intaller > Composant
                    * Etape 4 : Dans la zone installation à partir du répertoire, taper le chemin complet du répertoire (chez free par exemple c'est /var/www/sdb/d/8/ton.compte/toinstall)
                    * Etape 5 : Cliquer sur le bouton intallation
                    * Etape 6 : Croiser les doigts

                    Pour bogho, ça a marché. Tiens nous au courant.

                    A+

                    Commentaire


                    • #11
                      Sa marche, merci beaucoup, mais je ne comprend pas pourquoi sa ne marcher pas avant...

                      Commentaire


                      • #12
                        merci pour les réponses,

                        j'ai essayé la solution de PFLG effectivement ca marche mieux l'installation semble créer le premier répertoire d'une structure par exemple fckeditor (mais pour les autres ca semble être la même chose) le répertoire mambots/editors/fckeditor est créer puis il s'arrête en me disant qu'il ne peux pas creer le répertoire editor

                        Il réagit exactement comme si il n'avait pas acces au répertoire qu'il vient de créer

                        C'est je pense le même problème quand je créer un répertoire via l'interface admin gestion des medias j'obtient :

                        Warning: fopen(): SAFE MODE Restriction in effect. The script whose uid is 1112 is not allowed to access /home/local/apache/htdocs/sites/s/suiviperf.com/test/images/test2 owned by uid 2420 in /home/local/apache/htdocs/sites/s/suiviperf.com/test/administrator/components/com_media/admin.media.php on line 115

                        Warning: fopen(/home/local/apache/htdocs/sites/s/suiviperf.com/test/images//test2/index.html): failed to open stream: No such file or directory in /home/local/apache/htdocs/sites/s/suiviperf.com/test/administrator/components/com_media/admin.media.php on line 115

                        Warning: fwrite(): supplied argument is not a valid stream resource in /home/local/apache/htdocs/sites/s/suiviperf.com/test/administrator/components/com_media/admin.media.php on line 116

                        Warning: fclose(): supplied argument is not a valid stream resource in /home/local/apache/htdocs/sites/s/suiviperf.com/test/administrator/components/com_media/admin.media.php on line 117


                        Quelqu'un a t'il une idée ?

                        Commentaire


                        • #13
                          Une derniére question, ou s'instal normalement le mambot, ces le même endroit ou il va s'installer quand on fait comme sa ?

                          Commentaire


                          • #14
                            Salut,

                            @Arkangel :
                            Les mambots s'installent sous ton_site/mambots et dans un sous répertoire différent selon le type de mambot (content pour les mambots qui se déclenche lors du chargement du contenu, search pour les bot lancés lors d'une recherche, editors pour ceux qui servent à proposer un éditeur WYSYWYG,...)
                            Normalement quelque soit la méthode ça doit aboutir au même endroi (sinon ça marcherais pas).

                            @scotty : t'as vérifié les droits d'accès en lecture, ecriture et exécution de tes divers répertoires ?

                            A+

                            Commentaire


                            • #15
                              Bonsoir,

                              les droits sont 775 pour les répertoires et 664 pour les fichiers (anciens et nouveaux fichiers)

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X