.htaccess de joomla 1.0.11 sous OVH

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • .htaccess de joomla 1.0.11 sous OVH

    Bonjour:
    J'essaye d'utiliser le htaccess.txt fournit par Joomla 1.0.11 en le renommant en .htaccess, mais quand je le fait jai une erreur 403.

    J'ai commenter, uncommenter quelques variables a l'interieur de ce fichier (comme indiqué dans le fichier) mais sans success.

    Hors, je viens de trouver un topic chez OVH.fr (mon hebergeur) qui peut etre la source du probleme!
    Ils semblerait qu'il faille reecrire car ovh a un systeme particulier, mais je vous laisse lire:


    extrait: (source: http://guides.ovh.net/HtaccessModRewrite)
    Mod_rewrite est disponible chez Ovh sur l'ensemble des hébergements mutualisés (sauf 20gp).
    En savoir plus: www.engelschall.com/pw/apache/rewriteguide

    Mod_rewrite et Mod_ORT
    ORT (Ovh Redirect Technology) est un module développé par OVH qui nous permet d'héberger un nombre important de sites avec peu de RAM utilisée sur les machines.

    Mod_ort modifie l'URL de la page et vous pouvez donc avoir un problème
    si vous voulez utiliser mod_rewrite. La solution consiste à redefinir dans mod_rewrite la racine de reécriture:

    RewriteEngine on
    RewriteRule ^/grp([0-9]+).php$ groupe.php?id=$1 [L]
    RewriteRule ^/art([0-9]+).php$ article.php?id=$1 [L]
    RewriteRule ^/age([0-9]+).php$ agenda.php?id=$1 [L]
    RewriteRule ^/membre_([0-9]+).php$ membre.php?id=$1 [L]
    doivent être changés en

    RewriteEngine on
    RewriteRule ^/grp([0-9]+).php$ /groupe.php?id=$1 [L]
    RewriteRule ^/art([0-9]+).php$ /article.php?id=$1 [L]
    RewriteRule ^/age([0-9]+).php$ /agenda.php?id=$1 [L]
    RewriteRule ^/membre_([0-9]+).php$ /membre.php?id=$1 [L]

    Exemples d'utilisation:

    - Rediriger automatiquement le visiteur sur le site en ssl quand il visite le site en non sécurisé:
    RewriteEngine on
    Rewritecond %{HTTP_HOST} ^nom_domaine.tld$
    Rewriterule ^(.*) https://ssl5.ovh.net/~login_ftp/$1 [QSA,L,R=301]
    Pour ne passer sur le site sécurisé que pour la consultation d'une page précise:
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^nom_domaine.tld$
    RewriteCond %{REQUEST_URI} ~094/page.php
    RewriteRule ^(.*) https://ssl5.ovh.net/~login_ftp/$1 [QSA,L,R=301]
    Note:
    Pour connaître l'adresse sécurisée de votre plan: SslSurMutu



    Existe til des pros, ou des personnes qui ont le meme soucis (avec le meme hebergeur ou avec le htaccess)?


    edit: j'ai donc essayer de mettre une barre "/" devant index.php dans
    RewriteRule^(content/|component/) /index.php
    et puis dans
    RewriteRule^(.*)$ /index.php [F,L]

    sans success...tjours 403!
    Dernière édition par corsebou à 12/09/2006, 19h32

  • #2
    Edit du 15 Novembre 2006 : Compte tenu du succès inattendu de ce post je le met à jour pour y ajouter la ligne permettant de passer le register_global à off et placer l'identification de session dans le cookie
    Vous pouvez lire les commentaires du fichier pour décommenter/commenter les lignes nécessaires si intégration d'un composant sef.

    Code:
    ##
    # @version $Id: htaccess.txt 4756 2006-08-25 16:07:11Z stingrey $
    # @package Joomla
    # @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
    # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
    # Joomla! is Free Software
    ##
    
    
    #####################################################
    #  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
    #
    # The line just below this section: 'Options FollowSymLinks' may cause problems
    # with some server configurations.  It is required for use of mod_rewrite, but may already
    # be set by your server administrator in a way that dissallows changing it in
    # your .htaccess file.  If using it causes your server to error out, comment it out (add # to 
    # beginning of line), reload your site in your browser and test your sef url's.  If they work,
    # it has been set by your server administrator and you do not need it set here. 
    #
    # Only use one of the two SEF sections that follow.  Lines that can be uncommented
    # (and thus used) have only one #.  Lines with two #'s should not be uncommented
    # In the section that you don't use, all lines should start with #
    #
    # For Standard SEF, use the standard SEF section.  You can comment out
    # all of the RewriteCond lines and reduce your server's load if you
    # don't have directories in your root named 'component' or 'content'
    #
    # If you are using a 3rd Party SEF or the Core SEF solution
    # uncomment all of the lines in the '3rd Party or Core SEF' section
    #
    #####################################################
    
    
    #####  SOLVING PROBLEMS WITH COMPONENT URL's that don't work #####
    # SPECIAL NOTE FOR SMF USERS WHEN SMF IS INTEGRATED AND BRIDGED
    # OR ANY SITUATION WHERE A COMPONENT's URL's AREN't WORKING
    #
    # In both the 'Standard SEF', and '3rd Party or Core SEF' sections the line:
    # RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
    # May need to be uncommented.  If you are running your Joomla/Mambo from
    # a subdirectory the name of the subdirectory will need to be inserted into this
    # line.  For example, if your Joomla/Mambo is in a subdirectory called '/test/',
    # change this:
    # RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
    # to this:
    # RewriteCond %{REQUEST_URI} ^(/test/component/option,com) [NC,OR] ##optional - see notes##
    #
    #####################################################
    
    
    ##Passage register globals off
    SetEnv REGISTER_GLOBALS 0
    
    ## identifiant de session placé dans le cookie
    ##infos - http://www.manuelphp.com/php/ini.session.use-trans-sid.php##
    SetEnv SESSION_USE_TRANS_SID 0
    
    ##  Can be commented out if causes errors, see notes above.
    #Différence avec le fichier original : chez ovh ajouter un + devant FollowSymLinks
    #
    Options +FollowSymLinks
    #
    #  mod_rewrite in use
    
    RewriteEngine On
    
    
    #  Uncomment following line if your webserver's URL
    #  is not directly related to physical file paths.
    #  Update Your Joomla/MamboDirectory (just / for root)
    
     RewriteBase /
    
    
    ########## Begin - Joomla! core SEF Section
    ############# Use this section if using ONLY Joomla! core SEF
    ## ALL (RewriteCond) lines in this section are only required if you actually
    ## have directories named 'content' or 'component' on your server
    ## If you do not have directories with these names, comment them out.
    ######################################################
    #Commentez ces lignes en ajoutant # devant si
    #vous utilisez un composant type opensef 
    #####################################################
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] 		##optional - see notes##
    RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
    RewriteRule ^(content/|component/) index.php
    #
    ########## End - Joomla! core SEF Section
    
    
    
    ########## Begin - 3rd Party SEF Section
    ############# Use this section if you are using a 3rd party (Non Joomla! core) SEF extension - e.g. OpenSEF, 404_SEF, 404SEFx, SEF Advance, etc
    #######################################################
    #décommenter en supprimant les dièses devant les lignes suivantes
    #si vous utilisez un composant type opensef.
    #########################################################
    #RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] 		
    #RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
    #RewriteCond %{REQUEST_FILENAME} !-f
    #RewriteCond %{REQUEST_FILENAME} !-d
    #RewriteRule (.*) index.php
    #
    ########## End - 3rd Party SEF Section
    
    
    
    ########## Begin - Rewrite rules to block out some common exploits
    ## If you experience problems on your site block out the operations listed below
    ## This attempts to block the most common type of exploit `attempts` to Joomla! 
    #                              
    # Block out any script trying to set a mosConfig value through the URL
    RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
    # Block out any script trying to base64_encode crap to send via URL
    RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
    # Block out any script that includes a <script> tag in URL
    RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
    # Block out any script trying to set a PHP GLOBALS variable via URL
    RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
    # Block out any script trying to modify a _REQUEST variable via URL
    RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
    # Send all blocked request to homepage with 403 Forbidden error!
    RewriteRule ^(.*)$ index.php [F,L]
    # 
    ########## End - Rewrite rules to block out some common exploits
    Dernière édition par AniMo à 15/11/2006, 18h45
    Merci d'éviter les demandes de support par MP.

    Commentaire


    • #3
      Envoyé par AniMo
      Celui là marche chez moi avec seo simple de joomla

      cela fonctionne avec ta version...!!

      Je me demande si le fichier htaccess.txt fournit avec joomla 1.0.11 n'est pas ecrit bizarrement:
      J'explique: quand le l'ouvre avec notepad jai un paté de texte (meme avec l'option retour automatique a la ligne), or quand j'utilise word les retour a la lignes sont bien indiques, et le fichier est bien formatté

      Je pense donc que le probleme viendrais du retour a la ligne.. je vais poster un message sur joomla.org pour tenter de voir si c'est logique!
      Merci en tout cas

      Commentaire


      • #4
        Envoyé par corsebou
        cela fonctionne avec ta version...!!

        Je me demande si le fichier htaccess.txt fournit avec joomla 1.0.11 n'est pas ecrit bizarrement:
        J'explique: quand le l'ouvre avec notepad jai un paté de texte (meme avec l'option retour automatique a la ligne), or quand j'utilise word les retour a la lignes sont bien indiques, et le fichier est bien formatté

        Je pense donc que le probleme viendrais du retour a la ligne.. je vais poster un message sur joomla.org pour tenter de voir si c'est logique!
        Merci en tout cas
        Non le probleme est different:
        Jai ouvert le htaccess.txt du fichier 1.0.10>1.0.11 de joomla, et copier coller le "bloc de texte" dans cette endroit ou j'ecrit ce texte, ce qui a eu pour effet de mettre a la ligne automatiquement.
        Jai donc recopier, coller a partir de la vers mon htaccess.txt qui a donc une apparence correcte (retour a la ligne effectues, plus d'aspect de paté).
        Jai uploader le tout dans le folder www et renomer en .htaccess:
        Error 403...

        Donc je n'arrive pas a voir ce qui est different d'avec la version postee plus haut par Animo qui fonctionne parfaitement (ie: j'active son .htaccess et je nai pas d'erreur 403)

        Commentaire


        • #5
          J'ai trouver la difference entre ma version du .htaccess qui me fait error 403 et celle fournit par Animo:


          RewriteBase /
          (le mien etait commente).

          Cependant: jai effectuer un autre modification juste apres avoir utiliser le .htaccess de animo: jai clique sur global configuration , SEO et jai clique sur "Search Engine Friendly URLs:" ( qui a un message davertissemtn: attention ne changez que si vous avez renomez le htaccess.txt en .htaccess).

          Une fois ce parametre de changé jai reassayer avec le htaccess fournit par default de la version 1.0.11 et je suis tres surpris de ne pas avoir eu d'erreur 403!!!!

          Donc le probleme semble venir de la! (ie: de cette case quil faut toucher meme si on n'a pas encore renommer le htaccess.txt de defaut en .htaccess).

          J'espere que ca aide!

          Commentaire


          • #6
            Envoyé par corsebou
            Non le probleme est different:
            Jai ouvert le htaccess.txt du fichier 1.0.10>1.0.11 de joomla, et copier coller le "bloc de texte" dans cette endroit ou j'ecrit ce texte, ce qui a eu pour effet de mettre a la ligne automatiquement.
            Jai donc recopier, coller a partir de la vers mon htaccess.txt qui a donc une apparence correcte (retour a la ligne effectues, plus d'aspect de paté).
            Jai uploader le tout dans le folder www et renomer en .htaccess:
            Error 403...

            Donc je n'arrive pas a voir ce qui est different d'avec la version postee plus haut par Animo qui fonctionne parfaitement (ie: j'active son .htaccess et je nai pas d'erreur 403)
            Probleme classique de format de fichier texte (windows / unix).
            Windows (en fait, heritage de son lointain ancetre, DOS) termine les lignes par 2 caracteres ( CR + LF ). Unix n'a besoin que d'un seul (CR).

            D'ou le texte tout d' un bloc quand tu l'ouvre dans notepad. Pour lui le fichier ne contient qu'un seule ligne puisque il ne trouve que des CR, pas de CR+LF. Je crois que wordpad se comporte mieux.

            Quant tu l'ouvre avec word, je ne sais pas ce qu'il ecrit en plus dans ton fichier mais ce ne doit pas etre tres bon non plus.

            Donc ton fichier .htaccess qui ne marche pas n'est pas dans le bon format pour ton serveur.

            Je te conseillerais bien d'utiliser gvim, mais je suis pas sur que tu vas me benir apres ca . Perso je n'utilise que ca, conjointement a FileZilla, et lui au moins ne m'a jamais pourri un fichier a cause de ca.

            Cordialement,
            Richard.
            Association d'entraide de parents de multiples: http://www.jumeaux-et-plus.fr
            École de Musique de Villers-lès-Nancy: http://www.apm-villers.org

            Commentaire


            • #7
              Envoyé par rcognot
              Probleme classique de format de fichier texte (windows / unix).
              Windows (en fait, heritage de son lointain ancetre, DOS) termine les lignes par 2 caracteres ( CR + LF ). Unix n'a besoin que d'un seul (CR).

              D'ou le texte tout d' un bloc quand tu l'ouvre dans notepad. Pour lui le fichier ne contient qu'un seule ligne puisque il ne trouve que des CR, pas de CR+LF. Je crois que wordpad se comporte mieux.

              Quant tu l'ouvre avec word, je ne sais pas ce qu'il ecrit en plus dans ton fichier mais ce ne doit pas etre tres bon non plus.

              Donc ton fichier .htaccess qui ne marche pas n'est pas dans le bon format pour ton serveur.

              Je te conseillerais bien d'utiliser gvim, mais je suis pas sur que tu vas me benir apres ca . Perso je n'utilise que ca, conjointement a FileZilla, et lui au moins ne m'a jamais pourri un fichier a cause de ca.

              Cordialement,
              Richard.
              Bonjour, merci de la réponse!
              J'ai tout simplement copier coller le fichier htaccess.txt du package 1.0.11 dans cette boite de dialogue pour entrer un nouveau message, il le reformatte automatiquement avec les retours a la ligne, puis j'ai recopier a partir de la et recoller dans le fichier texte...


              Mais je pense plutot c'est qu'il fallait cocher cette option "SEF" dans joomla Global configuration avant de mettre le .htaccess de 1.0.11, meme si le warning disait de ne cocher qua'pres avpoir un .htaccess!

              Commentaire


              • #8
                Pour ma part et en respectant toutes vos consignes les uns et les autres, j'utilise le bloc note basic, j'ai fait un copie coller du code d'ANIMO, j'ai uploadé (sur ovh mutu), et j'ai l'erreur suivante sans plus, j'ai renomé mon txt en .htaccess et hop Erreur 500 :

                "Internal Server Error
                The server encountered an internal error or misconfiguration and was unable to complete your request.
                Please contact the server administrator, tech@ovh.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

                More information about this error may be available in the server error log."

                Si certain d'entre vous y capte kekechose et peuvent m'aider ils sont les bienvenus car n'y connaissant kedal dans ce genre de dev, je dois dire que je m'y perds un peu...
                merci.
                Dernière édition par JossRandall1 à 14/09/2006, 13h09

                Commentaire


                • #9
                  Hm.. aurait tu essayé de mettre le register globals a off dans ce htaccess?

                  Parceque OVH m'avait dit que si j'essayais de mettre le register globals a off grace au htaccess j'aurait une "erreur 500"...

                  Bizarre car j'ai copier le code d'Animo est cela a fonctionné sous Ovh... pas d'erreur 403 ni 500...


                  Peut etre, as tu penser a effacer les fichiers temporaires de internet explorer (ou de ton browser) avant de reessayer?

                  Commentaire


                  • #10
                    ?? je capte pas...j'ai rien dans le fichier htaccess qui se nome "register globals "...et mon cache navigateur est à "0" Mo lorsque je fais des tests, j'ai vidé recommencé et rien...

                    Commentaire


                    • #11
                      Envoyé par jomil
                      ?? je capte pas...j'ai rien dans le fichier htaccess qui se nome "register globals "...et mon cache navigateur est à "0" Mo lorsque je fais des tests, j'ai vidé recommencé et rien...

                      Hello,!
                      Ok...

                      Enfait ce "register globals" n'est pas par default dans le .htaccess...

                      En fait depuis joomla 1.0.11 on recoit des avertissements de securite disant qu'il faut mettre le register globals de php a off, car cela peut etre la source d'attaques faciles par des hackers...

                      Or, en lisant les posts sur la securite, il semble quil y a plusieurs techniques pour le faire:
                      -modifier le php.ini
                      -ou "php.ini override" (= mettre un autre php.ini dans chaque dossiers qui
                      -remplaceront le php.ini de base
                      -utiliser php5 (car cette variable est OFF par defaut)
                      -et enfin: rajouter la commande au .htaccess:

                      php_admin_flag register_globals off

                      Je pensais que cest ce que tu avais fait...
                      Etant donne que chez OVH, je leur avais demander et il mont dit quils ont bloquer cette commande et si on le fait on aurait erreur 500...

                      Commentaire


                      • #12
                        Jomil : dans la configuration générale du site, tu as bien activé le seo?
                        As-tu installé des composants type opensef ou 404sef?
                        Merci d'éviter les demandes de support par MP.

                        Commentaire


                        • #13
                          Envoyé par AniMo
                          Jomil : dans la configuration générale du site, tu as bien activé le seo?
                          As-tu installé des composants type opensef ou 404sef?
                          traduction:
                          SEF= Search Engine Friendly (facilite la prise en charge par les moteurs de recherches)

                          SEO= Search Engine Optoimization
                          (serait ce l'option Site/Global configuration/ Search Engine Optimization
                          Search Engine Friendly URLs: No Yes )

                          j'ai mis des heures avant de comprendre ce que voulait dire SEF et meme en recherchant avec Google j'au eu du mal...
                          une ptite definition fait plaisir parfois!

                          Commentaire


                          • #14
                            Version Htacess

                            Envoyé par jomil
                            j'ai l'erreur suivante sans plus, j'ai renomé mon txt en .htaccess et hop Erreur 500 : "Internal Server Error
                            Je te garantit rien mais ... essaye cette version :

                            RewriteEngine On
                            RewriteBase /

                            RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
                            RewriteCond %{REQUEST_FILENAME} !-f
                            RewriteCond %{REQUEST_FILENAME} !-d
                            RewriteRule (.*) index.php

                            Commentaire


                            • #15
                              Envoyé par corsebou
                              traduction:
                              SEF= Search Engine Friendly (facilite la prise en charge par les moteurs de recherches)

                              SEO= Search Engine Optoimization
                              (serait ce l'option Site/Global configuration/ Search Engine Optimization
                              Search Engine Friendly URLs: No Yes )

                              j'ai mis des heures avant de comprendre ce que voulait dire SEF et meme en recherchant avec Google j'au eu du mal...
                              une ptite definition fait plaisir parfois!
                              Toi, tu sais que je t'aime...

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X