Joomladay francophone 2018 à Paris 18 et 19 mai

Du jour au lendemain...

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Du jour au lendemain...

    J'en ai parlé dans un autre post mais c'est peut être pas la même chose.

    Voila mon problème:
    Hier tout allait bien.
    Ce matin ca ne va plus.

    Quand je me connectes sur l'interface d'administration j'ai cette erreur:



    Je tiens a dire que je n'ai pas touché au site et que c'est venu d'un coup.
    Cela m'empêche d'accéder a l'interface d'administration.

    D'ou ca vient?
    Que faire...?

    merci

  • #2
    il y a une discussion chez les US
    http://forum.joomla.org/index.php/topic,204073.0.html

    un resume vite fait traduit:
    his is not a Joomla! problem per' sai' but is brought about by the hosts configuration, most likely running PHP as an Apache module. This means that PHP scripts have to run under the WebServers user account, hence when you upload something through Joomla! ( or any other Web Based Application ) the uploaded files are owned by the WebServer ( this can be any defined user, but is normally apache or nobody, the numbers you are seeing are the UserID's of this user instead of the name, that is all )
    C'est pas un problème Joomla, mais un problème de configuration serveur

    The interim/temporary fixes are as discussed;

    1. Use JoomlaExplorer, because this runs as the WebServer User account, it gives access to these mis-owned files.
    2. Have your host chmod (change-mode) directories to 777, which is pretty dangerous...
    3. Have your host chown (change-owner) the group to the WebServer User and owner to your account
    then chmod directories 775, and files to 664, which still is not a great fix...
    4. Have your host chown all files and directories to your account and chmod directories to 755, files to 644...
    des suggestions de configuration, mais dans ton cas ....

    Or you could give your host a hard time about re-configuring their server more appropriately for WebBased Applications...
    Apache running PHP in CGI mode, PHP5, and install phpSuExec, which will then allow the WebServer to run temporarily as the users account, negating all these ownership problems.
    Running scripts as the WebServer user ( apache or nobody ) has its own security implications depending on server configuration.

    As for the quoted forum post elsewhere stating that this configuration is insecure, with PHP5, register_globals off and a fair server configuration, this is more secure than running in module mode, with less problems.
    et plus pour toi,
    "explique à ton serveur admin, que c'est urgent, et que fort probablement il y est pour quel'que chose
    et pour ta pomme vérfie , je ne sais pas quand, tes réglages
    PHP5
    register globals off
    et un configuration de serveur "fair" mal traduit hônnete, équilibre entre les différents interêts

    Une traduction vite , mais j'espère pas vraiment mal fait.

    Michael

    Commentaire


    • #3
      Merci beaucoup Mulrich pour ta réponse. Ca fait plaisir qu'on est pas tout seul...
      C'est mon premier site, et tomber face un bug comme ca...

      Le site est chez 1and1. Je sais pas qui c'est mon "serveur admin". Je vais tenter de voir l'assistance de 1and1.

      Ce bug a l'air coriace...En tout cas, je tiens a préciser qu'il est venu d'un coup, sans aucune modification de quoi que ce soit.

      Si y'en a qui ont des idées, n'hésitez pas...

      merci

      Commentaire


      • #4
        st j'avais posé le post de ce problème ce matin ou tu as confirmé les mêmes problèmes, si tu as une reponse de 1&1 pour corriger l'erreur je suis preneur, car moi nom plus je n'ai plus acces à l'admin et c'est embêtant car c'est pour un club de danse et je dois mettre à jour pour les cours.
        sinon je voudrais savoir si je refait une installation complète de joomla en laissant ma base de donné, est ce que je devrais refaire tout complètement ou est ce que les articles seront présents dans la nouvelle installation.
        c'est urgent si qq à une réponse a notre problème.
        eric

        Commentaire


        • #5
          Je me demande si c'est pas du a un problème d'heure.
          Voici le contenu de la ligne 111: (c'est sur une ligne mais la j'ai mis sur 3)

          // if now expired link set or expired time is more than half the admin session life set, simply load normal admin homepage
          $checktime = ( $mosConfig_session_life_admin ? $mosConfig_session_life_admin : 1800 ) / 2;
          if (!$expired || ( ( $now - $expired_time ) > $checktime ) ) {

          Il se pourrais que ce bout de code croie que la durée de la session admin est dépassée et force a se déconnecter.

          Qu'en pensez vous?

          Commentaire


          • #6
            comme t'es chez 1+1, t'as accés a tes logs, par FTP, essayez de lire
            le fichier dans /log
            "acces.log.current"
            et avant mi-nuit, si non il est remis à zero

            Michael

            Commentaire


            • #7
              J'ai reussi a le lire. Merci!
              La dernière connection c'était:
              "83.179.169.255 - - [25/Aug/2007:23:27:53 +0200] "

              Ca doit donc etre bon au niveau de l'heure.

              Commentaire


              • #8
                oublie l'heure, qui à essaye de faire qoui, sur le serveur, à part de toi même

                Commentaire


                • #9
                  J'ai un tres gros fichier...
                  Je vois rien de special.
                  Dernière édition par jpeeg à 25/08/2007, 22h50

                  Commentaire


                  • #10
                    Du jour au lendemain, ca remarche.
                    Je n'ai rien fait et ca remarche.

                    Vraiment bizarre ce truc!

                    Commentaire


                    • #11
                      Moi aussi ce matin ça marche de nouveau tout seul
                      je pense que ça viens de chez l'hebergeur
                      heureusement tout marche car j'avais mis le script dans phpadmin pour changer les login et pass
                      ouf

                      Commentaire


                      • #12
                        A mon avis c'est un problème de fichiers de sessions qui ne pouvaient pas être écrits, 1&1 ont du changé la permission d'écriture dans le répertoire "tmp" et vu que pleins de monde ont eu le même problème, ils ont remis comme avant. C'est juste une supposition. Maintenant, si ce problème persiste, il faut chercher sur le forum comment écrire le fichier de session ailleurs, il y a pleins de personnes qui sont dans ce cas.
                        Yann Sagon
                        Pas de MP pour demande de support!

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X