SEO joomla et OpenSEF(404)

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • SEO joomla et OpenSEF(404)

    Bonjour,

    J'ai un serveur sous joomla 1.0.10 hébergé chez moi sur une sme.

    J'ai installé le composant opensef sans probleme, sauf que les liens vers mes articles me renvois une erreur 404, mais ils sont réécrit de plus les autres liens qui ne sont pas des articles (composant,modules, etc..) restent inchangés, pas de réécriture du lien.

    j'ai désactivé opensef, activé le SEO de joomla et la c'est pire j'ai acces qu'a la page d'accueil, le reste c'est une erreur 404 mais avec les liens renommer aussi .
    ex:
    Not Found
    The requested URL /content/view/22/64/ was not found on this server.

    J'ai bien sur renommer mon .htaccess

    voici ce qu'il contient (j'ai testé avec et sans le slash "/" devant index.php) :


    Code PHP:
    #Options FollowSymLinks

    #
    #  mod_rewrite in use

    RewriteEngine On


    #  Uncomment following line if your webserver's URL
    #  is not directly related to physical file paths.
    #  Update Your Joomla/MamboDirectory (just / for root)

     
    RewriteBase /

    ########## Begin Standard SEF Section
    ## ALL (RewriteCond) lines in this section are only required if you actually
    ## have directories named 'content' or 'component' on your server
    ## If you do not have directories with these names, comment them out.
    #
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
    %{REQUEST_FILENAME} !-d
    RewriteCond 
    %{REQUEST_URI} ^(/component/option,com) [NC,OR]         ##optional - see notes##
    RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
    RewriteRule ^(content/|component/) /index.php
    #
    ######### End Standard SEF Section



    #RewriteCond %{REQUEST_FILENAME} !\.(jpg|jpeg|gif|png|css|js|pl|txt)$
    #RewriteCond %{REQUEST_FILENAME} !-f
    #RewriteCond %{REQUEST_FILENAME} !-d
    #RewriteRule ^(.*) index.php


    ########## Begin 3rd Party or Core SEF Section
    #
    RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]         ##optional - see notes##
    RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
    %{REQUEST_FILENAME} !-d
    RewriteRule 
    (.*) /index.php
    #
    ########## End 3rd Party or Core SEF Section 
    Dernière édition par west à 03/07/2006, 05h09
    www.gwadanet.com --> Partager vos connaissances et docs <--

  • #2
    Utilise 404SEFx, il n'y a pas de problème avec Joomla 1.0.10 et les versions antérieures et en plus il marche avec JoomFish.

    C'est juste un conseil !!!

    @++
    JoomlaSite Integrateur

    Commentaire


    • #3
      En fait je ne pense pas que cela réglera le pb.

      Comme j'ai écris, meme avec le SEO intégré de joomla ça marche pas.
      Donc doit bien avoir un soucis, peut etre de config, c'est pour cela que je vous ai renvoyé mon .htaccess pour me dire si le probleme ne se trouve pas à ce niveau.
      www.gwadanet.com --> Partager vos connaissances et docs <--

      Commentaire


      • #4
        quel est ton hébergeur ? Il ne permet peut être pas l'URL rewriting.

        normalement avec le SEO de joomla seul les premières règles de ton htaccess doivent etre décommentées

        pour ma part j'ai laissé commentées les lignes optionnelles
        http://www.lesous-marin.org Le site du Sous-marin, association pour la promotion des musiques électroniques

        Commentaire


        • #5
          Comme j'ai dis plus haut je suis héberger par moi meme, je ne me prend pas trop cher

          Donc toi t as juste décommenté la partie "Standard SEF Section" ??

          as tu mis le slash apres le index ?

          y a t il un endroit sur mon serveur ( je pense au fichier de config apache) que je dois vérifier pour l'url rewriting ?

          Pour la partie optionnelle, ils parlent dans la htaccess de dossiers component et content .
          comme quoi, si on a ces dossiers on peut décommenté. Sauf que je les ai, component à la racine et content dans le dossier media

          j'ai donc decommenté :
          RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional

          mais ca donne toujours rien
          Dernière édition par west à 03/07/2006, 18h34
          www.gwadanet.com --> Partager vos connaissances et docs <--

          Commentaire


          • #6
            tiens je te mets on htaccess

            Code:
            #RewriteBase /
            #RewriteCond %{REQUEST_FILENAME} !\.(jpg|jpeg|gif|png|css|js|pl|txt)$
            #RewriteCond %{REQUEST_FILENAME} !-f
            #RewriteCond %{REQUEST_FILENAME} !-d
            #RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]
            #RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
            #RewriteRule ^(.*) index.php [L]
            
            
            ##
            # @version $Id: htaccess.txt 2368 2006-02-14 17:40:02Z stingrey $
            # @package Joomla
            # @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
            # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
            # Joomla! is Free Software
            ##
            
            
            #####################################################
            #  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
            #
            # The line just below this section: 'Options FollowSymLinks' may cause problems
            # with some server configurations.  It is required for use of mod_rewrite, but may already
            # be set by your server administrator in a way that dissallows changing it in
            # your .htaccess file.  If using it causes your server to error out, comment it out (add # to 
            # beginning of line), reload your site in your browser and test your sef url's.  If they work,
            # it has been set by your server administrator and you do not need it set here. 
            #
            # Only use one of the two SEF sections that follow.  Lines that can be uncommented
            # (and thus used) have only one #.  Lines with two #'s should not be uncommented
            # In the section that you don't use, all lines should start with #
            #
            # For Standard SEF, use the standard SEF section.  You can comment out
            # all of the RewriteCond lines and reduce your server's load if you
            # don't have directories in your root named 'component' or 'content'
            #
            # If you are using a 3rd Party SEF or the Core SEF solution
            # uncomment all of the lines in the '3rd Party or Core SEF' section
            #
            #####################################################
            
            #####  SOLVING PROBLEMS WITH COMPONENT URL's that don't work #####
            # SPECIAL NOTE FOR SMF USERS WHEN SMF IS INTEGRATED AND BRIDGED
            # OR ANY SITUATION WHERE A COMPONENT's URL's AREN't WORKING
            #
            # In both the 'Standard SEF', and '3rd Party or Core SEF' sections the line:
            # RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
            # May need to be uncommented.  If you are running your Joomla/Mambo from
            # a subdirectory the name of the subdirectory will need to be inserted into this
            # line.  For example, if your Joomla/Mambo is in a subdirectory called '/test/',
            # change this:
            # RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
            # to this:
            # RewriteCond %{REQUEST_URI} ^(/test/component/option,com) [NC,OR] ##optional - see notes##
            #
            #####################################################
            
            
            ##  Can be commented out if causes errors, see notes above.
            #Options FollowSymLinks
            
            #
            #  mod_rewrite in use
            
            RewriteEngine On
            
            
            #  Uncomment following line if your webserver's URL
            #  is not directly related to physical file paths.
            #  Update Your Joomla/MamboDirectory (just / for root)
            
             RewriteBase /
            
            
            ########## Begin Standard SEF Section
            ## ALL (RewriteCond) lines in this section are only required if you actually
            ## have directories named 'content' or 'component' on your server
            ## If you do not have directories with these names, comment them out.
            #
            #RewriteCond %{REQUEST_FILENAME} !-f
            #RewriteCond %{REQUEST_FILENAME} !-d
            #RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] 		##optional - see notes##
            #RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
            #RewriteRule ^(content/|component/) index.php
            #
            ########## End Standard SEF Section
            
            
            ########## Begin 3rd Party or Core SEF Section
            #
            #RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] 		##optional - see notes##
            RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$  [NC]
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteCond %{REQUEST_FILENAME} !-d
            RewriteRule (.*) index.php
            #
            ########## End 3rd Party or Core SEF Section

            mais je n'ai pas encore tout mis en place, l'url rewriting marche pour certaines pages, mais à première vu ça marche.

            attention ce htaccess est valable avec openSEF mais je crois avoir fait marcher le SEF de Joomla seul en commentant les lignes pour un SEO tierce et en décommentant celle destiné au SEF de Joomla. Je sais plus très bien quelle version du htaccess c'est car j'en avait récupérer une version sur le forum de openSEF et pas mal bidouiller avant que ça marche.

            sinon pour apache (enfin je l'ai fait sous easyPHP mais ça doit être sensiblement la même chose pour toi ) il faut que tu décommente les lignes siuivantes dans le fichier de configuration :

            LoadModule rewrite_module modules/mod_rewrite.so

            et

            AddModule mod_rewrite.c

            voilà j'éspère que ça t'aide mais essaye d'abord de faire marcher le SEO de Joomla avant d'activer openSEF
            Dernière édition par bigbabou à 04/07/2006, 00h32
            http://www.lesous-marin.org Le site du Sous-marin, association pour la promotion des musiques électroniques

            Commentaire


            • #7
              Re,

              1- en remplacant mon htaccess par le tient ça ne marche pas

              2- j'ai vérifier la présence de "LoadModule rewrite_module modules/mod_rewrite.so" dans le fichier de conf apache, il s'y trouve bien, OK

              3- J'ai vérifier la présence de AddModule mod_rewrite.c, il nest pas présent
              - je l'ai rajouté, relancé apache, mais apache ne se lance plus, j'ai une erreur
              dutype " invalid command 'addmodule'....
              - j'ai enlever le addmodule, mais jai le meme probleme et meme message avec
              mod_rewrite.c (invalid commad 'mod_rewrite.c')
              c'est peut etre du à la version d'apache qui doit etre en 2.

              dans le phpinfo g bien mod_rewrite, donc j'imagine qu'il doit etre activé l'url rewriting.

              Le seul point positif c'est que j'ai bien les url qui sont réécrite, mais derriere apache n'a pas l'air de les comprendre puisqu'il me met un 404 error, page non trouvé.

              Si vous avez des idées n'hésiter pas car je ne vois plus quoi faire.

              PS: j'utilise bien pour le moment SEO de joomla, j'ai mis opensef de coté j'y reviendrai lorsqu'il fonctionnera dèja pour joomla le sef.
              www.gwadanet.com --> Partager vos connaissances et docs <--

              Commentaire


              • #8
                Bonjour,

                Ton pb est lié à la sme. Il semble (en l'état actuel de mes investigations) que l'utilisation d'un htaccess sur sme nécessite d'installer un logiciel spécifique, puis de trifouiller les templates pour activer un AllowOverride All qui permet de fonctionner pour l'URL rewriting.
                Pas de bol si tu utilises SME 7, il semble que ce rpm n'est pas encore compatible..

                Un lien en référence : http://forums.fr.ixus.net/viewtopic....light=htaccess

                Si tu peux passer un peu de temps là dessus, tiens nous informés, ça m'interesse...
                Je suis toujours le développeur de sh404sef, mais il est désormais distribué par Weeblr. Je ne réponds plus aux MP sur ce composant. Merci de votre compréhension.

                Commentaire


                • #9
                  là j'avoue que je vois pas trop d'où celà peut venir .... moi je suis chez OVH donc je ne sais pas du tout comment est configuré apache.

                  Essaye de faire marcher l'url rewriting sur un exemple tout bête comme sumisha t'as proposé.

                  mais là chuis désolé j'ai atteint mes limites de compétences
                  http://www.lesous-marin.org Le site du Sous-marin, association pour la promotion des musiques électroniques

                  Commentaire


                  • #10
                    merci tout dabord à tout ceux qui ont pris leur temps pour m'aider

                    shumisha:

                    thx, t as réponse à pu me router vers la bonne solution, en cherchant un peut j'ai pu constaté que AllowOverride était a "None" pour tous les virtualhosts sur la sme.

                    J'ai modifier ce parametre pour l'ibays de mon site via ces commandes:

                    # /sbin/e-smith/db accounts setprop <ibayname> AllowOverride All
                    # /sbin/e-smith/signal-event ibay-modify <ibayname>
                    # expand-template /etc/httpd/conf/httpd.conf
                    # service httpd-e-smith restart (un petit reboot du démon)

                    test, et.....roulement de tambour.....
                    ....
                    ...
                    ça n'a pas fonctionné !! LOL "acces non authorisé"
                    un lol parceque je savais que j'étais pas loin, car un probleme d'acces , ça, ça se résoud assez bien.

                    j'avais lancer tail juste avant:

                    # tail -f /var/log/httpd/error_log

                    J'ai donc eu cette info d'Apache:

                    [Wed Jul 05 02:06:18 2006] [error] [client 192.168.16.1] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /home/e-smith/files/ibays/gwadanet/html/

                    donc .... fallais activé en plus l'option ou directive (je ne sais ce qu'on dit) FollowSymLinks
                    je l'ai donc décommenté(dans le .htaccess), testé, sans relancé le démon apache et ça marche

                    à vous et à moi

                    donc c'était assez simple, encore faut il savoir ou chercher et quoi chercher.
                    je vais pouvoit efin testé opensef !

                    A toi shumisha de valider tout ça
                    www.gwadanet.com --> Partager vos connaissances et docs <--

                    Commentaire


                    • #11
                      content que tu t'en sois sortie
                      http://www.lesous-marin.org Le site du Sous-marin, association pour la promotion des musiques électroniques

                      Commentaire


                      • #12
                        Bravo

                        Ca fonctionne aussi chez moi, sur SME 7.0. D'après les essais que je viens de faire, les deux premières lignes suffisent :

                        Code:
                        # /sbin/e-smith/db accounts setprop <ibayname> AllowOverride All
                        # /sbin/e-smith/signal-event ibay-modify <ibayname>
                        Je n'ai testé aussi que le SEF standard, mais si lui marche, il n'y a aucune raison que OpenSEF ne marche pas aussi.

                        Encore bravo et merci
                        Je suis toujours le développeur de sh404sef, mais il est désormais distribué par Weeblr. Je ne réponds plus aux MP sur ce composant. Merci de votre compréhension.

                        Commentaire


                        • #13
                          Confirmation, OpenSEF fonctionne très bien (SME 7.0 + Joomla 1.0.10)
                          Je suis toujours le développeur de sh404sef, mais il est désormais distribué par Weeblr. Je ne réponds plus aux MP sur ce composant. Merci de votre compréhension.

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X