installation de composants

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • installation de composants

    bonjour
    je tiens tout d'abord à dire que ce topic est lié avec le suivant
    http://forum.joomla.fr/showthread.php?t=14439
    je me permet de faire un nouveau topic car j'ai compris certaine chose depuis (bien que le probleme reste entier) , que je ne parler pas de module mais de composant (du moins je pense)

    allons au fait : je me galere a installer les composants je me demander si il n'y avait pas moyen de le faire entierement manullement
    qui a appliquer les commande sql moi meme (c'est pas cela qui me fait peur )

    pourquoi une idee aussi saugrenue
    -je suis chez free donc l'installation depuis depuis le serveur j'oublie
    -l'installation de templates marche à merveilles ce n'est pas le cas des composant , module ou autre
    -et quand je tente d'installer par upload j'ai droit a:
    *Upload component - ECHEC
    Another component is already using directory:
    *ce document ne contient aucune donnée
    *une page (firefox) qui di en gros que il a un pb de serveur
    et j'ai le meme genre d'erreur sur IE sous opera pareil sur un autre pc pareil sa me rends dingue
    si vous avez un semblant d'idée faite moi signe !!!

    Envoyé par message erreur opera
    Connexion fermée par le serveur distant

    Vous tentez d'accèder à l'adresse http://--------------.free.fr/JOOMLA...tor/index2.php, actuellement injoignable. Assurez-vous que l'adresse web (URL) est écrite correctement puis tentez de recharger la page.
    Assurez-vous que votre connexion est activée et vérifiez si d'autres applications utilisent la même connexion.
    Vérifiez si un éventuel logiciel de sécurité est correctement configuré et n'interfère pas avec une navigation web normale.
    Si vous êtes derrière un pare-feu du réseau local et pensez que ceci peut poser problème, parlez-en à votre administrateur système.
    Appuyez sur la touche F12 de votre clavier et désactivez le serveur proxy, sauf si vous êtes obligé d'utiliser un proxy pour vous connecter à Internet. Rechargez la page.
    voici quelque info sur ma config
    modem: livebox
    antivirus: bitdefender(sur un pc) et encore j'ai meme essayer de le desactiver
    os:windows xp sp2
    Dernière édition par liquid à 08/08/2006, 13h27

  • #2
    Salut,

    La réponse est dans la question!
    Tu essaies d'installer un composant qui a déjà été installé !!

    Si la première installation s'est mal passée, il est possible qu'il reste qd même des traces dans le système de fichiers et la base de données, donc:

    - tu vas dans le menu Installation > Composants et tu s'assures que le composant n'est pas listé, s'il l'est tu le sélectionnes et tu cliques sur le bouton Désinstaller, sinon tu continues comme suit...
    - tu supprimes les dossiers du composant ici /components/com_nomducomposant et là /administrator/components/com_nomducomposant
    - tu ouvres ta base de données dans phpMyAdmin et tu supprimes les tables correspondants à ton composant (jos_nomducomposant)
    - tu vides le dossier /medias de tous les sous-dossiers qu'il pourrait contenir

    Ensuite tu peux retester l'installation de ton composant. Pour info, ça marche très bien chez Free, donc pas la peine de l'installer à la main.

    PS: c'est quoi le composant au fait?
    Pas de demande de support en MP ou par mail, le forum est là pour ça!
    http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
    http://www.lapatagonie.com : juste pour vous dépayser un peu...

    Commentaire


    • #3
      confirmation

      Bonjour,

      C'est vrai cela m'est déja arrivé sur des sites free... Il te suffit de supprimer les dossiers susdits...

      Et je n'ai pas lu le poste indiqué mais pour ma part je suis arrivé à installer phpbb pour joomla sur un site free.

      Commentaire


      • #4
        tout d'abord merci
        en realité il y en a plusieurs mais si on prends un probleme a la fois on dira le composante bookmarks cf http://www.joomlafrance.org/telechar...Bookmarks.html
        meme apres avoir fais les manip d'hormos
        voila le message d'erreur

        Upload component - ECHEC
        SQL Error DB function failed with error number 1067
        Invalid default value for 'credits' SQL=CREATE TABLE `jos_bookmarks` ( `id` int(11) unsigned NOT NULL auto_increment, `sid` int(11) NOT NULL default '0', `title` varchar(250) NOT NULL default '', `url` text NOT NULL default '', `description` text NOT NULL, `detail` text NOT NULL, `imageurl` varchar(250) NOT NULL default '', `created` datetime NOT NULL default '0000-00-00 00:00:00', `modified` datetime NOT NULL default '0000-00-00 00:00:00', `rating` float(3,2) NOT NULL default '0.00', `ratingcount` int(11) NOT NULL default '0', `ratingadmin` tinyint(3) NOT NULL default '0', `hits` int(11) NOT NULL default '0', `published` tinyint(1) NOT NULL default '0', `access` tinyint(3) NOT NULL default '0', `checked_out` int(11) NOT NULL default '0', `created_by` int(11) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `archived` tinyint(1) NOT NULL default '0', `approved` tinyint(1) NOT NULL default '1', `validated` varchar(5) NOT NULL default '0', `validationdate` datetime NOT NULL default '0000-00-00 00:00:00', `validationstatus` varchar(250) NOT NULL default '', `redirect` tinyint(1) NOT NULL default '0', `private` tinyint(1) NOT NULL default '0', `openwin` TINYINT( 1 ) DEFAULT '1' NOT NULL, `keywords` varchar(255) NOT NULL default '', `credits` int(11) NOT NULL default '', PRIMARY KEY (`id`), KEY `title` (`title`) ) TYPE=MyISAM;
        SQL =

        CREATE TABLE `jos_bookmarks` (
        `id` int(11) unsigned NOT NULL auto_increment,
        `sid` int(11) NOT NULL default '0',
        `title` varchar(250) NOT NULL default '',
        `url` text NOT NULL default '',
        `description` text NOT NULL,
        `detail` text NOT NULL,
        `imageurl` varchar(250) NOT NULL default '',
        `created` datetime NOT NULL default '0000-00-00 00:00:00',
        `modified` datetime NOT NULL default '0000-00-00 00:00:00',
        `rating` float(3,2) NOT NULL default '0.00',
        `ratingcount` int(11) NOT NULL default '0',
        `ratingadmin` tinyint(3) NOT NULL default '0',
        `hits` int(11) NOT NULL default '0',
        `published` tinyint(1) NOT NULL default '0',
        `access` tinyint(3) NOT NULL default '0',
        `checked_out` int(11) NOT NULL default '0',
        `created_by` int(11) NOT NULL default '0',
        `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00',
        `archived` tinyint(1) NOT NULL default '0',
        `approved` tinyint(1) NOT NULL default '1',
        `validated` varchar(5) NOT NULL default '0',
        `validationdate` datetime NOT NULL default '0000-00-00 00:00:00',
        `validationstatus` varchar(250) NOT NULL default '',
        `redirect` tinyint(1) NOT NULL default '0',
        `private` tinyint(1) NOT NULL default '0',
        `openwin` TINYINT( 1 ) DEFAULT '1' NOT NULL,
        `keywords` varchar(255) NOT NULL default '',
        `credits` int(11) NOT NULL default '',
        PRIMARY KEY (`id`),
        KEY `title` (`title`)
        ) TYPE=MyISAM;

        [ Continuer ... ]

        Commentaire


        • #5
          Un truc un peu con mais pense a vider ton cache! Moi je me suis fait avoir plus d'une fois par cela!
          Joomla 1.5.18

          Commentaire


          • #6
            ne trouvant pas la solution malgres votre aide(au passage je tiens a vous remercier pour l'aide que vous me fournissez)
            j'ai decider de tout reinstaller pour repartir du bon pieds
            j'ai vider mas bdd , ma compte free via le ftp il ne reste plus qu'a la racine les fichier joomla + un index.html
            Je crois que j'ai reduit au minimum vital

            ci apres mon post lié a ma reinstallation chez free

            et les truc vert et rouge de la preinstallation

            http://forum.joomla.fr/showpost.php?...7&postcount=54

            je me demander ci quelqu'un pouvant me confirmer que le truc rouge n'été pas la cause de mais malheur precedent

            Commentaire


            • #7
              Envoyé par liquid
              ...et les truc vert et rouge de la preinstallation

              http://forum.joomla.fr/showpost.php?...7&postcount=54

              je me demander ci quelqu'un pouvant me confirmer que le truc rouge n'été pas la cause de mais malheur precedent
              Oui bien sûre, tu dois mettre les répertoires modules, composants et templates en CHMOD 777, comme les autres, sinon ils osnt vérouillés et tu ne peux y installer des news éléments.

              Bonne chance !
              Communauté Suisse-Romande : www.joomlaromand.ch
              Kits Joomla!, extensions FR et tutoriels : www.joomlatutos.com
              Support de l'éditeur JCE FR : Fichiers à télécharger, aide & Forum www.sarki.ch/jce

              Commentaire


              • #8
                Salut,

                tu n'a plus qu'a tout réinstallé car tu a mal suivi la procédure très bien expliqué d'Hornos!

                Il ta dit pour la base de donné :

                tu ouvres ta base de données dans phpMyAdmin et tu supprimes les tables correspondants à ton composant (jos_nomducomposant)

                Toi tu a fait un ménage radical dans ta base!

                Sache qu'il y à plein de composant instable, je te conseil de les tester un par un en local a fond avant de les publier sur ton site réél.

                Pour le truc rouge et vert comme tu dis, on peu presque tout mettre au vert ça depend des fournisseur en général, sinon il y a des manipes a faire et un peu de code à écrire en *.php (je ferai un Tuto la dessus) ultérieurement.

                En attendant, bon courage, cordialement.
                Dernière édition par felichon à 11/08/2006, 03h31

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X