COMPOSANT 404SEFx

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • COMPOSANT 404SEFx

    Bonjour à toute la communautée,

    Je viens d'achever mon premier site joomla et pour que celui-ci apparaisse dans les moteurs de recherche, je m'attaque à l'URL REWRITING.

    Après avoir parcouru pas mal de forum sur la question, j'ai donc decidé d'installer le composant 404SEFx ( apparement le seul composant gratuit et sans failles de securité ).

    Je tiens à préciser que je fais ces tests en local, via le serveur apache de easyphp.

    Après avoir installé le composant, et l'avoir activé, si je renome mon fichier htaccess.txt en .htaccess, alors j'obtiens une belle page d'erreur 500 ( Problème apparement lié a la configuration du serveur apache.... pourtant le mod_rewrite est activé ... )

    Si je ne renome pas le fichier htaccess et le laisse au format txt , j'accede a mon site mais les liens du menu me renvoi sur une page d'erreur 404 .... j'ai pourtant bien pris la peine de vérifier la correspondance des urls dans "View/edit url" dans le composant 404SEFX, et celles ci correspondent.... c'est a plus rien y comprendre !

    Je ne vois décidement pas ou j'ai pu faire une bourde..... si quelqu'un à une idée je suis preneur..

    Merci d'avance

  • #2
    Quelques petites modifications par rapport à mon premier post :

    J'arrive maintenant à renomer mon fichier htaccess.txt en .htaccess et j'accede au site.... par contre cette fois quand je clique sur les liens du menu ca me ramene sur la page index.php de mon dossier WWW.

    Je ne comprend pas d'ou viens le problème, pourtant la réecriture de mes pages fonctionne.....

    Si cela peu vous aider , je vous joint mon fichier .htaccess :

    ----------------------------------------------------------------

    ## OpenSEF plain htaccess file

    ## Can be commented out if causes errors
    Options FollowSymLinks

    ## mod_rewrite in use
    RewriteEngine On

    ## If Joomla is installed in the web server root
    ## RewriteBase /
    ## If Joomla is installed in a sub-directory
    ## RewriteBase /directory_name_here
    RewriteBase /Joomla_1[1].0.10-Stable-fr/

    ## Begin 3rd Party or OpenSEF Section
    ##
    RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
    RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule (.*) /index.php
    ##
    ## End 3rd Party or OpenSEF Section

    Merci pour votre aide d'avance

    Commentaire


    • #3
      bonjour,

      Attention les erreurs 500 surtout si tu es chez 1and 1 sont assez frequentes, mais disparaissent au bout d'un moment ..
      Contrairement a ce que tu annonce dans ton premeier post 404SEFx, n'est pas sans faille de sécutité, certains posts sur joomla.org conseillent meme de le desintaller. Par contre il existe ATIO joomsef qui est la suite de 404sefX, trés récent, mais j'ignore si les failles de sécurités sont corrigée, et il fonctionne au poil.

      Cordialement
      Jean-Pierre REYT

      Commentaire


      • #4
        Merci arma33,

        par contre j'ai recherché ATIO joomsef sur google et je trouve aucune réponse, est ce bien ce nom ?

        Merci d'avance

        Commentaire


        • #5
          Envoyé par arma33
          bonjour,

          Attention les erreurs 500 surtout si tu es chez 1and 1 sont assez frequentes, mais disparaissent au bout d'un moment ..
          Contrairement a ce que tu annonce dans ton premeier post 404SEFx, n'est pas sans faille de sécutité, certains posts sur joomla.org conseillent meme de le desintaller. Par contre il existe ATIO joomsef qui est la suite de 404sefX, trés récent, mais j'ignore si les failles de sécurités sont corrigée, et il fonctionne au poil.

          Cordialement
          Salut !! Effectivement je suis chez 1and1, et bah bonjour les erreurs 500 de partout !!! Et elles disparaissent pas malheureusement... :'( Pourtant j'ai suivi tous les tutos (http://forum.joomla.fr/showpost.php?p=76006&postcount=7) mais là rien à faire, j'ai toujours ça :

          " Paramètre PHP register_globals est sur `ON` au lieu de `OFF` "

          Et par conséquent, pas possible d'utiliser SEF, erreur 500 à chaque lien. Que faire, quelqu'un est-il chez 1and1 et a résolu ce problème ?

          Envoyé par BALTABOR
          Merci arma33,

          par contre j'ai recherché ATIO joomsef sur google et je trouve aucune réponse, est ce bien ce nom ?

          Merci d'avance
          Tu devrais trouver ton bonheur ici :

          http://www.artio.cz/downloads/joomla-extensions/

          Dernière édition par Tchek à 05/09/2006, 13h27

          Commentaire


          • #6
            Petite avancée, j'ai relancé le script de charlynancy, j'ai plus la notification "Paramètre PHP register_globals est sur `ON` au lieu de `OFF` " mais j'ai toujours ce problème d'erreur 500 à tout bout de champ...

            EDIT : autant pour moi, j'ai trouvé la solution ici :

            http://forum.joomla.fr/showthread.ph...obl%E8me+1and1

            Merci charly pour ce tuto !
            Dernière édition par Tchek à 05/09/2006, 14h16

            Commentaire


            • #7
              Merci tchek pour cette petite précision.

              J'ai donc désinstaller 404SEFx, puis installer ARTIO JOOMSEF,mais cette fois lorsque je clique sur un des liens de mon menu il m'affiche une page d'erreur 404. Je vous joint mon fichier htaccess... peut etre que ca vous aidera

              --------------------------------------------------------------------------
              ## Can be commented out if causes errors, see notes above.
              Options FollowSymLinks

              #
              # mod_rewrite in use

              RewriteEngine On


              # Uncomment following line if your webserver's URL
              # is not directly related to physical file paths.
              # Update Your Joomla/MamboDirectory (just / for root)

              RewriteBase /Joomla_1[1].0.10-Stable-fr


              ########## Begin Standard SEF Section
              ## ALL (RewriteCond) lines in this section are only required if you actually
              ## have directories named 'content' or 'component' on your server
              ## If you do not have directories with these names, comment them out.
              #
              #RewriteCond %{REQUEST_FILENAME} !-f
              #RewriteCond %{REQUEST_FILENAME} !-d
              #RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
              #RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
              #RewriteRule ^(content/|component/) index.php
              #
              ########## End Standard SEF Section


              ########## Begin 3rd Party or Core SEF Section
              #
              #RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
              RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
              RewriteCond %{REQUEST_FILENAME} !-f
              RewriteCond %{REQUEST_FILENAME} !-d
              RewriteRule (.*) index.php
              #
              ########## End 3rd Party or Core SEF Sect

              si quelqu'un a une idée ...

              Merci d'avance

              Commentaire


              • #8
                Donc si je comprends bien , ce composant n'est pas compatible avec un hébergeur de type "FREE" ?

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X