bug avec JoomlaComment 2.40

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • bug avec JoomlaComment 2.40

    Bonjour,
    je vous expose mon probleme, je suis en train de créer un site perso et hier j'ai rajouté le composants joomla comment, le composant fonctionne, le probleme c'est que j'ai ça d'afficher sur la page:

    Warning: Invalid argument supplied for foreach() in /mnt/106/sdb/a/d/totorock/joomla/components/com_comment/joscomment/properties.php on line 160

    Je suis nul, je vous préviens tout de suite mais qu'es? et comment virer ça?
    J'aurrai aimé savoir si il y a une trad en français qui existe aussi...

    Merci

    j'allais oublié l'adresse:

    Http://totorock.free.fr/joomla
    Dernière édition par V-MeTaL à 09/10/2006, 12h49

  • #2
    J'ai le même problème que toi. De plus je n'arrive pas à supprimer des commentaires inscrit!
    Nous avons besoin d'aide!
    Merci

    http://www.elrenzo.free.fr

    Commentaire


    • #3
      ta essayé dans :

      composants-->jommlacoment-->manage comment

      tu sellectionne les coms a suprimer et tu clique sur la grosse icone supprimer
      (la derniere)


      sinon je sais pas

      Commentaire


      • #4
        joomlacomment est un super outil mais malheureusement comporte plein de bugs....
        J'ai eu les mêmes surprises...

        Voici les correctifs que j'ai appliqué (et qui me permette de l'utiliser) pour les erreurs suivantes:
        C'est un peu technique...il faut rentrer dans les sources...
        line error 160

        divers problèmes côté administration (celui là est en anglais parce que finalement je me suis dit que çà pouvait servir pour tout le monde.... )

        Pour ma part, j'ai désactivé l'ajax [à cause de problèmes avec les caractères accentués] (je ne me suis pas encore penché sur ce problème pour le solutionner)...

        J'ai écrit au responsable de ce composant pour faire part de ces erreurs. pas de nouvelles pour le moment d'une version future....

        si cela peut aider...
        Dernière édition par alcaribou à 09/10/2006, 22h49
        non mais sans blague !

        Commentaire


        • #5
          pour la ligne 160, ca a rien changé :'(

          Commentaire


          • #6
            désolé !
            pour moi cela a fonctionné.

            Autre essai :
            as-tu désactivé l'ajax ? (pour voir si cela a un impact....)
            edit setting -> General -> Ajax support = Non

            ?
            OUPS laissez tomber, j'ai retrouvé le problème que j'avais avec mon ajax. rien à voir avec la ligne 160 etc... (problème de caractères accentués...)

            En revanche l'indication line error 160 reste vraie dans certains cas. Pour moi cela a corrigé le problème. A voir pour d'autres....
            désolé...j'suis qu'un bleu !
            Dernière édition par alcaribou à 09/10/2006, 22h39
            non mais sans blague !

            Commentaire


            • #7
              Salut elrenzo,

              Pour supprimer les commentaires tu te connectes directement avec ton login et ton mot de passe administrateur par le front end (par où se connectent les membres enregistrés sur ton site), tu édites le commentaire et tu peux ensuite le supprimer.

              Par le back end j'ai jamais pu supprimer de commentaires...

              A+
              Le bonheur n'est pas pour demain, il n'est pas hypothétique, il commence ici et maintenant.

              Commentaire


              • #8
                Envoyé par caribou
                désolé !
                pour moi cela a fonctionné.

                Autre essai :
                as-tu désactivé l'ajax ? (pour voir si cela a un impact....)
                edit setting -> General -> Ajax support = Non

                ?
                OUPS laissez tomber, j'ai retrouvé le problème que j'avais avec mon ajax. rien à voir avec la ligne 160 etc... (problème de caractères accentués...)

                En revanche l'indication line error 160 reste vraie dans certains cas. Pour moi cela a corrigé le problème. A voir pour d'autres....
                désolé...j'suis qu'un bleu !
                ca ne fonctionne toujours pas

                Commentaire


                • #9
                  Envoyé par caribou Voir le message
                  désolé !
                  pour moi cela a fonctionné.

                  Autre essai :
                  as-tu désactivé l'ajax ? (pour voir si cela a un impact....)
                  edit setting -> General -> Ajax support = Non

                  ?
                  OUPS laissez tomber, j'ai retrouvé le problème que j'avais avec mon ajax. rien à voir avec la ligne 160 etc... (problème de caractères accentués...)

                  En revanche l'indication line error 160 reste vraie dans certains cas. Pour moi cela a corrigé le problème. A voir pour d'autres....
                  désolé...j'suis qu'un bleu !
                  A moins qu'il ne faille tout réinstaller avec le fichier modifié?

                  Commentaire


                  • #10
                    Bon, j'ai finalement installer la version dispo ici:

                    http://forum.joomla.fr/showthread.php?t=14823

                    Le bug 160 a disparu et c'est en français...

                    Commentaire


                    • #11
                      je trouve à nouveau un peu de temps pour suivre cette discussion...désolé.

                      Super !

                      Cependant, c'est vraiment bizarre...
                      En effet, c'est la fonction loadProfiles qui pose problème à la ligne 160 et en mettant la ligne 123 en commentaire, cela la désactive.

                      Avais-tu bien les lignes ainsi dans ton properties :
                      ............
                      $this->loadEmoticons("$absolutePath/emoticons/$this->_emoticon_pack/index.php");
                      $this->_show_readon = $josc_show_readon;
                      #this->loadProfiles();
                      $exclude = false;
                      ........

                      Je vois que le fichier properties de la version 2.33 est assez différent. il n'y a pas cette fonction.

                      J'allais te proposer de m'envoyer ton fichier "properties.php".
                      Mais bon si la 2.33 te suffit. Laisse tomber.
                      non mais sans blague !

                      Commentaire


                      • #12
                        J'en profite pour demander si quelqun a trouvé la solution pour activer l'ajax et éviter les problèmes avec les caractères accentués ???

                        J'ai trouvé une résolution partielle. Elle règle les à,ç mais perd les é,è
                        >>>>>>>>>>>>>>>
                        Open up visual.php, you find it in components\com_comment\joscomment . Look for the line, its around line 97-98:
                        return "$html\nvar postCSS=$postCSS;";

                        Just above this line write this:
                        $html = utf8_decode($html);

                        So it will look like this:
                        $html = utf8_decode($html);
                        return "$html\nvar postCSS=$postCSS;";
                        <<<<<<<

                        une idée ???
                        non mais sans blague !

                        Commentaire


                        • #13

                          En fait je viens de re-tester et çà fonctionne pour tous les nouveaux commentaires que j'ajoute... !

                          Ce sont les anciens qui sont restés avec des caractères bizarres.

                          le seul petit bug est le lien "répondre" a un problème de ? sur le é.
                          mais j'ai bon espoir de le solutionner !

                          ! Solution trouvée :
                          Pour y remédier, dans le fichier components/com_comment/joscomment/language/french.php, cherchez la constante _JOOMLACOMMENT_REPLY et remplacer le "é" de "Répondre" par le code HTML "&eacute ;". (j'ai mis un espace à retirer avant le ; pour que le code soit lisible dans cet article). Cela donne :

                          DEFINE('_JOOMLACOMMENT_REPLY', 'R&eacute ;pondre');
                          Dernière édition par alcaribou à 11/10/2006, 23h21
                          non mais sans blague !

                          Commentaire


                          • #14
                            Envoyé par caribou Voir le message
                            Avais-tu bien les lignes ainsi dans ton properties :
                            ............
                            $this->loadEmoticons("$absolutePath/emoticons/$this->_emoticon_pack/index.php");
                            $this->_show_readon = $josc_show_readon;
                            #this->loadProfiles();
                            $exclude = false;
                            ........

                            Je vois que le fichier properties de la version 2.33 est assez différent. il n'y a pas cette fonction.

                            J'allais te proposer de m'envoyer ton fichier "properties.php".
                            Mais bon si la 2.33 te suffit. Laisse tomber.
                            je n'ai plus le fichier, dsl...




                            Envoyé par caribou Voir le message
                            J'en profite pour demander si quelqun a trouvé la solution pour activer l'ajax et éviter les problèmes avec les caractères accentués ???

                            J'ai trouvé une résolution partielle. Elle règle les à,ç mais perd les é,è
                            >>>>>>>>>>>>>>>
                            Open up visual.php, you find it in components\com_comment\joscomment . Look for the line, its around line 97-98:
                            return "$html\nvar postCSS=$postCSS;";

                            Just above this line write this:
                            $html = utf8_decode($html);

                            So it will look like this:
                            $html = utf8_decode($html);
                            return "$html\nvar postCSS=$postCSS;";
                            <<<<<<<

                            une idée ???
                            La version 2.33fr modifié par la personne qui a écris le sujet prend en charge les accents, et je crois qu'elle explique comment elle a fait.
                            Maintenant moi je suis nul en codage donc voila ...lol

                            Sinon, j'ai désactivé l'ajax (d'ailleurs je sais pas ce que c'est, pour moi ça me fait plus penser a de la lessive ) parce que après posté une réponse j'avais une alerte comme quoi l'admin devait la validé (alors que non !!) Et il y avais un code bizarre qui apparaissait dans la fenêtre d'édition du message...

                            Apparemment pas possibilité de re-éditer le message je sais pas si c'est lié a la version ou a ça, mais sur la plupart des sites on peut jamais éditer donc ça ne me dérange pas...

                            Edit:
                            Humm// la fonction rechercher ne fonctionne pas, j'ai cette erreur:

                            Fatal error: Call to undefined function: mb_convert_encoding() in /mnt/106/sdb/a/d/totorock/joomla/components/com_comment/joscomment/board.php on line 382
                            Dernière édition par V-MeTaL à 12/10/2006, 12h27

                            Commentaire


                            • #15
                              es que quelqu'un sais comment changer les couleurs de "nom" bbcode"et "titre" ? parce que je n'arrive pas a trouver d'autre endroits pour mettre des couleurs dans la feuille de style... Merci :d

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X