Liens d'un composant ne marchant pas

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Liens d'un composant ne marchant pas

    Bonjour,

    Suite au hack de mon site, j'ai été obligé de tout réinstaller. Je suis donc repartis d'une installation toute propre de joomla.

    Je viens de réinstaller le composant AkoLegal (que j'avais d'ailleur découvert sur ce même forum) qui me permet de gérer les quelques infos légales de mon site et les conditions d'utilisation et les règles relatives à la vie privée.

    Le problème c'est que les deux liens de ce composant vers les conditions d'utilisation et de vie privée que je viens de mentionner ne marchent pas.

    Pourtant, ils sont classiques et du type : index.php?option=com_akolegal&Itemid=19&func=terms
    et index.php?option=com_akolegal&Itemid=19&func=priva cy

    Bref, rien d'original. Je suis sous joomla 1.0.11 sans aucun SEF activé, uniquement les URL de base de Joomla.

    J'ai vérifié le contenu du fichier AkoLegal, mais je ne vois rien de problématique. L'affichage de la page correspondante se fait avec l'instruction case switch.

    Bref, si vous aviez une idée ou si vous êtes prêts à m'aider, ce serait très sympa pcq j'avoue vraiment bloquer à ce stade.

    Si vous souhaitez tester ce composant, téléchargez le dans le lien du forum que j'ai mis plus haut.

    Pour le tester sur mon site : http://www.campusdroit.com/index.php...egal&Itemid=19

    Merci d'avance,
    Themis

  • #2
    bon je pose que bien sur la question bete as tu verifier en premier lieu que tout est bien publié??
    Alzeihmer .........de bonne heure
    je sais faire le café et le thé.................

    Commentaire


    • #3
      Of Course

      Merci pour ta réponse.
      Oui en effet tout est bien publié : composants, modules etc.

      As-tu jeter un coup d'oeil sur le site ? As-tu déjà rencontré ce type de problème ?
      Merci encore pour ton aide.

      Commentaire


      • #4
        Réponse trouvée

        Il s'agit d'une incompatibilité entre AkoLegal 2 et les nouveaux paramètres de sécurité de Joomla 1.0.11 (registar_global off et rg_emulation sur 0).

        Il faut donc remplacer la ligne 27 de /components/com_akolegal/akolegal.php:

        Celle-ci :

        Code PHP:
        switch ($func) { 
        par celle-ci

        Code PHP:
        switch($_REQUEST["func"]) { 
        Voila,
        Themis

        Commentaire


        • #5
          J'ai un autre probleme c'est que dans la partie admin lorsque j'enregistre les paametres siret, siren ou autres puis je clique sur save, tous disparait de mes champs et lorsque je teste en frontend, rien du tout ne s'affiche. Comme si la sauvegarde de mes donnes backoffice n'a pas fonctionné. Cela me fait la meme chose avec le composant artlink. Si je modifie les parmatrées de configuration et je clique sur save, plus rien n'est sauvegardé !!!

          Je suis sur Free, est ce que cela vient de là ?

          Merci
          Parrainage zlio-Conty Loeuilly SC- Planéte foot - la boutique pour les fous du foot-La boutique esthetique cosmetique beaute- La boutique de l'olympique de marseille- La boutique des stickers- Soldes discount

          Commentaire


          • #6
            Salut,

            tes fichiers config des composants doivent être ouvert en écriture. (chmod)
            Lenamtl

            Commentaire


            • #7
              Ben mes fichiers config sont en rw r r c'est bon non ? Mon hébergeur est free.
              Parrainage zlio-Conty Loeuilly SC- Planéte foot - la boutique pour les fous du foot-La boutique esthetique cosmetique beaute- La boutique de l'olympique de marseille- La boutique des stickers- Soldes discount

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X