Erreur sql a l'installation de Bookmarks

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Erreur sql a l'installation de Bookmarks

    Bonjour,

    Je voufrais installer le composant bookmarks ... mais voici le message d'erreur que la base sql me retourne :

    Code:
    SQL Error DB function failed with error number 1067
    Invalid default value for 'credits' SQL=CREATE TABLE `jos_bookmarks` ( `id` int(11) unsigned NOT NULL auto_increment, `sid` int(11) NOT NULL default '0', `title` varchar(250) NOT NULL default '', `url` text NOT NULL default '', `description` text NOT NULL, `detail` text NOT NULL, `imageurl` varchar(250) NOT NULL default '', `created` datetime NOT NULL default '0000-00-00 00:00:00', `modified` datetime NOT NULL default '0000-00-00 00:00:00', `rating` float(3,2) NOT NULL default '0.00', `ratingcount` int(11) NOT NULL default '0', `ratingadmin` tinyint(3) NOT NULL default '0', `hits` int(11) NOT NULL default '0', `published` tinyint(1) NOT NULL default '0', `access` tinyint(3) NOT NULL default '0', `checked_out` int(11) NOT NULL default '0', `created_by` int(11) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `archived` tinyint(1) NOT NULL default '0', `approved` tinyint(1) NOT NULL default '1', `validated` varchar(5) NOT NULL default '0', `validationdate` datetime NOT NULL default '0000-00-00 00:00:00', `validationstatus` varchar(250) NOT NULL default '', `redirect` tinyint(1) NOT NULL default '0', `private` tinyint(1) NOT NULL default '0', `openwin` TINYINT( 1 ) DEFAULT '1' NOT NULL, `keywords` varchar(255) NOT NULL default '', `credits` int(11) NOT NULL default '', PRIMARY KEY (`id`), KEY `title` (`title`) ) TYPE=MyISAM;
    SQL =
    
    CREATE TABLE `jos_bookmarks` (
                         `id` int(11) unsigned NOT NULL auto_increment,
                         `sid` int(11) NOT NULL default '0',
                         `title` varchar(250) NOT NULL default '',
                         `url` text NOT NULL default '',
                         `description` text NOT NULL,
                         `detail` text NOT NULL,
                         `imageurl` varchar(250) NOT NULL default '',
                         `created` datetime NOT NULL default '0000-00-00 00:00:00',
                         `modified` datetime NOT NULL default '0000-00-00 00:00:00',
                         `rating` float(3,2) NOT NULL default '0.00',
                         `ratingcount` int(11) NOT NULL default '0',
                         `ratingadmin` tinyint(3) NOT NULL default '0',
                         `hits` int(11) NOT NULL default '0',
                         `published` tinyint(1) NOT NULL default '0',
                         `access` tinyint(3) NOT NULL default '0',
                         `checked_out` int(11) NOT NULL default '0',
                         `created_by` int(11) NOT NULL default '0',
                         `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00',
                         `archived` tinyint(1) NOT NULL default '0',
                         `approved` tinyint(1) NOT NULL default '1',
                         `validated` varchar(5) NOT NULL default '0',
                         `validationdate` datetime NOT NULL default '0000-00-00 00:00:00',
                         `validationstatus` varchar(250) NOT NULL default '',
                         `redirect` tinyint(1) NOT NULL default '0',
                         `private` tinyint(1) NOT NULL default '0',
                         `openwin` TINYINT( 1 ) DEFAULT '1' NOT NULL,
                         `keywords` varchar(255) NOT NULL default '',
                         `credits` int(11) NOT NULL default '',
                         PRIMARY KEY  (`id`),
                         KEY `title` (`title`)
                       ) TYPE=MyISAM;
    D'ou cela vient il ?

    Que puis je faire ?

    Merci d'avance.
    Dernière édition par pfff à 17/10/2006, 10h21 Raison: je voulais passé le message en [réglé]
    Actualités Web
    Création de site internet 78

  • #2
    Bonjour,

    j'ai essayé, suite a mes recherches sur différents forum de rajouter un 0 entre les ' apres les lignes ou le paramètres default figure

    ex: `title` varchar(250) NOT NULL default '', je l'ai transformen en `title` varchar(250) NOT NULL default '0',

    mais le problème persiste

    SOS !!

    quelqu'un peut m'aider, m'aiguiller
    Actualités Web
    Création de site internet 78

    Commentaire


    • #3
      Personne n'a d'idée ?
      Actualités Web
      Création de site internet 78

      Commentaire


      • #4
        Bon j'ai réglé le probleme en ne mettant qu'un 0 a la ligne

        `credits` int(11) NOT NULL default '',

        pour la modifier en

        `credits` int(11) NOT NULL default '0',

        si ca ^peut servir quelqu'un par la suite
        Actualités Web
        Création de site internet 78

        Commentaire


        • #5
          Envoyé par pfff Voir le message
          Bon j'ai réglé le probleme en ne mettant qu'un 0 a la ligne

          `credits` int(11) NOT NULL default '',

          pour la modifier en

          `credits` int(11) NOT NULL default '0',

          si ca ^peut servir quelqu'un par la suite
          Bonjour,

          Cela m'intéresse car j'ai le même problème.

          Ou se trouve la ligne à modifier ? Dans un fichier du pack Bookmarks avant l'installation ?

          Merci d'avance pour la précision.

          A +

          Jérôme

          Commentaire


          • #6
            Envoyé par jhautier Voir le message
            Bonjour,

            Cela m'intéresse car j'ai le même problème.

            Ou se trouve la ligne à modifier ? Dans un fichier du pack Bookmarks avant l'installation ?

            Merci d'avance pour la précision.

            A +

            Jérôme
            Ok j'ai trouvé, c'est dans le fichier bookmarks_install

            A modifier avant installation.

            Jérôme

            Commentaire


            • #7
              oui dans kle fichier .xml
              Actualités Web
              Création de site internet 78

              Commentaire


              • #8
                bonjour après avoir lu les différents post et la correction proposée dans le fichier d'install, le composant est bien installé et dans le backend fonctionne
                par contre après avoir fait un link dans un de mes menu vers le composant, voici l'erreur
                une idée ? merci


                Class 'sef_bookmarks' not found in /home/www/html/components/com_sef/joomsef.php(106) : eval()'d code on line 1

                Commentaire


                • #9
                  Il semble que la version béta 2.72 s'installe un peu mieux
                  olivier

                  Commentaire


                  • #10
                    Bonjour,
                    pour ma part j'ai réglé mon soucis en désactivant Joomsef pour ce composant.

                    fr

                    Commentaire


                    • #11
                      Bonjour,

                      J'ai les mêmes problèmes avec JoomSEF + bookmark (voir sujet http://forum.joomla.fr/showthread.php?t=23697 )

                      Comment avez-vous fait pour désactiver JoomSEF juste pour ce composant ?

                      Stéphane

                      Commentaire


                      • #12
                        Merci beaucoup ça marche
                        Création de sites web Tunisie : http://www.idealconception.com
                        http://www.italianistica-tunisia.com

                        Commentaire


                        • #13
                          Bonjour à tous !

                          J'utilise Joomla depuis peu, et j'ai un problème avec Bookmarks. J'ai téléchargé le pack, modifié le fichier XML. Lors de l'installation du composant, je n'ai plus les erreurs MySQL, mais en revanche, j'ai

                          File /(...)/www/media/install_47e64a361936c/bookmarks.class.php does not exist!

                          En effet, le dossier install_47e64a361936c n'existe pas dans le FTP. Que dois-je faire ? Ai-je sauté une étape ?

                          Merci de votre aide !

                          Commentaire


                          • #14
                            Super ça marche au poil, merci beaucoup !

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X