Joomladay francophone 2018 à Paris 18 et 19 mai

Sobi2 et Google Maps

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Sobi2 et Google Maps

    Bonjour à tous,

    Le lien vers google maps était en allemand, je l'ai donc modifié vers le français (Belgique). Cela fonctionne sauf pour les adresses comportant une lettre avec un accent tel que chaussée. En effet, il me dirige vers le google en allemand avec la carte de l'Europe.
    Quelqu'un peut-il m'aider ?
    Merci d'avance.
    Dernière édition par Yasmine à 13/11/2007, 13h13
    Tout s'arrange toujours, même ... mal. Bernard Lavilliers
    yakalire

  • #2
    Je ne connais pas spécialement SOBI mais pour google maps il suffit que ton adresse soit du type :

    numéro+rue+codepostal+ville+pays

    ce qui donne par exemple :

    14+rue+chaussée+d+antain+75000+paris+france

    chez moi ce type d'adresse fonctionne tout le temps.
    http://www.christophehagnere.fr
    Joomladay, j'y serai ====> http://joomladay.fr/
    AUCUN support ne sera fait par MP

    Commentaire


    • #3
      Elle est de ce type. D'ailleurs, ça fonctionne quand il n'y a pas d'accent
      Tout s'arrange toujours, même ... mal. Bernard Lavilliers
      yakalire

      Commentaire


      • #4
        Envoyé par chessman Voir le message
        Je ne connais pas spécialement SOBI mais pour google maps il suffit que ton adresse soit du type :

        numéro+rue+codepostal+ville+pays

        ce qui donne par exemple :

        14+rue+chaussée+d+antain+75000+paris+france

        chez moi ce type d'adresse fonctionne tout le temps.
        C'est ton adresse ?
        Tout s'arrange toujours, même ... mal. Bernard Lavilliers
        yakalire

        Commentaire


        • #5
          non c'est une adresse prise au hasard. Je ne suis pas de Paris mais j'y traine souvent.

          O fait : le retour de buzz l'éclair yasmine lol.
          http://www.christophehagnere.fr
          Joomladay, j'y serai ====> http://joomladay.fr/
          AUCUN support ne sera fait par MP

          Commentaire


          • #6
            Sorry mais je ne comprends pas avec buzz l'éclair. Explique stp
            Tout s'arrange toujours, même ... mal. Bernard Lavilliers
            yakalire

            Commentaire


            • #7
              Tu réponds toujours plus vite que ton ombre tel l'éclair.

              Sinon pour google maps tu peux utiliser indifféremment les accents ou non dans l'adresse car le script remet tout ca en ordre chez eux directement (j'ai fait pleins de testes pour le site que je suis en train de finaliser pour avoir de jolies cartes).
              http://www.christophehagnere.fr
              Joomladay, j'y serai ====> http://joomladay.fr/
              AUCUN support ne sera fait par MP

              Commentaire


              • #8
                Mais non !!!! je viens de dire que justement, chez moi, ça ne marche pas. Mes adresses sont encodées normalement, comme il se doit. Ceux dont les rues n'ont pas d'accent, ça marche, mais pas les autres.
                Il y a donc une config quelque part à faire
                Tout s'arrange toujours, même ... mal. Bernard Lavilliers
                yakalire

                Commentaire


                • #9
                  Pour preuve "chaussée" dans google maps devient "chauss?e"
                  Tout s'arrange toujours, même ... mal. Bernard Lavilliers
                  yakalire

                  Commentaire


                  • #10
                    Bonsoir,

                    Je viens d'avoir ce même problème, et pense avoir solutionné.

                    Dans la configuration de l'affichage, dans le champs : URL de routage il y a l'adresse : http://maps.google.fr/?ie=UTF8&hl=fr&q=STREET ZIPCODE CITY

                    Je me suis aperçu qu'à la place du fr que j'ai mis en rouge, j'avais un (ds). J'avais alors des cartes googlemap en Allemand avec de fausses coordonnées.

                    Depuis que j'ai mis le fr, je n'ai plus de problémes!!!

                    Est-ce la bonne solution?

                    Tiens moi au courant.

                    Commentaire


                    • #11
                      Je pense m'être mal exprimée. Lorsque je dis avoir modifié en français (Belgique), c'est justement en ayant remplacé les "de" en "be" pour la Belgique.
                      Voici ce que j'ai mis
                      http://maps.google.be/?ie=UTF8&hl=be&q=STREET+ZIPCODE+CITY+COUNTY+FEDSTATE+COUNTRY
                      Une adresse telle que "rue de village" fonctionne sans problème mais à chaque fois qu'il y a un accent dans l'adresse comme "chaussée Brunehault", "rue rivière", il me donne la carte de Belgique en entier, dans la barre de recherche il note, par exemple pour "rue rivière" : Rue Rivi?re
                      mais en-dessous (dans la colonne de gauche), il me propose la bonne adresse en me demandant si c'est bien cela que je voulais.

                      Ce qui veut dire que le problème ne vient pas de Google Maps, mais bien du composant
                      Tout s'arrange toujours, même ... mal. Bernard Lavilliers
                      yakalire

                      Commentaire


                      • #12
                        Si quelqu'un s'y connaît en code, voici ce que j'ai pu remarquer :
                        Apparemment la page d'erreur indique pour le "è" de Rivière : %E8

                        Par contre le bon lien transforme le "è" en : %C3%A8
                        Tout s'arrange toujours, même ... mal. Bernard Lavilliers
                        yakalire

                        Commentaire


                        • #13
                          Tiens essaies avec ca :http://maps.google.com/?ie=UTF8&q=ST...TATE+COUNTRYen gros tu met google.com au lieu de googe.be et tu vire hl=be pour voir ce qui ce passe.
                          http://www.christophehagnere.fr
                          Joomladay, j'y serai ====> http://joomladay.fr/
                          AUCUN support ne sera fait par MP

                          Commentaire


                          • #14
                            Je viens de teste mais là il ne trouve rien. Ceci dit c'est un peu normal, si tu élimines toutes traces du pays
                            Tout s'arrange toujours, même ... mal. Bernard Lavilliers
                            yakalire

                            Commentaire


                            • #15
                              pour les belges : google maps et problèmes accents

                              J'avais ce problème aussi...
                              J'ai simplement enlever =UTF8 après IE et ça marche
                              Va comprendre !!!!!

                              http://maps.google.be/?ie&hl=fr&q=STREET ZIPCODE CITY

                              Mais bon, ça marche.

                              A bientôt

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X