Lien des images "mores_images" (changement d'hebergeur)

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Lien des images "mores_images" (changement d'hebergeur)

    Salut à tous,
    j'ai un gros problème, je vien de changé d'hébergeur et j'ai transferé ma base de donnée de l'ancien vers le nouveau mais depuis les images des produits qui devrait s'affichées dans la gallerie "plus d'images" n'y sont plus .
    Je pense qu'il s'agit juste d'un problème de path, je vais le modifier manuellement
    dans la base de donnée.
    J'aimerais savoir par contre dans quel tables je vais pouvoir trouver ces path .

    merci d'avance
    Dernière édition par Asgard à 31/05/2006, 23h26
    Pas de demande de support en MP ou par mail, le forum est là pour ça!
    Joomla Ecommerce terminé grace à la communauté joomla , merci à tous. Maintenant je squate http://www.pc-tuning.fr
    http://www.mx-console.com
    http://www.alsace-boutique.fr prevu pour mars 2007

  • #2
    Salut,
    je ne crois pas que les chemins soient stockés dans la bdd. Plutot dans le virtuemart.cfg.php.
    Mais as tu bien le répertoire resized dans component/com_virtuemart/shop_image/product
    soit
    component/com_virtuemart/shop_image/product/resized
    Parce que a priori le hack en a besoin de ce répertoire.

    Didier

    Commentaire


    • #3
      salut didier , oui j'ai bien ce répertoire dans mon ftp, par contre quand je clic droit sur les images manquantes je vois apparaitre l'adresse de mon encien hébergeur donc c'est pour cette raison que j'ai pensé à un problème de path.
      Aie aie c'est la pagaille.
      Pas de demande de support en MP ou par mail, le forum est là pour ça!
      Joomla Ecommerce terminé grace à la communauté joomla , merci à tous. Maintenant je squate http://www.pc-tuning.fr
      http://www.mx-console.com
      http://www.alsace-boutique.fr prevu pour mars 2007

      Commentaire


      • #4
        en éditant le code source de la page d'un produit on trouve ce lien pour l'image en question :
        Code:
        <a href="http://pctuning.celeonet.fr/new/components/com_virtuemart/shop_image/product/3592_4.jpg" target="_blank" title=""><img class="galimg-deux" src="http://pctuning.celeonet.fr/new/components/com_virtuemart/shop_image/product/resized/3592_4_90x90.jpg" alt="My Title" align="center" width="90" border="0" /></a>
                    </noscript>
        alors qu'il devrait être comem ceci :

        Code:
        <a href="http://www.pc-tuning.fr/new/components/com_virtuemart/shop_image/product/3592_4.jpg" target="_blank" title=""><img class="galimg-deux" src="http://pctuning.celeonet.fr/new/components/com_virtuemart/shop_image/product/resized/3592_4_90x90.jpg" alt="My Title" align="center" width="90" border="0" /></a>
                    </noscript>
        ahh je m'arrache les cheuveux
        Pas de demande de support en MP ou par mail, le forum est là pour ça!
        Joomla Ecommerce terminé grace à la communauté joomla , merci à tous. Maintenant je squate http://www.pc-tuning.fr
        http://www.mx-console.com
        http://www.alsace-boutique.fr prevu pour mars 2007

        Commentaire


        • #5
          Solution --> configuration.php à la racine de ton site
          remplace
          $mosConfig_live_site = 'http://pctuning.celeonet.fr/new';
          par
          $mosConfig_live_site = 'http://www.pc-tuning.fr/new';

          Commentaire


          • #6
            je test de suite , je crois que je t'ais envoyé un mp pour rien
            Pas de demande de support en MP ou par mail, le forum est là pour ça!
            Joomla Ecommerce terminé grace à la communauté joomla , merci à tous. Maintenant je squate http://www.pc-tuning.fr
            http://www.mx-console.com
            http://www.alsace-boutique.fr prevu pour mars 2007

            Commentaire


            • #7
              ah j'avais déja essayé ca
              mais apparement ca ne change pas

              en fait ej me doutais qu'il y aurais un problème avec le configuration .php j'ai donc remis le dossier installation , j'ai réinstaller la totale et ensuite j'ai suprimé la base existant et j'ai remis la base de mon encien hébergeur.
              l'erreur vien peut être de la je en sais plus ou chercher ............
              Dernière édition par Asgard à 31/05/2006, 21h42
              Pas de demande de support en MP ou par mail, le forum est là pour ça!
              Joomla Ecommerce terminé grace à la communauté joomla , merci à tous. Maintenant je squate http://www.pc-tuning.fr
              http://www.mx-console.com
              http://www.alsace-boutique.fr prevu pour mars 2007

              Commentaire


              • #8
                Si tu as changer d'hergeur il faut aussi changer le path

                $mosConfig_cachepath = '';
                $mosConfig_absolute_path = '';

                Commentaire


                • #9
                  Je ne comprend l'historique de tes manoeuvres
                  Tu dis avoir changer d'hebergeurs, et tu dis être revenus avec la base de l'ancien hebergeur. Quelle base avais tu alors pour ce nouveau hebergeur ?
                  L'exportation d'une base doit se faire consciencieusement.
                  En prenant soin des compatibilitées.

                  Commentaire


                  • #10
                    Ok j'ai rien dis,
                    donc ça marche maintenant ?

                    Le fait d'avoir remis le dossier install et d'avoir proceder à l'installation ça a reecrit le fichier configuration.php avec les bons chemins physiques des dossiers.

                    Commentaire


                    • #11
                      en fait je vais être plus précis, j'ai simplement importé ma base depuis mon ancien hébergeur vers le nouveau pour ne pas avoir à remettre tout les produits manuellements etc..

                      J'ai fait une reinstall juste avant l'importation de la base pour justement avoir les bonnes path dans le fichier configuration.php .
                      malgrées les bonnes path cela ne fonctionen plus et je ne sais pas pourquoi .

                      dans le code source d'une fiche produit c'est toujours le lien de l'image vers l'ancien hébergeur qui s'y trouve, et c'est pareil pour chaques produits , toutes les images secondaires ont un mauvais lien
                      Pas de demande de support en MP ou par mail, le forum est là pour ça!
                      Joomla Ecommerce terminé grace à la communauté joomla , merci à tous. Maintenant je squate http://www.pc-tuning.fr
                      http://www.mx-console.com
                      http://www.alsace-boutique.fr prevu pour mars 2007

                      Commentaire


                      • #12
                        Tu peux me donner le lien du produit en question pour que je regarde ?

                        Commentaire


                        • #13
                          oui biensur :
                          http://www.pc-tuning.fr/new/index.ph...mart&Itemid=26
                          Pas de demande de support en MP ou par mail, le forum est là pour ça!
                          Joomla Ecommerce terminé grace à la communauté joomla , merci à tous. Maintenant je squate http://www.pc-tuning.fr
                          http://www.mx-console.com
                          http://www.alsace-boutique.fr prevu pour mars 2007

                          Commentaire


                          • #14
                            bon c'est réparé , alors explications :
                            1) extraction des tables : jos_vm_product_files
                            et remplacement de tout les liens http://pctuning.celeonet.fr/new/components
                            par http://www.pc-tuning.fr/new/components

                            puis importation des tables modifiées et voila ça roule raoul
                            Pas de demande de support en MP ou par mail, le forum est là pour ça!
                            Joomla Ecommerce terminé grace à la communauté joomla , merci à tous. Maintenant je squate http://www.pc-tuning.fr
                            http://www.mx-console.com
                            http://www.alsace-boutique.fr prevu pour mars 2007

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X