Pathway et JSCook menu

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Pathway et JSCook menu

    Bonjour à tout le monde,

    avec un copain, on fait le site d'un de nos potes couteliers avec Joomla et Virtuemart ; ça prend forme progressivement ; on est même carrément ravi. Je bute néanmoins sur un petit bug et je joints des copies d'écran : lorsque je navigue à l'aide du menu de gauche (jscook) vers la catégorie "couteaux" par exemple, il n'y pas de pathway affiché en haut de ma page de catégories (idem si je vais directement à la sous-catégorie "Couteaux pliants").
    En revanche, si je navigue dès le départ, grâce aux images de catégories et de sous-catégories, le pathway s'affiche sans problème.
    Un grand merci pour votre aide et vos conseils.

    Pascal
    Fichiers joints
    Dernière édition par pchevallot à 09/11/2006, 11h30 Raison: [Réglé]

  • #2
    Un petit up ? Quelqu'un aurait une super idée pour ce problème ? Suis-je le seul à l'avoir ? Mille mercis pour votre aide.

    Commentaire


    • #3
      Même problème, non résolu

      bonjour,
      avez-vous résolu votre problème, car j'ai exactement le même. Je poursuis mes recherches et vous tiens au courant si...

      Deuch

      Commentaire


      • #4
        Toujours le probleme

        Bonjour Deuch,

        Non, toujours rien sur le problème de pathway et jscook menu... Désolé. Je cherche en vain mais je vous tiens au courant si je trouve quelque chose.

        Commentaire


        • #5
          bonjour,
          pareil. bon courage
          deuch

          Commentaire


          • #6
            Pathway et JSCook menu - toujours problème

            Bonjour à toutes et à tous,

            Un petit up car visiblement, je n'ai pas beaucoup de chance : personne ne trouve de solution à ce problème apparemment, et j'ai beau chercher, je fais du sur-place. Si un super développeur pouvait jeter un oeil.
            Je redis le problème :
            Lorsque je navigue à l'aide du menu de gauche (jscook) vers la catégorie "couteaux" par exemple, il n'y pas de pathway affiché en haut de ma page de catégories (idem si je vais directement à la sous-catégorie "Couteaux pliants").
            En revanche, si je navigue dès le départ, grâce aux images de catégories et de sous-catégories, le pathway s'affiche sans problème.
            Et d'avance mille mercis si quelqu'un me met sur la voie... de la lumière

            Pascal

            Commentaire


            • #7
              tre joli site peux faire voir les couteau ferme enfin moi j'aime bien voir les deux ouvert et fermeee
              "Méfiez-vous des rêves de jeunesse, ils finissent toujours par se réaliser" toutes les fautes d'orthographe, de grammaire et de syntaxe ci de-dessus, sont propriété de l'auteur elles ne peuve être reproduites ou même corrigées sans son accord préalable

              Commentaire


              • #8
                Toujours probleme pathway et jscook menu

                Bonjour tout le monde,

                Je me permets de faire un petit up, parce que je desespère trouver moi-même la soluce à ce problème d'affichage de pathway avec jscook menu.
                Rappel : pas de pathway affiché quand on passe par le menu jscook de gauche. En revanche, pas de problème, le pathway s'affiche bien si on passe par les images illustrant les catégories et les sous-catégories. Si une âme charitable et connaissant bien ce point pouvait se pencher sur mon problème, je serai aux anges D'avance un grand merci pour toutes les bonnes idées ou solutions.

                Pascal

                Commentaire


                • #9
                  Pathway et JScook menu [Réglé]

                  Bonjour,
                  Grâce à l'aide sur le forum de Virtuemart, ce problème a trouvé sa solution.
                  Explication en français :
                  Dans le fichier modules/vm_JSCook.php, un utilisateur proposait de modifier la ligne :

                  Code PHP:
                  $itemid = isset($_REQUEST['itemid']) ? '&itemid='.$_REQUEST['itemid'] : ""
                  par :
                  Code PHP:
                  $itemid '/Itemid,45'
                  En essayant ces paramètres, cela ne fonctionnait pas : l'explication est la suivante : le '45' n'est pas standard à toutes les installations de VirtueMart. Il peut être 1, 2, 3, 4, etc. Pour trouver le nombre que que vous devez utiliser, vous pouvez cliquer sur un lien dans le pathway et regarder l'itemid qui apparait dans l'URL : cet itemid est le vôtre et vous devez prendre en compte ce nombre.
                  De plus, pour ma part, la ligne de code prenait une forme différente pour fonctionner correctement :

                  Code PHP:
                  $itemid '&Itemid=26'
                  Notez les différences "&" et "=".
                  Merci pour ceux qui m'ont fourni des pistes de recherche, je finissais par me résigner, comme quoi tout arrive.
                  Pascal

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X