VirtueMart 1.0.6 /Module CyberMUT (pscic)

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • VirtueMart 1.0.6 /Module CyberMUT (pscic)

    Bonjour messieurs,

    Je suis en train de tester :

    Joomla 1.0.10
    VirtueMart 1.0.6
    Module de paiement CIC développé par Alataka fourni par www.virtuemart.com

    J'ai contacté le CIC et toute la config est OK :
    Authentification entre mon site et CIC OK
    Paiement refusé ou accepté par la banque OK
    Je suis actuellement en mode test (dir: /test/)

    Mon problème est le suivant :
    Après acceptation ou refus de la banque, dans aucun des cas le statut de la commande dans VirtueMart n'est mis à jour (il reste en Attente) alors que j'ai paramétrer le module pscic pour passer les commandes OK en "confirmée" et les commandes refusées en "Annulée".

    Pourtant, le retour de la banque semble bien s'effectuer car j'obtiens bien un message (sur mon site) précisant le statut du paiement :
    Paiement effectué avec succès (avec CB de test autorisée)
    Echec dans le traitement du réglement (avec CB de test refusée).

    Alataka, aurais-tu une idée lumineuse concernant mon problème ?
    Ou qq1 d'autres )

    Merci pour vos réponses.
    Dernière édition par BigBugz à 28/08/2006, 12h40

  • #2
    Arg!!

    Problème résolu... tout fonctionnait bien coté Joomla/Virtuemart et module CyberMut...

    Mon url de retour n'avait pas été correctement renseignée au niveau du système de paiement en ligne coté Banque..... une fois effectué, TOUT fonctionne beaucoup mieux!!!

    Merci pour les réponses (oops... lol)

    ++

    Commentaire


    • #3
      Yeti, désolé, mais malgré ta procédure pour passer mon sujet en Reglé, je n'ai pas pu le faire... impossible de passer en mode Avancé... aucun préfixe visible et modifiable.

      Commentaire


      • #4
        Bonjour,

        Je viens de lire ton post.

        A tous ceux qui le liront, l'erreur que tu as eu est apparemment une erreur commune car la doc fourni n'est pas hyper explicite, et apparemment, je ne le suis pas assez dans la mienne aussi.

        Mon url de retour n'avait pas été correctement renseignée au niveau du système de paiement en ligne coté Banque..... une fois effectué, TOUT fonctionne beaucoup mieux!!!
        Vérifiez que l'URL de retour que vous donnez à la banque est correct.

        Bonne chance avec ta boutique.
        alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

        Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

        Commentaire


        • #5
          Bnjour tout le monde,

          J'utilise pour la première fois un module de paiement en ligne, et je me suis donc fais guider par cmcic-v4 de ALATAK.

          Tout fonctionne pour l'envoi des données chez CIC mais j'ai un problème qui persiste : je ne sais pas quelle url donner au cic comme url de retour...

          Je ne sais pas quelle url doit récupérer les informations de la banque et permettre à la commande de changer de stratus???

          Je suis perdu,est ce que quelqu'un pourrait m'aider ?

          Merci d'avance pour vos réponses !

          (oui je sais up d'un vieux sujet mais c'est ce qui colle le mieux avec mon probléme !)

          Commentaire


          • #6
            Bonjour,

            J'ai un soucis avec mon TPE cmcic, j'ai bien renseigné mon url retour, mais le statut de la commande ne se modifie pas! Le paiement fonctionne le cgi du cic répond sans erreur, je ne sais pas du tout d'où peut venir ce problème.

            Pour info, j'utilise joomla 1.0.15 et VM 1.0.15

            Merci pour vos réponse

            Commentaire


            • #7
              bonjour,

              Verification numéro 1: quelle est la version du module de paiement?
              alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

              Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

              Commentaire


              • #8
                j'ai trouvé un numéro de version dans checkout.cmcic_cc_form.php

                C'est la v1.1, est-ce cette information que tu voulais? car je ne trouve pas de numéro de version ailleurs dans tes fichiers.

                Commentaire


                • #9
                  Du nouveau alatak?

                  Commentaire


                  • #10
                    Bonjour

                    as tu utilisé cette version:
                    http://alatak.net/telechargements/vo...emart-1.0.html
                    alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                    Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                    Commentaire


                    • #11
                      non je pense que c'est la V2 car le dossier se nomme virtuemart-cmcic 2

                      Commentaire


                      • #12
                        Non j'ai vérifié c'est la version 4 que j'ai utilisé

                        Commentaire


                        • #13
                          Salut,

                          J'utilise la version 5 mais le statut de la commande ne change toujours pas !!!
                          J'ai envoyé un mail sur alatak.net, on verra bien.

                          ++
                          JoomlaSite Integrateur

                          Commentaire


                          • #14
                            Bonjour,

                            je souhaitais savoir si vous avez finalement trouvé une solution pour l'update du statut? car je suis exactement dans la même situation.

                            En fait, tout fonctionne correctement, c'est juste le statut qui ne se met pas à jour.
                            Une fois le paiement effectué, je clique sur "revenir sur la boutique" : la page du site réagit bien en fonction du paiement accepté ou réfusé : par contre rien ne change en back office...

                            Merci de votre aide

                            Commentaire


                            • #15
                              Bonjour,

                              Tu es sur Joomla 1.0 ou 1.5, VM 1.0 ou VM 1.1 ?

                              Es tu sur un site en local? ou chez un hebergeur?
                              As tu renseigné ton URL CGI chez centre-com?
                              As tu verifié que l'URL etait bien renseigné en leur téléphonant?
                              alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                              Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X