PB Virtuemart, eTransaction et 1and1

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • PB Virtuemart, eTransaction et 1and1

    bonjour à tous,


    il semble que le kit eTransaction (celui développé par ATOS, pas PAYBOX) soit incompatible avec 1and1 (en serveur mutualisé sous linux).
    Les fichiers fournis par eTransaction (SIPS 600 - pour le compte du Crédit Agricole) ne sont pas des cgi, donc non exécutables par les scripts développés par Alataka dans Virtuemart.

    1and1 exige 3 choses pour exécuter des cgi:
    >1/ le fichier doit être en CHMOD 755
    >2/ se terminer par ".cgi"
    >3/ le code doit commencer par "#!/usr/bin/perl"

    vous pouvez également lire les infos 1and1 ici:
    http://faq.oneandone.co.uk/script_co...options/1.html

    Est-ce que qqn a déjà été confronté à ce problème??


    solution : PAYBOX ou changer d'hébergeur ou passer en serveur dédié?

  • #2
    Il faut voir si les scripts transmis par le crédit agricole sont des scripts perl.
    Freelance PHP LAMP
    http://www.nicolasfischer.com

    Commentaire


    • #3
      J'attends la réponse du support technique de 1and1.
      Mais en utilisant le contrôle de synthaxe perl mis à disposition par 1and1, voici la réponse :
      - cgi: File has no correct script header (should be #! /usr/bin/perl)
      (no output)

      Les fichiers fournis par eTransaction sont compilés et eTransaction ne les fait évoluer sur demande. eTransaction m'a donc orienté vers PAYBOX... mais cela voudrait dire que les beaux scripts Alatak sont OUT! et ça m'embête de ne pas capitaliser sur ce travail!

      Commentaire


      • #4
        Salut, mon site est chez 1and1 , j'ai virtuemart 1.05 avec paiement CB par e-transaction sips 600 et tout fonctionne très bien, le script CGI donné par le crédit agricole fonctionne donc bien chez 1and1....
        Le fichier doit effectivement être en 755, ce qui est normal mais par contre les fichiers de l'API (request et response) qui contienne les CGI reste sans extension sur le serveur et peuvent être placé n'importe où à condition de bien paramétrer le chemin absolu vers ceux-ci dans le fichiers ps_sips.cfg.php (paramètre SIPS_CGI_BIN_PATH)...
        Le code ne doit pas non plus forcément commencer par "#!/usr/bin/perl" ...
        Dit moi en plus sur ton problème exact, je pourrai peut-être t'aider en t'indiquant le paramétrage de mes différents fichiers e-transaction et sips !

        @+
        www.salaison.fr : vente en ligne de saucissons de savoie !!
        Salma ou Pénélope ? --> Voter pour : http://forum.joomlafacile.com/showthread.php?t=9926

        Commentaire


        • #5
          Bonsoir,


          J'ai déjà installé plusieurs fois le kit de paiement SIPS chez 1&1, et je n'ai pas eu de problème du tout.
          Les fichiers request.exe et response.exe s'executent sans problème .
          alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

          Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

          Commentaire


          • #6
            Envoyé par escape74
            Salut, mon site est chez 1and1 , j'ai virtuemart 1.05 avec paiement CB par e-transaction sips 600 et tout fonctionne très bien, le script CGI donné par le crédit agricole fonctionne donc bien chez 1and1....
            Le fichier doit effectivement être en 755, ce qui est normal mais par contre les fichiers de l'API (request et response) qui contienne les CGI reste sans extension sur le serveur et peuvent être placé n'importe où à condition de bien paramétrer le chemin absolu vers ceux-ci dans le fichiers ps_sips.cfg.php (paramètre SIPS_CGI_BIN_PATH)...
            Le code ne doit pas non plus forcément commencer par "#!/usr/bin/perl" ...
            Dit moi en plus sur ton problème exact, je pourrai peut-être t'aider en t'indiquant le paramétrage de mes différents fichiers e-transaction et sips !

            @+
            Merci pour ton aide. Le support technique 1&1 a évoqué un changement technique entre les premiers clients et les nouveaux... peut-être que ton hébergement accepte les exécutables autres que cgi. Mon hébergement ne les accepte apparemment pas. Le support technique m'a dit qu'en revanche si j'optais pour un hébergement dédié je pourrai exécuter d'autres fichiers.
            As-tu un hébergement mutualisé ou dédié?

            Mais bien sûr ce ne sont que des hypothèses... je veux bien essayer de nouveaux paramétrages!

            En fait tout le problème vient du fait que la fenêtre SIPS (qui permet de saisir nom, n° de carte, cryptogramme) ne s'ouvre pas.

            j'ai passé en revue les erreurs les plus répandues mentionnées dans le forum :
            1/ le payment extra info est bien (sans espace)
            <?php require_once(PAGEPATH.'checkout.sips_cc_form.php' ); ?>

            2/ le CHMOD est 755

            au secours!!!

            Commentaire


            • #7
              Je suis en hébergement mutualisé et les éxecutables que e-transaction t'ont donné contienne bien les cgi nécessaire...et je suis quasiment sûr que tu peux les éxécuter sur 1and1...
              lorsque ta commande est validé, sur la page de remerciement, les icone visa et mastercard aparraissent ou pas ?
              www.salaison.fr : vente en ligne de saucissons de savoie !!
              Salma ou Pénélope ? --> Voter pour : http://forum.joomlafacile.com/showthread.php?t=9926

              Commentaire


              • #8
                Bonsoir,

                Les installations de SIPS que j'ai faite chez 1&1 sont aussi sur des hébergements mutualises.
                alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                Commentaire


                • #9
                  Envoyé par escape74
                  Je suis en hébergement mutualisé et les éxecutables que e-transaction t'ont donné contienne bien les cgi nécessaire...et je suis quasiment sûr que tu peux les éxécuter sur 1and1...
                  lorsque ta commande est validé, sur la page de remerciement, les icone visa et mastercard aparraissent ou pas ?
                  un message d'espoir !
                  lorsque ma commande est validée, pas de page de remerciement, pas d'icone visa ou mastercard

                  en fait, lorsque je choisis le mode de règlement, voici le message qui apparait en mode débug:

                  Problème de configuration de la méthode de paiement.
                  Le fichier éxecutable nommé 'request' n'a pas été trouvé.
                  - Vérifier que le chemin spécifié lors de la configuration de la méthode de paiement est correcte.
                  - Vérifier que vous avez copié le fichier 'request' dans le bon répertoire.
                  - Vérifier les droit d'accès du fichier 'request'.
                  Chemin que vous avez configuré pour l'éxecutable: homepages/30/dxxxxxxxxx/htdocs/cgi-bin/
                  Fichier executable appelé: homepages/30/dxxxxxxxxx/htdocs/cgi-bin/request.cgi

                  ... j'ai vérifier les 3 points.
                  j'ai essayé de renommer les fichiers 'request' avec et sans suffixe 'cgi'
                  pour l'appel du 'request' comment est-ce que je peux faire en sorte que l'appli appelle 'request' et non 'request.cgi' comme indiqué dans le message de debug?
                  Dernière édition par migdalo à 13/09/2006, 00h39

                  Commentaire


                  • #10
                    voici la réponse de 1&1 à propos de l'utilisation de CGI :

                    "e-transactions propose 2 solutions techniques.

                    La première, fourni par ATOS, fonctionne avec 2 exécutablesqui ne sont pas des CGI. C'est celle que vous utilisez actuellement et ellen'est pas compatible avec les demandes de votre hébergeur.

                    La deuxième, fournie par PAYBOX, fonctionne avec unCGI. Cette solution technique correspond aux demandes de votre hébergeur."


                    pour rappel les demande de 1&1 sont :
                    "
                    >1/ le fichier doit être en CHMOD 755
                    >2/ se terminer par ".cgi"
                    >3/ le code doit commencer par"#!/usr/bin/perl""

                    Commentaire


                    • #11
                      Envoyé par migdalo
                      Problème de configuration de la méthode de paiement.
                      Le fichier éxecutable nommé 'request' n'a pas été trouvé.
                      - Vérifier que le chemin spécifié lors de la configuration de la méthode de paiement est correcte.
                      - Vérifier que vous avez copié le fichier 'request' dans le bon répertoire.
                      - Vérifier les droit d'accès du fichier 'request'.
                      Chemin que vous avez configuré pour l'éxecutable: homepages/30/d117797446/htdocs/cgi-bin/
                      Fichier executable appelé: homepages/30/d117797446/htdocs/cgi-bin/request.cgi
                      J'ai eu ce message d'erreur aussi, je pense que tu as un paramètre incorrect dans tes fichiers sips...demain je te donnerai mes fichiers de config et on vérifiera si tout est bien paramétré
                      www.salaison.fr : vente en ligne de saucissons de savoie !!
                      Salma ou Pénélope ? --> Voter pour : http://forum.joomlafacile.com/showthread.php?t=9926

                      Commentaire


                      • #12
                        Envoyé par escape74
                        J'ai eu ce message d'erreur aussi, je pense que tu as un paramètre incorrect dans tes fichiers sips...demain je te donnerai mes fichiers de config et on vérifiera si tout est bien paramétré

                        merci !
                        Dernière édition par migdalo à 01/10/2006, 21h27

                        Commentaire


                        • #13
                          Envoyé par nfischer
                          Il faut voir si les scripts transmis par le crédit agricole sont des scripts perl.
                          Voici la réponse du support technique 1&1 :

                          "il ne s’agit pas de script exécutable mais d’exécutable, de binaire si vous préféré.
                          Le code source une fois compilé n’a plus de lien avec le langage dans lequel il a été écrit.
                          Cordialement,
                          Support Technique"

                          Commentaire


                          • #14
                            Salut, voici toute ma config : j'ai créé un répertoire cgi-bin à la racine du site dans lequel j'ai placé les deux éxécutables request et response. Toujours à la racine du site j'ai un autre répertoire nommé sips qui contient un dossier logo et un dossier param (qui contient ton certificat certif.fr.044387490100021, parmcom.044387490100021 et parcom.e-transactions aisni que ton fichier pathfile).

                            Le contenu de ton fichier pathfile chez 1&1 doit resembler à ça :

                            D_LOGO!http://www.tonsite.fr/sips/logo/!

                            F_DEFAULT!/homepages/10/d140445423/htdocs/sips/param/parmcom.e-transactions!

                            F_PARAM!/homepages/10/d140445423/htdocs/sips/param/parmcom!

                            F_CERTIFICATE!/homepages/10/d140445423/htdocs/sips/param/certif!

                            Le dernier fichier de config important est ps_sips.cfg.php (qui se trouve dans le dossier classes puis le dossier payement) que tu peux paramétrer via le panneau d'admin dans ta méthode de paiement ou alors manuellement. Voici à quoi ressemble le mien :
                            Code PHP:
                            <?php
                            defined
                            ('_VALID_MOS') or die('Direct Access to this location is not allowed.'); 
                            define ('SIPS_MERCHANT_ID''044387490100021');
                            define ('SIPS_PARCOM''e-transactions');
                            define ('SIPS_CGI_BIN_PATH''/homepages/10/d140445423/htdocs/cgi-bin/');
                            define ('SIPS_VERIFIED_STATUS''C');
                            define ('SIPS_INVALID_STATUS''N');
                            define ('SIPS_DEBUG''no');
                            define ('SIPS_PAYMENT_MEANS''');
                            define ('SIPS_HEADER_FLAG''yes');
                            define ('SIPS_BLOCK_ALIGN''center');
                            define ('SIPS_BLOCK_ORDER''');
                            define ('SIPS_SUBMIT_LOGO''submit_logo.gif');
                            define ('SIPS_NORMAL_RETURN_LOGO''return_logo.gif');
                            define ('SIPS_CANCEL_RETURN_LOGO''cancel_logo.gif');
                            define ('SIPS_TEMPLATE''merchant_template');
                            define ('SIPS_CAPTURE_MODE''AUTHOR_CAPTURE');
                            define ('SIPS_CAPTURE_DAY''6');
                            ?>
                            Si tu as des questions n'hésite pas !
                            Bon courage

                            PS : les n° sont bien sur fictif mais le nombre de chiffre est exact....
                            www.salaison.fr : vente en ligne de saucissons de savoie !!
                            Salma ou Pénélope ? --> Voter pour : http://forum.joomlafacile.com/showthread.php?t=9926

                            Commentaire


                            • #15
                              Envoyé par escape74
                              Salut, voici toute ma config : j'ai créé un répertoire cgi-bin à la racine du site dans lequel j'ai placé les deux éxécutables request et response. Toujours à la racine du site j'ai un autre répertoire nommé sips qui contient un dossier logo et un dossier param (qui contient ton certificat certif.fr.044387490100021, parmcom.044387490100021 et parcom.e-transactions aisni que ton fichier pathfile).

                              Le contenu de ton fichier pathfile chez 1&1 doit resembler à ça :

                              D_LOGO!http://www.tonsite.fr/sips/logo/!

                              F_DEFAULT!/homepages/10/d140445423/htdocs/sips/param/parmcom.e-transactions!

                              F_PARAM!/homepages/10/d140445423/htdocs/sips/param/parmcom!

                              F_CERTIFICATE!/homepages/10/d140445423/htdocs/sips/param/certif!

                              Le dernier fichier de config important est ps_sips.cfg.php (qui se trouve dans le dossier classes puis le dossier payement) que tu peux paramétrer via le panneau d'admin dans ta méthode de paiement ou alors manuellement. Voici à quoi ressemble le mien :
                              Code PHP:
                              <?php
                              defined
                              ('_VALID_MOS') or die('Direct Access to this location is not allowed.'); 
                              define ('SIPS_MERCHANT_ID''044387490100021');
                              define ('SIPS_PARCOM''e-transactions');
                              define ('SIPS_CGI_BIN_PATH''/homepages/10/d140445423/htdocs/cgi-bin/');
                              define ('SIPS_VERIFIED_STATUS''C');
                              define ('SIPS_INVALID_STATUS''N');
                              define ('SIPS_DEBUG''no');
                              define ('SIPS_PAYMENT_MEANS''');
                              define ('SIPS_HEADER_FLAG''yes');
                              define ('SIPS_BLOCK_ALIGN''center');
                              define ('SIPS_BLOCK_ORDER''');
                              define ('SIPS_SUBMIT_LOGO''submit_logo.gif');
                              define ('SIPS_NORMAL_RETURN_LOGO''return_logo.gif');
                              define ('SIPS_CANCEL_RETURN_LOGO''cancel_logo.gif');
                              define ('SIPS_TEMPLATE''merchant_template');
                              define ('SIPS_CAPTURE_MODE''AUTHOR_CAPTURE');
                              define ('SIPS_CAPTURE_DAY''6');
                              ?>
                              Si tu as des questions n'hésite pas !
                              Bon courage

                              PS : les n° sont bien sur fictif mais le nombre de chiffre est exact....
                              ---

                              super c'est très sympa!

                              je vais regarder ça en détail.
                              a tout hasard, voici la version du kit envoyé par eTransaction : etransactions_p600_PLUGIN_linux-2.6.9

                              peut-être est-ce un problème de version de kit??

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X