Joomladay francophone 2018 à Paris 18 et 19 mai

Autoresponse - Retour Boutique

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Autoresponse - Retour Boutique

    Bonjour,

    J'ai un problème et je ne sais pas si c'est du même genre mais ça urge et je galère depuis pas mal de temps.
    En fait, j'utilise le module sips de alatak et je voudrais que le client ne soit pas obligé de cliquer sur "retour à la boutique" pour que la commande soit confirmée sur mon site.

    La banque me parle d'auto response...
    Je ne sais pas comment la configurer.

    Merci pour votre aide.

  • #2
    up

    Commentaire


    • #3
      Pire mon autoresponse n'est pas appelé par la banque. C'est peut être parce que je suis sur le serveur de démo ?
      Dernière édition par gamani à 04/12/2007, 10h57

      Commentaire


      • #4
        Bonjour

        En fait, j'utilise le module sips de alatak et je voudrais que le client ne soit pas obligé de cliquer sur "retour à la boutique" pour que la commande soit confirmée sur mon site.
        Comme tu utilises le module de paiement que j'ai développé, je te précise que le statut de la commande est mis à jour avec l'auto response, et que le client n'a pas besoin de cliquer sur le bouton "retour la boutique" pour le statut se mette à jour.

        Pire mon autoresponse n'est pas appelé par la banque. C'est peut être parce que je suis sur le serveur de démo ?
        L'unique cas où l'autoresponse ne marche pas est lorsque tu testes ta boutique en local. Dans tous les autres cas, cela doit marcher. Si ce n'est pas le cas, il faut que tu me décrives un peu plus la situation.
        alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

        Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

        Commentaire


        • #5
          Salut,

          J'ai changé l'adresse de retour avec l'url de réponse automatique et ça marche dans ce cas là quand je clique sur le bouton retour à la boutique.

          Donc ton script marche mais il n'est pas appelé automatiquement par la banque

          Commentaire


          • #6
            Normalement, tu installes le module de paiement tel que je l'ai indiqué, tu le configures, et tu n'as pas à changer le code du tout, surtout pas. Tu n'as rien d'autre à faire.

            la procédure à suivre est celle là;:
            Configuration de Virtuemart avec SIPS
            alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

            Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

            Commentaire


            • #7
              Merci mais c'est exactement ce que j'ai suivi.

              Mon automatic_response_url est : https://monsite.com/administrator/co...toresponse.php

              Il n'est pas appelé par la banque de démo...

              Commentaire


              • #8
                - L'URL est appelé automatiquement lorsque le script checkout.sips_cc_form.php est appelé. C'est dans le code. Tu n'as rien à faire.

                - Ton site est en HTTPS? pourquoi? normalement tu n'as pas besoin de HTTPS.
                alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                Commentaire


                • #9
                  - L'URL est appelé automatiquement lorsque le script checkout.sips_cc_form.php est appelé. C'est dans le code. Tu n'as rien à faire.

                  Oui je sais mais il ne se passe rien, je suis sur la page de la banque validée. Je ferme la fenetre mais j'ai pas de retour

                  - Ton site est en HTTPS? pourquoi? normalement tu n'as pas besoin de HTTPS.

                  Même en http tout court ça ne passe pas

                  Commentaire


                  • #10
                    Même en http tout court ça ne passe pas
                    Je ne comprends pas ce que tu veux dire. Je pense qu'il faut résoudre ce problème d'abord. Ton site doit marcher en http.
                    alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                    Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                    Commentaire


                    • #11
                      Excuse moi je me suis mal exprimé. Je veux simplement dire que l'automatic response ne marche pas, sans rien toucher au code et en étant en http.

                      Commentaire


                      • #12
                        Je suis formel j'ai regardé les logs d'apache, j'ai aucune ligne faisant appel à autoresponse.

                        Dans la doc ils mettent :
                        Enfin, si votre script de réponse automatique fonctionne quand il est appelé via l'URL de réponse manuelle, mais ne fonctionne pas via l'URL de réponse automatique, il y a probablement un cookie, une redirection, ou toute autre chose nécessitant la présence d’un navigateur dans le code de votre script call_autoresponse.
                        Une idée ?
                        Dernière édition par gamani à 04/12/2007, 17h08

                        Commentaire


                        • #13
                          Hello,

                          Je suis toujours bloqué sur ma réponse auto. Je n'ai pas de traces d'un serveur atos en POST sur mes logs ...

                          Petite parenthèse dans le script d'alatak j'ai du changé order_id par transaction_id dans la requete car order_id avait la valeur de 9102 au lieu de 102.

                          SELECT order_id FROM #__{vm}_orders WHERE MOD(order_id,1000000)='9102' < Marche pas
                          Dernière édition par gamani à 05/12/2007, 14h25

                          Commentaire


                          • #14
                            Est ce que tu as configuré correctement les statuts (cf image)?
                            Fichiers joints
                            alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                            Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                            Commentaire


                            • #15
                              Hello,

                              Ce n'est pas un problème de statut, je parle de la requete

                              La banque me retourne comme order_id 9102 au lieu de 102 que je leur ai correctement envoyé...
                              Dernière édition par gamani à 07/12/2007, 15h00

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X