AIDEZ MOI !!!!! Affichage de différents Module, alors que j'en veut pas !(virtuemart)

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • AIDEZ MOI !!!!! Affichage de différents Module, alors que j'en veut pas !(virtuemart)

    Bonjour à tous !
    J'essai de me faire comprendre mais c'est pas évident vu que le problème est un peu bizarre...
    Je vous propose donc de jeter un oeil directement... http://www.arbodirect.fr/index.php

    Il s'agit de joomla 1.05 + virtuemart

    Le probleme est que j'ai créé mes propres modules avec leurs propres positions.
    C'est modules (promotions, a saisir, en aperçu, occasions), doivent s'afficher uniquement lorsque nous sommes sur la page d'accueil du site (index.php).
    Pour chaques modules, sur ma page index.php de mon template j'ai ajouté ce code :
    Code PHP:
    <?
    if (mosCountModules"user2" )) 
    {
    mosLoadModules 'user2'); 
    }
    ?>
    Coté administrator, j'ai bien crée les positions, puis dans la gestion des modules je spécifie bien un affichage uniquement sur la page d'accueil.

    Et là SURPRISE ! je retrouve sur chacunes de mes pages virtuemart (produits, catégories, listing produits, recherche etc) mes modules alors qu'ils ne devraient pas etre affichés...

    JE VOUS PROMET JE DEVIENS FOU ET CELA EST TRES URGENT !!!


    SVP J'IMPLORE VOTRE AIDE !!!

    PS : pour info...il arrive parfois qu'ils n'apparaisent pas....AUCUNE LOGIQUE

    JE VOUS REMERCIE, DAVID
    Dernière édition par cyberswell à 27/02/2006, 15h25

  • #2
    je viens d'essayer pendant 10 min, je ne les vois pas sur les autres pages.
    Peut etre est ce du à ton cache ? purge le et re-essaye.
    par contre sous mon FF ou IE, les onglets en haut ne fonctionnent pas.

    (ps très joli site ! mes félicitations si le template est de toi !)

    Nico
    cours de SVT - infos scientifiques : www.nicolas-ogier.fr
    pas de demandes d'aide par mp, elles seront systématiquement refusées !

    Commentaire


    • #3
      - C'est ce que je disais...une fois sur 2 cela fonctionne.. CA ME GONFLE...il faut cliquer un peu partout afin de forcer l'erreur...
      JE SUIS DESEPERE !

      - Merci pour ton compliment, oui le template et de moi et c'est normal por les onglets...le site n'est pas encore finis...NORMAL JE PERD DU TEMPS SUR UNE FOUTU ERREUR !!

      merci de ta réponse...
      POST non réglé.....

      Commentaire


      • #4
        Je viens de reperer quelque chose..si ca peut aider dans vos investigations !!

        j'ai réussi à choper l'url d'une meme page, l'une avec les modules (grrr) et l'autre qui est nickel...

        Regardez c'est abérant ! la variable de Itemid change alors que j'ai fais la meme démarche pour acceder à cette page :

        PAGE QUI FONCTIONNE
        http://www.arbodirect.fr/index.php?o...id=19&Itemid=9

        PAGE QUI FONCTIONNE PAS
        http://www.arbodirect.fr/index.php?o...id=19&Itemid=1

        Commentaire


        • #5
          délire, et je n'arrive pas à la reproduire, mais c'est vrai que s'il on tape Itemid=1 ca merde !

          S'il y a quelqu'un qui connait virtualmark, pouvez vous l'aider ?

          Merci !

          Nico
          cours de SVT - infos scientifiques : www.nicolas-ogier.fr
          pas de demandes d'aide par mp, elles seront systématiquement refusées !

          Commentaire


          • #6
            Ca ne marche pas !!! du moins si vous allez sur le site et que vous suivez ma démarche....

            http://www.arbodirect.fr/index.php
            Puis dans le menu de gauche "Catalogue Général" -> "Moto Pompe"

            et là THEORIQUEMENT les modules s'affichent alors qu'ils ne devraient pas !!!

            C'est incroyable.

            Commentaire


            • #7
              je me permet de vous montrer mon fichier index.php pour que vous puissiez jeter un oeil...on ne sais jamais.

              Encore merci
              Fichiers joints

              Commentaire


              • #8
                bonjour,

                quel type d'entrée utilise tu dans ton menu manager ?
                des url-link ?

                Commentaire


                • #9
                  Solution trouvé sur joomla.org par infograf768 :

                  Installer le bot mosloadposition qui permet d'appeler mes positions... (http://www.bpixel.com/content/view/70/65/)

                  puis creer un article qui sera mis en en frontpage contenant les differents appels à mes différents modules via la fonction {mosloadposition maposition}
                  .

                  J'espere que vous avez compris. En tous ca cela marche

                  Voici le lien sur le forum de joomla.org : http://forum.joomla.org/index.php?to...;topicseen#new

                  Merci à tous pour votre investissement personnel et longue vie à joomla !
                  [POST REGLE]

                  Commentaire


                  • #10
                    Peut etre une solution alternative d'apres doo89 :

                    "Peut-être une solution, elle fonctionne chez moi
                    (EN LOCALE)

                    Dans ton template a l'emplacement de ta position de module mets ce code ou adapte le a ta convenance:
                    Code:
                    <?php

                    function url_actuelle()
                    {
                    return "http://" . $_SERVER["SERVER_NAME"] . $_SERVER["REQUEST_URI"];
                    }


                    $URLtest1=$mosConfig_live_site."/index.php?option=com_frontpage&Itemid=1";
                    $URLtest2=$mosConfig_live_site."/index.php";
                    $URLtest3=$mosConfig_live_site."/";

                    $testURL=url_actuelle();


                    if ($URLtest3==$testURL or $URLtest2==$testURL or $URLtest1==$testURL){
                    mosLoadModules ( 'user2' );
                    }else{
                    }

                    ?>

                    Remplace le mosLoadModules ( 'user2' ); par le code de ton module ou ta condition :
                    Citation:
                    Code:
                    <?
                    if (mosCountModules( "user2" ))
                    {
                    mosLoadModules ( 'user2');
                    }
                    ?>

                    Voilà, je vais pouvoir dormir tranquille.

                    A TESTER EN LIGNE "
                    Vu sur : http://forum.mamboportail.net/viewto...?p=41888#41888

                    Commentaire


                    • #11
                      Mode Regle Stp

                      Vas dans le debut de ton post modifie le va dans avance et fais suge regle stp.Merci

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X