Virtuemart erreurs lors chargement d'images

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Virtuemart erreurs lors chargement d'images

    Erreurs lors de la saisie d'images dans VirtueMArt.

    16/2/2006 toujours pas de solution

    Depuis ce matin (lundi 13/02/2006) lors du chargement d'images nous avons ces erreurs (dans partie administrateur):

    Warning: imagejpeg(): Restriction in effect. Access to this file (/var/www/free.fr/5/6/mulhouse.autos/components/com_virtuemart/shop_image//product/resized/
    01b07fabc5b451cc525aea00f29f516f_90x90.jpg) is not allowed in /var/www/sdb/5/6/mulhouse.autos/administrator/components/com_virtuemart/classes/class.img2thumb.php on line 284

    Warning: imagejpeg(): Invalid filename '/var/www/free.fr/5/6/mulhouse.autos/components/com_virtuemart/shop_image//product/resized/
    01b07fabc5b451cc525aea00f29f516f_90x90.jpg' in /var/www/sdb/5/6/mulhouse.autos/administrator/components/com_virtuemart/classes/class.img2thumb.php on line 284

    Erreur: Cannot read uploaded thumbnail image temp file: /var/www/free.fr/5/6/mulhouse.autos/components/com_virtuemart/shop_image//product/resized/
    01b07fabc5b451cc525aea00f29f516f_90x90.jpg.
    One common reason for this that the upload path cannot be accessed because of the open_basedir settings in the php.ini.


    J'ai vérifié la présence de la table qui contient les images - elle est bien là-. 81 occurence(s) dans la table jos_vm_product

    Qui aurait une idée??

    Le site ne présente pas d'anomalie et les images des différents produits chargés avant aujourd'hui (lundi 13/2/2006) sont toujours visibles sur http://mulhouse.autos.free.fr.
    Par contre les nouveaux produits sont sans image.

    Merci
    Dernière édition par christian à 18/02/2006, 14h26 Raison: Précision de date
    christian http://www.cuha.fr (association-ULM-ecole de pilotage)
    => - joomla 1.0.15 - VMart 1.0.14 - chez 1&1

  • #2
    tu as vérifier tes droits (CHMOD) sur les dossiers où tu upload tes images ??
    Juste comme ca au cas où
    JoomlaSite Integrateur

    Commentaire


    • #3
      Les fichiers sont "Writeable"

      Selon les informations de VirtueMart les fichiers contenant les images sont "Writeable".

      Cliquez sur l'image pour l'afficher en taille normale

Nom : VirtueMart_WEB.jpg 
Affichages : 1 
Taille : 58,2 Ko 
ID : 1784891

      /var/www/free.fr/5/6/mulhouse.autos/components/com_virtuemart/shop_image/product :: Writeable
      /var/www/free.fr/5/6/mulhouse.autos/components/com_virtuemart/shop_image/product/resized :: Writeable

      Il me semble donc qu'à ce niveau ce soit bon.

      Merci
      christian http://www.cuha.fr (association-ULM-ecole de pilotage)
      => - joomla 1.0.15 - VMart 1.0.14 - chez 1&1

      Commentaire


      • #4
        j'ai eu le meme problème que toi, et meme si tu as l'impression que tes dossiers sont writeable y'a un petit soucis, va voir les 2 dossiers concernés en ftp et regarde leur chmod et passe le 777 si comme moi ca ne fonctionne pas, va dans la configuration globale du site onglet server, vérifie que les chmod de file permission et directory permission soit bien à 777, coche egalement Apply to existing files et Apply to existing directory en faisant tous cela ce devrait resoudre ton problème, du moins je l'espere tient nous au courant...
        http://www.ekypia.fr - Création de sites Internet - Voir nos réalisations http://www.ekypia.fr/realisations/No...-internet.html

        Commentaire


        • #5
          ca pourrait pas venir de free qui ont fait des modifications sur leur serveur??
          ==> Moi je pencherais pour cette solution, mais n'ayant découvert VirtueMart que depuis hier je n'ai pas encore assez de recul pour voir un autre problème mais vu le type d'erreur que tu as ca m'en a tout l'air !!!

          Si quelqu'un d'autre avait d'autres idées !!!

          Voili voilou
          JoomlaSite Integrateur

          Commentaire


          • #6
            héhé toi aussi tu bosses sur virtuemart gonado??? Que du bonheur...
            http://www.ekypia.fr - Création de sites Internet - Voir nos réalisations http://www.ekypia.fr/realisations/No...-internet.html

            Commentaire


            • #7
              VOui bien obliger je viens de réussir à le mettre en plusieurs langues avec Mambelfish mais je lutte pour la Pony Gallery en multilangue !!!
              JoomlaSite Integrateur

              Commentaire


              • #8
                C'est pas encore ça!

                Envoyé par frodon2604
                j'ai eu le meme problème que toi, et meme si tu as l'impression que tes dossiers sont writeable y'a un petit soucis, va voir les 2 dossiers concernés en ftp et regarde leur chmod et passe le 777 si comme moi ca ne fonctionne pas, va dans la configuration globale du site onglet server, vérifie que les chmod de file permission et directory permission soit bien à 777, coche egalement Apply to existing files et Apply to existing directory en faisant tous cela ce devrait resoudre ton problème, du moins je l'espere tient nous au courant...
                J'ai fait les modifications tel que préconisé à l'exception d'étendre la modification chmod 777 à l'ensemble des fichiers (par crainte - justifiée ou non) Apply to existing directory. Cela d'autant plus que les images étant dans le fichier s'affichent. Actuellement il est impossible d'en ajouter.

                Après ces premières modifications ça ne marche pas.

                Le problème ne viendrait-il pas du fichier php.ini bien que aucun changement n'ai été fait.

                Ou le problème serait-il effectivement lié aux modifications serveur de free???? (suggestion de gonado).

                Merci pour les infos.
                christian http://www.cuha.fr (association-ULM-ecole de pilotage)
                => - joomla 1.0.15 - VMart 1.0.14 - chez 1&1

                Commentaire


                • #9
                  Moi à mon avis ca viendrait de là vu qu'il te parle de Problème de permission et de php.ini et ils peuvent très bien brider quelque chose ou upgrader leur PHP (Version 5), et Free c'est gratuit faut pas l'oublier donc à voir !!!
                  JoomlaSite Integrateur

                  Commentaire


                  • #10
                    Par simple curiosité quand tu essayais d'uploader une image de quel format était ton image ???
                    JoomlaSite Integrateur

                    Commentaire


                    • #11
                      Les images sont en .jpg

                      Envoyé par gonado
                      Par simple curiosité quand tu essayais d'uploader une image de quel format était ton image ???

                      Les images sont en .jpg

                      D'où as-tu l'info d'un problème de serveur chez free?
                      Car lundi mon site était inaccessible durant :
                      Your Web Site is no longer on error

                      URL: http://mulhouse.autos.free.fr
                      Time: Mon Feb 13 10:04:12 EST 2006
                      Total Time on Error: 8 hours, 25 minutes, 26 seconds
                      information fournie par InternetSeer Recovery.
                      christian http://www.cuha.fr (association-ULM-ecole de pilotage)
                      => - joomla 1.0.15 - VMart 1.0.14 - chez 1&1

                      Commentaire


                      • #12
                        Je n'ai pas eu spécialement d'infos je disais ca au pif !!! Mais pas loin de la vérité héhé !!!!
                        Sinon je te demandais le format de l'image car j'ai fait quelques tests cet aprem et en insérant un produit avec une image bmp j'avais le même message d'erreur (suit en rouge) que toi et avec une image jpeg ca marche alors je me disais que ca aurait pu être ca!!!
                        Mais bon je vois que non !!!
                        JoomlaSite Integrateur

                        Commentaire


                        • #13
                          Information

                          Le problème n'est pas lié à free. J'ai testé un second site d'essai que j'ai chez free et "l'upload" d'image dans le composant VirtueMart fonctionne normalement.

                          Je ne sais toujours pas comment m'y prendre pour remedier à ce problème.
                          J'ai été sur le forum de VirtueMart et j'ai constaté que mon problème n'est pas un cas unique malheureusement je n'y ai pas trouvé la solution.
                          Mon anglais étant très basique ce n'est pas évident.

                          Donc, si quelqu'un a une idée... merci d'avance.
                          Dernière édition par christian à 15/02/2006, 11h23
                          christian http://www.cuha.fr (association-ULM-ecole de pilotage)
                          => - joomla 1.0.15 - VMart 1.0.14 - chez 1&1

                          Commentaire


                          • #14
                            Tu as essayé d'uploader plusieur type de fichiers ? .jpg .JPG .jpeg .JPEG .gif .GIF etc
                            Faut faire attention à la case en php alors peut être que tu as un problème de majuscule miniscule. (Je dis ca comme ca j'ai déjà eu se problème sur un autre composant).
                            Si le problème vient de là il faudra ajouter ces extentions dans le fichier de contrôle des extentions.

                            Salutations

                            Greg

                            Intermitant ( trop de job ces temps )

                            Commentaire


                            • #15
                              Toujours pas résolu.

                              Envoyé par greig
                              Tu as essayé d'uploader plusieur type de fichiers ? .jpg .JPG .jpeg .JPEG .gif .GIF etc
                              Faut faire attention à la case en php alors peut être que tu as un problème de majuscule miniscule. (Je dis ca comme ca j'ai déjà eu se problème sur un autre composant).
                              Si le problème vient de là il faudra ajouter ces extentions dans le fichier de contrôle des extentions.

                              Salutations

                              Greg

                              Merci de te pencher sur mes tracas.


                              J'ai effectivement testé plusieurs extensions *.gif, *.jpg. Le problème est toujours là.
                              Les noms des images qui ont déjà été utilisé ont été écrit avec des mélanges de minuscules et de majuscules cela ne posait pas de problème.

                              Le problème doit venir d'ailleur.
                              Info j'ai également utlisié le forum de VirtueMart pour ce souci mais malheureusement "ils" ne sont pas très réactifs là-bas. Et curieusement je ne suis pas le seul à avoir le même type d'erreur.

                              Encore merci
                              christian http://www.cuha.fr (association-ULM-ecole de pilotage)
                              => - joomla 1.0.15 - VMart 1.0.14 - chez 1&1

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X