Joomladay francophone 2018 à Paris 18 et 19 mai

Problème avec cybermut

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Problème avec cybermut

    Bonjour,
    Je viens d'installer un site de vente avec Joomla 1.0.15 et VirtueMart 1.1.2 l'installation se passe sans problème, j'ai suivi le tutoriel sur alatak.net ici.
    Lors du paiement tout se déroule convenablement mais le serveur de la banque m'indique systématiquement que mon CGI2 de test à émis un accusé de reception invalide et dans le mail que je reçois de mon site, j'ai cette indication
    RÉPONSE DE VOTRE CGI DE CONFIRMATION :
    Restricted access
    mais là je sèche un peu, si quelqu'un pouvait me donner une indication ou un conseil.
    La banque, c'est le CIC.
    Dernière édition par schtroumpf26 à 18/09/2008, 18h03

  • #2
    Bonjour,


    Est ce que tu as envoyé tous les URLs (URL pricipale, URL de retour, et cgi2) à COMMERCE ELECTRONIQUE "CENTRECOM (at) e-i (point) com" ?
    alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

    Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

    Commentaire


    • #3
      Bonjour,
      Envoyé par alatak Voir le message
      Est ce que tu as envoyé tous les URLs (URL pricipale, URL de retour, et cgi2) à COMMERCE ELECTRONIQUE "CENTRECOM (at) e-i (point) com" ?
      J'ai bien envoyé l'url principale du site lors de la demande d'enregistrement auprés de ma banque et l'url de retour CGI2 à centrecom comme tu l'indique dans ton tuto, et j'ai même téléphoné pour avoir la confirmation qu'ils avaient reçus mon mail et que leur serveur était OK.
      Quand à ce que tu appelle l'url de retour je suppose que c'est celle qui est avec la demande de paiement qui est envoyée au serveur sécurisé de la banque, donc elle est renseignée automatiquement non ??

      Commentaire


      • #4
        Bonjour,
        Le crois que j'avance un peu dans ma quête...
        D'après moi le message Restricted access que me renvoi Joomla en réponse à la requête du serveur de la banque, vient du fait que cette requête est faite directement sur un fichier .php sans passer par l'index du site, donc lorsque on essaye d'inclure le fichier french.php dans checkout.cmcic_cgi2.php cette ligne
        defined( '_VALID_MOS' ) or die( 'Restricted access' );
        renvoie bien le fameux Restricted access.
        Pour palier à ce problème, j'ai ajouté au fichier cmcic_cgi2.php l'instruction :
        define( '_VALID_MOS', 1 );
        et la plus de problème de Restricted access, je ne sais pas si il y a des inconvénients sur la sécurité du site en faisant comme ça et j'aimerais que les spécialistes puissent me renseigner la-dessus !!

        Par contre tout n'est pas terminé parce que maintenant j'ai d'autres erreurs:
        REPONSE DE VOTRE CGI DE CONFIRMATION :
        <br />
        <b>Notice</b>: Use of undefined constant JPATH_BASE - assumed 'JPATH_BASE' in <b>/administrator/components/com_virtuemart/html/checkout.cmcic_cgi2.php</b> on line <b>39</b><br />
        <br />
        <b>Notice</b>: Use of undefined constant JPATH_BASE - assumed 'JPATH_BASE' in <b>/administrator/components/com_virtuemart/html/checkout.cmcic_cgi2.php</b> on line <b>40</b><br />
        <br />
        <b>Warning</b>: main() [<a href='function.main'>function.main</a>]: open_basedir restriction in effect. File(/JPATH_BASE/administrator/components/com_virtuemart/virtuemart.cfg.php) is not within the allowed path(s): (/:/tmp) in <b>/administrator/components/com_virtuemart/html/checkout.cmcic_cgi2.php</b> on line <b>40</b><br />
        <br />
        <b>Warning</b>: main(JPATH_BASE/administrator/components/com_virtuemart/virtuemart.cfg.php) [<a href='function.main'>function.main</a>]: failed to open stream: Operation not permitted in <b>/administrator/components/com_virtuemart/html/checkout.cmcic_cgi2.php</b> on line <b>40</b><br />
        <br />
        <b>Fatal error</b>: main() [<a href='function.require'>function.require</a>]: Failed opening required 'JPATH_BASE/administrator/components/com_virtuemart/virtuemart.cfg.php' (include_path='.:.:') in <b>/administrator/components/com_virtuemart/html/checkout.cmcic_cgi2.php</b> on line <b>40</b><br />
        Voila si quelqu'un ou une veut bien se pencher sur mon problème !!!!
        Dernière édition par schtroumpf26 à 11/09/2008, 07h31

        Commentaire


        • #5
          Bonjour,


          Je sais ou est le problème. J'essaye de t'envoyer une nouvelle version du fichier dans la journée.
          alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

          Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

          Commentaire


          • #6
            Bonjour,
            Un tres grand merci

            Commentaire


            • #7
              Bonsoir,
              Je désespère de faire marcher un jour ce système de paiement cybermut....
              J'ai passé le site en version Joomla 1.5.7 et Virtuemart en version 1.1.2 en pensant que cela pourrait résoudre mes problèmes, mais toujours pas !!!
              J'ai d'abord eu ce message:
              Notice: Undefined variable: absolute_path in /httpdocs/administrator/components/com_virtuemart/html/checkout.cmcic_cgi2.php on line 35
              en voyant ça j'ai modifié ce fichier en mettant l'adresse en dur au lieu d'utiliser une variable, et maintenant je n'ai plus aucune réponse à la requête du serveur de la banque alors que je devrais lui envoyer un accusé de réception je pense ??

              Franchement je ne sais plus quoi faire et si quelqu'un pouvait se donner la peine de me dire ce que je fais mal ou alors seulement de me mettre sur une piste, un signe quelque chose de positif quoi, pour que je puisse enfin avancer.

              Commentaire


              • #8
                Bonjour,

                'Scuse moi, j'avais oublié. Je m'en occupe aujourd'hui.


                Valérie
                alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                Commentaire


                • #9
                  Bonjour,

                  Normalement ce fichier doit marcher.

                  Remplace le.

                  Valérie
                  Fichiers joints
                  alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                  Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                  Commentaire


                  • #10
                    Merci

                    En cherchant le même problème, je suis tombé sur ce fil, et pour moi cela fonctionne.
                    merci beaucoup

                    Commentaire


                    • #11
                      Bonjour,


                      Merci,pour la reponse. Je vais en faire une release. De mon coté je n'ai pas pu le tester. J'attends le mise à jour de la part de la banque.
                      alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                      Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                      Commentaire


                      • #12
                        Bonsoir,
                        Envoyé par craftou Voir le message
                        En cherchant le même problème, je suis tombé sur ce fil, et pour moi cela fonctionne.
                        merci beaucoup
                        Et bien pour moi toujours le même problème, le serveur de la banque m'envoie toujours le même mail de confirmation
                        Votre CGI 2 de TEST a émis un accusé de réception invalide et la commande a ete VALIDEE

                        pourtant le cgi de retour c'est bien
                        /cmcic_cgi2.php
                        Par contre je n'ai plus aucun message d'erreur !!
                        Je n'y comprends plus rien, je vais retélécharger les fichiers sur le site alatak.net et réinstaller tout ça pour voir

                        Commentaire


                        • #13
                          Bonsoir,

                          le cgi2 est:

                          http://tonsite.com/cmcic_cgi2.php

                          Si tu tapes cette url dans un navigateur tu dois avoir:
                          Code HTML:
                          Pragma: no-cache Content-type: text/plain Version: 1 Document Falsifie 0--0831276+++++1.2open++
                          le terme document falsifié est correct dans ce cas.

                          Si tu n'as pas ce message d'affiché, alors dis nous ce que tu as.
                          Tu ne dois pas avoir une page blanche.
                          alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

                          Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

                          Commentaire


                          • #14
                            Bonsoir,
                            Non je n'ai rien en réponse à part une page blanche !!

                            Commentaire


                            • #15
                              Pour continuer...

                              Bonsoir,
                              J'ai un probleme qui n'a peut etre pas de rapport mais...
                              J'ai un message au moment d'aller sur le site de paiement :
                              Le site de votre commerçant n'a pas été identifié par notre serveur.
                              Nous ne sommes pas en mesure de traiter la demande de paiement
                              relative à votre commande.
                              a cette adresse : https://www.creditmutuel.fr/telepaie...t/paiement.cgi
                              Je ne comprend pas la banque m'a confirmer qu'avec le nouveau fichier j'étais bon, mais je ne suis pas identifié en arrivant pourtant il me colle bien mon numero de TPE sur le cote avec le numero de la commande mais c'est tout ?
                              Si vous avez une idée ?
                              Merci d'avance
                              Et bravo a Alatak pour ce remarquable travail.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X