Joomladay francophone 2018 à Paris 18 et 19 mai

Problème Paiement CIC (ALATAK) avec Virtuemart

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Problème Paiement CIC (ALATAK) avec Virtuemart

    Le site hébergé sur CELEONET (PHP5) fonctionne depuis près d'un an avec jommla 1.0.15 et virtuemart 1.0.15, sans problème avec un module de paiement par chèque. Nous avons rajouté un module de paiement Banque CIC (Cybermut), soit le virtuemart-cmcic-V5.zip de Alatak. A l'aide du kit CIC, nous avons généré les différents paramètres de configuration du module (TPE, etc..), mais quand on ouvre ce module pour le configurer, nous tombons sur la page de formulaire avec juste le logo Virtuemart et les deux onglets "Général" et "Configuration", faisant disparaître toute le template Joomla et virtuemart. Il y a des erreurs de script signalées par IE7 en pied de fenêtre et quand on clique sur l'onglet "configuration" pour mettre les paramètres du générateur de clefs Cybermut-CIC, la page reste blanche, sans aucun champs de formulaire.

    Nous avons essayés de downgrader le module de paiement en virtuemart-cmcic-V4.zip de Alatak. Le comportement est différent. Lorsqu'on entre dans la configuration du module, tout se passe normalement et on peut saisir tous les champs nécessaires et enregistrer les paramètres. Par contre, côté utilisateur, quand le moment fatidique de l'affichage du formulaire de paiement doit de mettre en action, la page affiche directement que la commande est validée, suivi du code php suivant :

    Code PHP:
    <?php require_once(PAGEPATH."checkout.cmcic_cc_form.php " ) ; ?>
    Soit, le code que l'on rajoute justement dans le champs "Paiement Extra Infos"

    Quelqu'un a-t-il une petite idée de ce qu'il se passe ? Merci
    Dernière édition par cybergaby à 15/04/2009, 16h28
    L'erreur est humaine. Pour une catastrophe, donnons-lui un ordinateur.

    Ne réponds pas aux MPs. Exposez votre problème sur le forum !

  • #2
    Un peu plus de précision, peut-être.

    voilà en fait exactement la situation dans laquelle on se retrouve :

    Messages d'erreur en pied de page :
    Code:
    Ligne : 44
    Caractère : 1
    Erreur : '_cmNoAction' est indéfini.
    Code : 0
    URL : http://www.monsite.fr/administrator/index2.php?page=store.payment_method_form&limitstart=0&keyword=&payment_method_id=20&option=com_virtuemart
    
    Ligne : 4
    Caractère : 1
    Erreur : '_cmSplit' est indéfini.
    Code : 0
    URL : http://www.monsite.fr/administrator/index2.php?page=store.payment_method_form&limitstart=0&keyword=&payment_method_id=20&option=com_virtuemart
    
    Ligne : 110
    Caractère : 1
    Erreur : Objet attendu
    Code : 0
    URL : http://www.monsite.fr/administrator/index2.php?page=store.payment_method_form&limitstart=0&keyword=&payment_method_id=20&option=com_virtuemart
    Ci-joint les copies d'écran pour mieux apprécier le problème. Merci
    Fichiers joints
    L'erreur est humaine. Pour une catastrophe, donnons-lui un ordinateur.

    Ne réponds pas aux MPs. Exposez votre problème sur le forum !

    Commentaire


    • #3
      Toujours dans l'impasse ! ! !

      Quelqu'un a-t-il un début de piste à me proposer pour la résolution de ce problème ? Car je tourne en rond depuis 15 jours. A tel point que je me demande si cela ne vient pas simplement de CELEONET (hébergement mutualisé Formule Turbo).
      Dernière édition par cybergaby à 21/01/2009, 12h07 Raison: Correction d'une faute de frappe
      L'erreur est humaine. Pour une catastrophe, donnons-lui un ordinateur.

      Ne réponds pas aux MPs. Exposez votre problème sur le forum !

      Commentaire


      • #4
        Erreur 500 du serveur de CELEONET

        J'ai remonté une sauvegarde du site de la boutique et j'ai réinstallé la V4 du module CMCIC de ALATAK. J'ai régénéré les paramètres et les clefs que j'ai saisi dans l'onglet de configuration du module. Au passage, j'ai corrigé ce qui me semble être une petite erreur de syntaxe (des espaces en trop). J'ai remplacé :
        Code PHP:
        <?php require_once(PAGEPATH."checkout.cmcic_cc_form.php " ) ; ?>
        qui n'affichait pas le bouton de paiement CIC, mais passait la commande "en cours", avec mail de l'ordre d'achat au client.

        par

        Code PHP:
        <?php require_once(PAGEPATH."checkout.cmcic_cc_form.php"); ?>
        qui n'affiche toujours pas le bouton de paiement CIC, mais plante le serveur (ERREUR 500), passe la commande "en cours", avec mail de l'ordre d'achat au client.

        Résultat : Quand je fais un test de commande, tout à l'air de se passer normalement côté client jusqu'au moment où doit s'afficher le bouton de redirection vers le paiement CYBERMUT. A ce moment là, je me retrouve devant une erreur 500 du serveur de CELEONET. Le client reçoit bien l'ordre d'achat sur son email et la commande est "En cours" sur l'interface d'administration. Pour moi, même si le résultat n'est pas encore là, je pense qu'il y a du progrès car le serveur réagit avec une erreur 500, au lieu de faire comme si de rien n'était.

        Il me semble avoir lu par ailleurs que pour CELEONET en PHP5, il fallait modifier une ligne dans le code, mais je ne me rappelle plus quoi.

        Config J1.0.15+VM1.0.15 avec module CMCIC V4 ALATAK sur un hébergement CELEONET mutualisé Formule TURBO tournant en PHP5.2.5 (php.ini non modifié)
        L'erreur est humaine. Pour une catastrophe, donnons-lui un ordinateur.

        Ne réponds pas aux MPs. Exposez votre problème sur le forum !

        Commentaire


        • #5
          Problème résolu

          Le problème a été résolu.

          Il s'agissait en fait de la disparition de retours de lignes lors du transfert de certains fichiers avec Filezilla.

          J'ai donc édité un à un tous les fichiers présents dans le répertoire com_virtuemart, puis j'ai transformé tous les fichiers problématiques. Fastidieux, mais efficace.

          J'en conclu que Filezilla n'est pas un outil FTP très fidèle car les fichiers sources étaient bons. C'est donc au moment de l'upload qu'ils subissent des modifications. J'avais déjà remarqué que certains fichiers avaient du mal à s'uploader et surtout que quand on faisait un download du FTP complet pour une sauvegarde, certains fichiers manquaient sans que ceux-ci ne soient dans la liste des transferts échoués.

          Bref, pour éviter certaines galères, FileZilla est à éviter, me semble-t-il.
          L'erreur est humaine. Pour une catastrophe, donnons-lui un ordinateur.

          Ne réponds pas aux MPs. Exposez votre problème sur le forum !

          Commentaire


          • #6
            bonjour,

            J'ai donc édité un à un tous les fichiers présents dans le répertoire com_virtuemart, puis j'ai transformé tous les fichiers problématiques. Fastidieux, mais efficace.
            Pour résoudre ce problème là,tu airais pu transférer les fichiers en mode binaire, et non ASCII. Tu devrais verifier la config de Filezilla.
            alatak.net, Spécialiste VirtueMart et Développeur http://alatak.net

            Aucun MP. Je n'y réponds pas. Merci de votre compréhension.

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins
            Travaille ...
            X