Installation d'OpenWiki

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Installation d'OpenWiki

    Bonjour,
    Quelqu'un a-t-il installé OpenWiki, comme nous y sommes invité en page News du dossier Extensions.
    J'ai plusieurs problèmes.
    D'abord un problème avec les langues : le pack langue ne comporte pas de fichier setup XML et donc on ne peut pas le charger comme composant. J'ai donc téléchargé par FTP dans administrator/compents/com_openwiki les dossiers dézippés du pack (964 fichiers!). Apparemment, sans effet.
    J'ai bricolé dans les paramètres de configuration et ai remplacé "en" par "fr". Voilà ce que j'obtiens après clic en frontend :
    "Warning: main(): Unable to access /data/members/paid/e/u/europe-avenir.com/htdocs/plurilinguisme/components/com_openwiki/inc/lang/fr/lang.php in /data/members/paid/e/u/europe-avenir.com/htdocs/plurilinguisme/components/com_openwiki/inc/init.php on line 27
    Warning: main(/data/members/paid/e/u/europe-avenir.com/htdocs/plurilinguisme/components/com_openwiki/inc/lang/fr/lang.php): failed to open stream: No such file or directory in /data/members/paid/e/u/europe-avenir.com/htdocs/plurilinguisme/components/com_openwiki/inc/init.php on line 27"
    Je comprends très bien que le fichier ../fr/lang.php, qui existe bien et au bon emplacement, ne soit pas trouvé dans ini.php, car c'est ini.php qui n'existe pas.

    Problème avec le répertoire de stockage du wiki.
    En restant dans les paramètres de configuration avec "langue : en", le message d'erreur est le suivant :
    "DokuWiki Setup Error
    The datadir does not exist, isn't accessable or writable. Check your config and permission settings!"
    J'ai vérifié que le répertoire de sauvegarde par défaut existe bien.

    Si quelqu'un peut m'aider à débrouiller ce sac de noeuds, merci d'avance!

  • #2
    bonjour,

    Comme je l'ai annoncé dans cette news,
    pour avoir openwiki en français, il est nécessaire de décompresser le zip du pack de langues en gardant la structure des répertoires puis de transférer ces répertoires obtenus(il y en a 2 : lib et inc) dans ton site par un logiciel FTP dans le répertoire /components/com_openwiki/ (il est important de garder les noms de répertoires se trouvant dans l'archive et non pas de transférer uniquement les fichiers !!).

    Enfin dans la configuration de OpenWiki (dans le menu composant de ton administration du site), tu dois écrire "fr" à la place de "en" (mais ça c'est fait!).

    Enfin tu dois configurer les droits d'accès (les "chmod") sur le répertoire du composant pour autoriser la sauvegarde des données car le composant enregistre les textes dans son répertoire et non pas dans la base de données.

    Une fois installé, il ne te reste plus qu'a remplacer le texte d'origine par celui que tu veux... en frontend bien sur.

    Pour l'utilisation du wiki, tu cherche "docuwiki" sur internet et tu trouvera de la doc sans problème.

    J'espère t'avoir aidé !
    Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

    Commentaire


    • #3
      Merci pour ce dépannage ultra rapide!
      En fait, ce qui bloquait, c'était simplement que j'avais installé le pack de langue dans /administrator/components au lieu de /components.
      En ce qui concerne les droits d'accès (les "chmod"), je n'ai rien compris, parce que ça marche et je ne vois pas à quelle manip tu fais allusion (ne me dis pas que je dois rentrer dans un config.php, j'ai rien contre, mais ça me paraît un peu brutal...).
      Merci en tout cas, car je peux avancer.
      Pardon, j'oubliais. Je me disais bien que j'avais lu quelque chose sur le forum, mais impossible de retrouver ton annonce. Le moteur de recherche ne connait pas openwiki...
      Cordialement

      Commentaire


      • #4
        Je me réponds à moi-même.
        Il y a quand même un problème étrange : Openwiki n'admet pas les caractères accentués. Admettons. Mais qu'il transforme en point d'interrogation tous les caractères accentués des menus, il y a un abus. Heureusement qu'il est destiné à un usage restreint...
        Désolé de ce jugement un peu dur. Pour le reste, je verrai à l'expérience, mais le composant me paraît très attractif.

        Commentaire


        • #5
          Christian,

          Pour le pb de l'affichage il est évident qu'il s'agit d'un problème d'encodage de caractères.

          Le site aura été développé en ISO-8859-1 ou ISO-8859-15 (zone euro)
          or en l'état actuel Openwiki gère tout en UTF-8.

          Pour s'en rendre compte il suffit avec Firefox de regarder dans le menu affichage, encodage des caractères :
          La marque est dynamiquement placée en face de l'encodage courant, c'est à dire celui qui est défini dans la page HTML (code source de la page) dans l'instruction HTML
          <head>
          <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
          ...
          </head>

          qui provient en l'occurence de la page courante de saisie de ce texte, pour l'afficher (ctrl-J ou menu:affichage:code de la page.

          Or OPENWIKI force l'encodage en UTF-8, la conséquence immédiate est que les textes saisis en ISO-8859-1 dont les menus Joomla, les modules etc tous les caractères accentués seront affichés par un "?" encadré sur fond noir.
          Si l'on force manuellement l'encodage par le menu on retrouve un affichage "normal" pour les zones autres que celles gérées par openwiki, par contre dès que l'on active une commande de openwiki on basculera tout l'affichage en UTF-8.

          Je n'ai pas le temps de rechercher le bug, ni l'entraînement, mais avec du temps...
          Le code de la page est bien ISO-8859-1 mais des parties sont affichées en UTF-8 ce qui ne pose pas de problèmes fondamentaux.
          cf W3C HTML 4.01 Specifications p44
          To sum up, conforming user agents must observe the following priorities when
          determining a document’s character encoding (from highest priority to lowest):
          1. An HTTP "charset" parameter in a "Content-Type" field.
          2. A META declaration with "http-equiv" set to "Content-Type" and a value set for
          "charset".
          3. The charset attribute set on an element that designates an external resource.
          In addition to this list of priorities, the user agent may use heuristics and user
          settings. For example, many user agents use a heuristic to distinguish the various
          encodings used for Japanese text. Also, user agents typically have a user-definable,
          local default character encoding which they apply in the absence of other indicators.
          User agents may provide a mechanism that allows users to override incorrect
          "charset" information. However, if a user agent offers such a mechanism, it should
          only offer it for browsing and not for editing, to avoid the creation of Web pages
          marked with an incorrect "charset" parameter.


          Aussi la prise en charge d'une partie de l'affichage en UTF-8 pose actuellment problème.
          On peut penser que ce problème trouvera une solution rapide.

          Commentaire


          • #6
            Bernard,
            J'ai cherché dans les fichiers ce qui traite de l'encodage. Je n'ai trouvé que deux lignes de code :
            1ère ligne d'openwiki.xml (dans /administrator/component)
            <?xml version="1.0" encoding="iso-8859-1"?>
            25e ligne de feed.php (dans /component)
            function createFeed($format = "RSS0.91",$encoding='iso-8859-15')
            Donc l'explication par la norme UTF-8 n'est pas la bonne. Il faut chercher ailleurs!

            Commentaire


            • #7
              Suite install Openwiki - un petit tuto style parcours de découverte

              Je poursuis cette discussion entre personnes qui découvrent l'outil.
              Je me suis exercé à openwiki en décrivant tout simplement ce que je faisais. Ca donne le texte ci-après (c'est la 8e version) :

              "Je poursuis l’essai et vérifie la création d’une nouvelle page dans une nouvelle catégorie. Cette création se faisant évidemment en arrière-scène (backend). en saisissant un nouveau nom dans le champ "start page name" (faut quand même y penser). Pour insérer la page dans une catégorie ou créer la nouvelle catégorie et la page, c'est une pure question de syntaxe, tout simple, c'est dans le texte, voir ici.

              Je viens de vérifier que tout fonctionne bien. Si l'on veut changer de "page actuelle", cliquer sur index.

              Je poursuis donc l’évolution du document en inscrivant le résultat de ma démarche en éditant la page.

              Je vais voir maintenant si je retrouve bien les éditions successives.

              J’ai bien vérifié qu’on retrouvait bien les versions successives et que chaque version peut elle-même être éditée.

              Je viens d’effectuer un retour en arrière et repars de la version n-1. Je veux voir ce qui se passe quand j’édite cette version n-1. Devient-elle la version n+1. Y-a-t-il un lien avec la version source. Quid des branches mortes?

              Vérification faite : l’ancienne version dont je suis repartie est simplement restaurée et devient, modifiée et sauvegardée, la version courante ou actuelle. Par contre, je ne vois pas quelles sont les versions anciennes qui se trouvent en quelque sorte invalidées par ce retour en arrière.

              Maintenant, je vais faire une autre recherche qui va consister à chercher quel est le modèle (template) par défaut pour régler cette fichue question de caractères. Peut-être que l’anomalie est une question de modèle et qu’il suffit d’en trouver un plus approprié.

              Je réponds quand même à mon interrogation sur le suivi des modifications. Il y a une icône bien pratique qui veut dire “différences par rapport à la version actuelle”. On peut par ce moyen retrouver son fil d’ariane.

              Je dois ajouter que dans l’historique on sait à quel moment on a restauré une version antérieure, ce qui est bien, mais on ne dit pas laquelle.

              J’en profite pour corriger quelques fautes de frappe.

              Je poursuis le travail avec un nouveau template. Toute la technique, très simple, de l'installation des templates est dans dokuwiki, ici. Ca n’a rien changé à la question des caractères."
              Bon! la question des caractères, c'est désagréable, mais ça ne concerne que ceux qui ont ouvert openwiki...Faut relativiser. Mais quand même, c'est pas l'top!
              Yati quéquun qui sai?

              Commentaire


              • #8
                Charset

                Pour résoudre le problème d'affichage des caractères accentués français, j'ai fait un grep 'utf-8' sur tous les fichiers de l'arborescence du composant openwiki et j'ai remplacé 'utf-8' par 'iso-8859-1'. De toute évidence, ça fonctionne (à quelques petites exceptions près).

                Si vous voulez le composant adapté pour effectuer une comparaison avec l'original, je peux vous l'envoyer au format de compression que vous souhaitez.

                Avis aux amateurs :-).
                .....>(ô ô)<
                --oOOo--(_)--oOOo--
                Ce qui ne nous tue pas nous rend plus fort !

                Commentaire


                • #9
                  open wiki

                  oui merci de le mettre en archive zip les fichiers modifiées (insère le dans une pièce jointe pour le forum).

                  Envoyé par Lucioleke Voir le message
                  Pour résoudre le problème d'affichage des caractères accentués français, j'ai fait un grep 'utf-8' sur tous les fichiers de l'arborescence du composant openwiki et j'ai remplacé 'utf-8' par 'iso-8859-1'. De toute évidence, ça fonctionne (à quelques petites exceptions près).

                  Si vous voulez le composant adapté pour effectuer une comparaison avec l'original, je peux vous l'envoyer au format de compression que vous souhaitez.

                  Avis aux amateurs :-).
                  Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

                  Commentaire


                  • #10
                    Dossier zippé

                    Heu ... le dossier zippé fait 421 Ko. Impossible de le télécharger cause dépasse la taille maximale autorisée.
                    Je fais quoi ?
                    .....>(ô ô)<
                    --oOOo--(_)--oOOo--
                    Ce qui ne nous tue pas nous rend plus fort !

                    Commentaire


                    • #11
                      Je me greffe sur le fil ...(me deplacer si preferable)
                      je viens d'installer openwiki
                      Le composant semble operationnel (pas encore exploré)
                      mais depuis son insta, la page installation/composant et "en vrac", se terminant par ce message:
                      Code:
                      Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 51 bytes) in /var/www/rinho/administrator/modules/mod_fullmenu.php on line 180
                      je precise que j'ai recement migré sur une dedibox, avec la distri "recommandée", a savoir Ubuntu special dedibox et que j'ai eu le meme genre de message aprés la migration, dés la page d'accueil, jusqu'a ce que je desinstalle manuellement le composant Bigape backup
                      Tout nouveau

                      Commentaire


                      • #12
                        Envoyé par wildbear Voir le message
                        Je me greffe sur le fil ....
                        Désolé d'avoir pollué pour rien !
                        c'est un probleme de "memory_limit", parametre de php.ini
                        Tout nouveau

                        Commentaire


                        • #13
                          A Daneel,
                          Quitte à passer pour demeuré, c'est quoi un grep?

                          Commentaire


                          • #14
                            jette un oeil ici
                            Grep
                            Tout nouveau

                            Commentaire


                            • #15
                              Salut,

                              Les liens donnés par 'lavsteph' m'ont déjà réglé un problème mais j'en ai encore un qui me pourrit la vie !

                              Quand je crée un lien du style [[Photo de famille]], le titre de la nouvelle page me déplait fortement: Photo_de_famille ! Comment éviter ses '_'

                              Merci
                              Sebe
                              Le pourquoi de Joomla !

                              Tutos [Facile Forms] (sans suite ): Installation et configuration, Mon 1er formulaire, Faire un Package

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X