datso. image sous-catégorie cliquable ?

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • datso. image sous-catégorie cliquable ?

    Bonjour.

    je vais prendre un exemple pour être clair.
    J'ai une catégorie voiture. là on peut avoir une image.
    Dans cette catégorie, j'ai deux sous-catégories, essence, diesiel
    là on ne peut avoir que des cases vides avec le nom de la sous-catégorie et le nombre d'image contenues. ça c'est vraiment pas beau.

    Aussi dans la description de la sous-catégorie, j'ai mis une image.
    maintenant c'est joli

    Sauf que si on veut accéder aux images de la sous-catégorie, il faut cliquer sur le nom de la sous-catégorie.

    Il faudrait que lorqu'on puisse cliquer sur l'image également pour accéder aux images.

    Quelqu'un à une idée ?
    merci à lui d'avance
    Dernière édition par ObibiKenowan à 28/11/2006, 06h47
    Obibi Kenowan
    (La Force n'est pas toujours avec moi !)
    Etienne Audfray Sculpteur http://www.audfray.com
    Armand Petersen Sculpteur http://www.armand-petersen.fr

  • #2
    Oh Grand Maître de tous les Grands Maîtres j'ai suivi ton idée 1/ (la 2/ j'ai pas compris) et ça marche du feu de dieu mais j'ai une petite question quand même.
    Pour l'instant je suis en local sous
    c:\program files\easyphp\www\ea_prod\ (ensuite il y a ts les répertoires joomla)
    Le code que j'ai ajouté dans la description de la sous-catégorie est le suivant:

    <DIV align=center><A href="/ea_prod/index.php? option=com_datsogallery&amp;Itemid=28&amp;func=vie wcategory&amp;catid=17">
    <IMG height=100 alt="Les sculptues monumentales" src="/ea_prod/images/stories/sous_cat_sculptures.jpg" width=66 border=0></DIV></A>

    Comme tu l'as vu, je mentionne ea_prod sous-répertoire de www.
    Quand je vais transporter tout cela chez free, ea_prod n'existera pas.
    ça va planter grave non ?
    Obibi Kenowan
    (La Force n'est pas toujours avec moi !)
    Etienne Audfray Sculpteur http://www.audfray.com
    Armand Petersen Sculpteur http://www.armand-petersen.fr

    Commentaire


    • #3
      Bonjour,

      Cela me parait bien compliquer comme affaire;

      Moi j'ai mis une image dans une sous-catégorie, ensuite j'ai copier l'url ce la page arrivant à cette sous-catégorie et je l'ai copiée dans le lien url de l'image.
      Et pis ça marche et ça se transporte en distant.
      Mais peut-être que c'est pas ça que tu voulais.

      Cordialement
      Site d'un artisan : www.bgs-alu.com

      Commentaire


      • #4
        Envoyé par mijou
        Bonjour,
        Cela me parait bien compliquer comme affaire;
        Moi j'ai mis une image dans une sous-catégorie, ensuite j'ai copier l'url ce la page arrivant à cette sous-catégorie et je l'ai copiée dans le lien url de l'image.
        Et pis ça marche et ça se transporte en distant.
        Mais peut-être que c'est pas ça que tu voulais.
        Cordialement
        J'ai pas compris ce que tu as fait. Quand tu créé une nouvelle sous-catégorie (ou catégorie) dans datso, tu arrives sur l'écran "ajouter catégorie". Tu saisis le nom de la sous-catégorie dans titre, tu choisis la catégorie parente ainsi qu'une image pour cette sous-catégorie dans la zone "image de la catégorie".
        L'image s'affiche à droite. tu sauvegardes. mais là tu es d'accord dans le front-end, l'image n'apparait pas dans l'écran qui présente toutes les sous-catégories de la même catégorie que celle qu'on vient de créer. Il y a juste le titre de la sous-catégorie qui apparait avec entre parenthèses le nombre d'images contenues dans cette sous-catégorie.
        moi ce que j'aimerais, c'est que l'image de la sous-catégorie apparaisse et que si l'on clic dessus on aille sur la page qui affiche toutes les vignettes des images contenues dans la sous-catégories de la même manière que si on cliquait sur le nom de la sous-catégorie.

        Le code url de la page présentant les vignettes des images contenues dans la sous-catégorie, ça je la connais (à l'exception près qu'elle contient un chemin complet). mais ce que je ne comprends pas, "je colle l'url dans le lien url de l'image" ? il est où le lien url de l'image ?

        bien à toi.
        Obibi Kenowan
        (La Force n'est pas toujours avec moi !)
        Etienne Audfray Sculpteur http://www.audfray.com
        Armand Petersen Sculpteur http://www.armand-petersen.fr

        Commentaire


        • #5
          Bonsoir,

          On est bien d'accord jusqu'au moment où tu choisis ta catégorie parente.

          Ensuite, au lieu de choisir "une image de la catégorie", va dans le cadre de texte, fait insérer une image (petit arbre vert) avec l'URL de l'image que tu vas prendre dans la gallerie de la sous-catégorie (clic droit, propriétés), ensuite tu cliques sur l'image et tu lui mets un lien (maillons de chaine), celui que tu prend sur la page OU sont les images de la sous-catégories.

          J'espère être assez clair, sinon n'hésites pas à me redemander.

          Cordialement

          PS : j'ai un fichier en swf pour te montrer mais il est trop gros pour le mettre en pièces jointe. Si tu le souhaites je peux te l'envoyer en MP.
          Site d'un artisan : www.bgs-alu.com

          Commentaire


          • #6
            Envoyé par mijou
            Bonsoir,

            PS : j'ai un fichier en swf pour te montrer mais il est trop gros pour le mettre en pièces jointe. Si tu le souhaites je peux te l'envoyer en MP.
            Re bonjour Bijou.
            Désolé pour cette réponse tardive mais un petit accident de moto m'a éloigné de l'ordi.

            La tête a du cogner car je ne vois toujours pas comment faire.
            Si tu l'as encore peux-tu m'envoyer ton fichier à obibikenowan AT free.fr je t'en remercie d'avance.

            Cordialement.
            Dernière édition par hornos à 01/10/2006, 11h48
            Obibi Kenowan
            (La Force n'est pas toujours avec moi !)
            Etienne Audfray Sculpteur http://www.audfray.com
            Armand Petersen Sculpteur http://www.armand-petersen.fr

            Commentaire


            • #7
              Envoyé par ObibiKenowan
              Re bonjour Bijou.
              Désolé pour cette réponse tardive mais un petit accident de moto m'a éloigné de l'ordi.

              La tête a du cogner car je ne vois toujours pas comment faire.
              Si tu l'as encore peux-tu m'envoyer ton fichier à obibikenowan@free.fr je t'en remercie d'avance.

              Cordialement.
              On laisse tomber. j'ai trouvé une solution. Dans le texte, en html, j'écris <A href="/ea_prod/index.php?option=com_datsogallery&amp;Itemid=28&am p;func=viewcategory&amp;catid=15"><IMG src="/ea_prod/images/stories/sous_cat_villiers.jpg"></DIV></A>

              Merci à vous tous.
              Obibi Kenowan
              (La Force n'est pas toujours avec moi !)
              Etienne Audfray Sculpteur http://www.audfray.com
              Armand Petersen Sculpteur http://www.armand-petersen.fr

              Commentaire


              • #8
                Salut,

                Comme te l'a indiqué anonyme, tu devrais virer ea_prod/ dans ton lien car si tu dois déplacer ton site à la racine de ton serveur, ou ailleurs...
                Pas de demande de support en MP ou par mail, le forum est là pour ça!
                http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
                http://www.lapatagonie.com : juste pour vous dépayser un peu...

                Commentaire


                • #9
                  Envoyé par hornos
                  Salut,

                  Comme te l'a indiqué anonyme, tu devrais virer ea_prod/ dans ton lien car si tu dois déplacer ton site à la racine de ton serveur, ou ailleurs...
                  Sauf que cela ne marche plus. Non seulement j'ai plus l'image mais le lien ne fonctionne plus.

                  De plus, après avoir viré /ea-prod/ et sauvegardé. quand je rouvre le code à la place de <A href="index.php? ...... il y a
                  <A href="/ea_prod/mambots/editors/spaw/index.php?

                  C'est l'editeur spaw qui me met celà tout seul ?
                  Obibi Kenowan
                  (La Force n'est pas toujours avec moi !)
                  Etienne Audfray Sculpteur http://www.audfray.com
                  Armand Petersen Sculpteur http://www.armand-petersen.fr

                  Commentaire


                  • #10
                    Envoyé par ObibiKenowan
                    Sauf que cela ne marche plus. Non seulement j'ai plus l'image mais le lien ne fonctionne plus.

                    De plus, après avoir viré /ea-prod/ et sauvegardé. quand je rouvre le code à la place de <A href="index.php? ...... il y a
                    <A href="/ea_prod/mambots/editors/spaw/index.php?

                    C'est l'editeur spaw qui me met celà tout seul ?
                    je viens de changer d'éditeur et mettre tiny.
                    là maintenant j'ai <a href="http://127.0.0.1/ea_prod/index.php?.....
                    et quand je vire http://127.0.0.1/ea_prod/ et que je sauvegarde et que j'ouvre à nouveau j'ai toujours <a href="http://127.0.0.1/ea_prod/index.php?.....
                    je comprends rien.
                    Obibi Kenowan
                    (La Force n'est pas toujours avec moi !)
                    Etienne Audfray Sculpteur http://www.audfray.com
                    Armand Petersen Sculpteur http://www.armand-petersen.fr

                    Commentaire


                    • #11
                      Envoyé par anonyme
                      J'ulitise un éditeur assez frustre mais avec lequel je n'ai aucun pb : "no wysiwyg editor", je te le conseille
                      -anonyme
                      Effectivement, j'ai mis "no wisiwyg editor" dans la config géné et quand je modifie le code, il reste tel quel.

                      dans le front, ça marche (en fait j'en sais rien tant que je n'aurais pas tout balancé sur free), il n'y a que dans le back ou l'image est remplacé par la croix rouge dans le cadre description de la catégorie quand je remet un editor wisiwyg.

                      mais bon ......

                      merci à tous.
                      Obibi Kenowan
                      (La Force n'est pas toujours avec moi !)
                      Etienne Audfray Sculpteur http://www.audfray.com
                      Armand Petersen Sculpteur http://www.armand-petersen.fr

                      Commentaire


                      • #12
                        gallerie Photos

                        J'ai lu ce que vous écrivez. Je viens de me faire créér un site web. J'essaie de mettre les photos mais c'est difficile pour. Les phots sont dans Datsogallery. Quand je fais DG, puis Pictures, je vois les fichiers photos uploadés, comment je dois les publier?
                        Merci

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X