Joomladay francophone 2018 à Paris 18 et 19 mai

Liens CB faux : erreur 404

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Liens CB faux : erreur 404

    Bonjour à tous !

    Je suis pour l'instant en local et je rencontre un problème avec le composant Community Builder. Tous les liens relatifs à ce composants sont "faux". Ils m'envoient tous sur une page "404 not found" m'indiquant que le lien n'est pas valide.

    En y regardant de plus près, je constate qu'au lieu que l'adresse soit constituée comme suit :
    http://localhost/test exemple/suite_du_lien
    Le lien m'envoie à la page :
    http://localhost/test exemple/test exemple/suite_du_lien

    Le "test exemple" étant repris deux fois au lieu d'une...

    Quelqu'un sait-il comment corriger ce problème ?

    D'avance un grand merci
    Dernière édition par Erix à 24/12/2009, 10h17 Raison: modération : déplacement vers forum adéquat
    Artistiquement parlant, le web est une grosse mise en scène en fait... Avec ses décors, ses coulisses, son jeu, son interactivité et ses spectateurs...

  • #2
    Salut Le mome et bienvenue sur le forum !

    J'ai créé une nouvelle discussion pour que ta question soit mieux vue. A la fin d'une discussion de 2008 elle avait peu de chance de trouver réponse

    Pour t'aider à utiliser le forum voici quelques liens qui te guideront dans tes débuts :

    1- Les règles du forum : http://forum.joomla.fr/showthread.php?t=3144 C'est la première étape, elle te permettra de comprendre ce qu'il faut faire et surtout ce qu'il ne faut PAS faire. Lis les attentivement c'est important.

    2- La forum questions générales sur Joomla! 1.5 : http://forum.joomla.fr/forumdisplay.php?f=133 C'est également un bon début puisque ce forum propose de répondre aux questions sur Joomla! en général, forum que tu utiliseras certainement souvent dans ton début d'apprentissage de Joomla!

    3- Extension tierce : http://forum.joomla.fr/forumdisplay.php?f=115 Quand tu auras bien pris en main Joomla! tu voudras surement avoir des renseignements sur les extensions déjà installées ou à installer dans ton CMS. Ce forum contient des sous-forum dédié aux grands groupes d'extension.

    VOilà pour le début, pense aussi à faire des recherches sur le forum, les questions que l'on se pose au début ont souvent déjà été posées et ont une réponse, profites-en !

    Bonne lecture et à bientôt sur le forum
    adishatz, érix
    https://www.agerix.fr/?utm_source=forumjoomlafr- Agerix partenaire du JoomlaDay 2018 : https://www.joomladay.fr/
    Vous aimez ce forum ? Aidez-nous à le maintenir en adhérant à l'AFUJ : http://www.joomla.fr/component/compr...ers?Itemid=825

    Commentaire


    • #3
      Re salut,

      Envoyé par Le mome Voir le message
      Bonjour à tous !

      Je suis pour l'instant en local et je rencontre un problème avec le composant Community Builder. Tous les liens relatifs à ce composants sont "faux". Ils m'envoient tous sur une page "404 not found" m'indiquant que le lien n'est pas valide.

      En y regardant de plus près, je constate qu'au lieu que l'adresse soit constituée comme suit :
      http://localhost/test exemple/suite_du_lien
      Le lien m'envoie à la page :
      http://localhost/test exemple/test exemple/suite_du_lien

      Le "test exemple" étant repris deux fois au lieu d'une...

      Quelqu'un sait-il comment corriger ce problème ?

      D'avance un grand merci
      2 pistes à réfléchir à mon avis :
      • Regarde quand même du coté de l'extension qui te gère la réécriture d'URL's, le natif de Joomla ou SH404sef,
      • vois aussi du coté de ton fichier htaccess, si tu as mis un htaccess costaud du genre de celui de syrius regarde s'il n'y a pas quelques lignes à modifier.
      adishatz, érix
      https://www.agerix.fr/?utm_source=forumjoomlafr- Agerix partenaire du JoomlaDay 2018 : https://www.joomladay.fr/
      Vous aimez ce forum ? Aidez-nous à le maintenir en adhérant à l'AFUJ : http://www.joomla.fr/component/compr...ers?Itemid=825

      Commentaire


      • #4
        Déjà merci pour ton accueil Erix. Ca fait plaisir

        J'ai été voir côté du côté de la configuration générale de Joomla en désactivant la réécriture d'url mais ça ne change rien.

        J'ai désinstallé et réinstallé plusieurs fois CB mais ça ne change rien non plus.

        Pour info, j'ai oublié de préciser que je suis sous Joomla 1.5.15 et j'utilise CB 1.2.1

        Ce qui est bizarre c'est que sous un autre site que je développe en local, je n'ai pas ce problème. Mais j'utilise Joomla 1.5.12 pour celui-ci...
        Artistiquement parlant, le web est une grosse mise en scène en fait... Avec ses décors, ses coulisses, son jeu, son interactivité et ses spectateurs...

        Commentaire


        • #5
          Salut,

          tu ne m'a pas dit pour le fichier htaccess, tu utilises ou pas ?
          adishatz, érix
          https://www.agerix.fr/?utm_source=forumjoomlafr- Agerix partenaire du JoomlaDay 2018 : https://www.joomladay.fr/
          Vous aimez ce forum ? Aidez-nous à le maintenir en adhérant à l'AFUJ : http://www.joomla.fr/component/compr...ers?Itemid=825

          Commentaire


          • #6
            Non je n'utilises pas htaccess ni de Sh404sef. Entretemps j'ai remis mon autre site à jour (Joomla 1.5.15) et CB fonctionne toujours sans prob. J'ai peut-être fais une mauvaise manœuvre mais je ne vois pas du tout quoi...
            Donc pour l'instant je recommence tout le site à zéro en commençant par installer CB 1.2.1 qui fonctionne. Mais c'est laborieux, j'ai pas mal d'article, de contact, d'évènements à copier-coller... J'étais arriver à la fin de sa construction...
            Artistiquement parlant, le web est une grosse mise en scène en fait... Avec ses décors, ses coulisses, son jeu, son interactivité et ses spectateurs...

            Commentaire


            • #7
              Alors voilà, j'ai trouver la réponse au problème. Je la publie pour la partager à ceux qui rencontreraient le même problème :

              En fait, travaillant en local j'avais un "domaine" contenant un espace à savoir :
              http://localhost/test exemple/suitedulien et Community Builder ne semble pas supporter les espaces.

              En les supprimant pour arriver à :
              http://localhost/testexemple/suitedulien le problème est résolu !

              En fait c'était tout bête mais il fallait y penser

              Merci à Erix pour l'aide qu'il a essayé de m'apporter
              Artistiquement parlant, le web est une grosse mise en scène en fait... Avec ses décors, ses coulisses, son jeu, son interactivité et ses spectateurs...

              Commentaire


              • #8
                Salut le mome,

                Je suis content de lire que tu as trouvé la solution, comme quoi il faut être perséverent et la solution fini souvent par arriver !
                Je passe ce fil de discussion en RÉGLÉ

                Joyeux Noël !
                adishatz, érix
                https://www.agerix.fr/?utm_source=forumjoomlafr- Agerix partenaire du JoomlaDay 2018 : https://www.joomladay.fr/
                Vous aimez ce forum ? Aidez-nous à le maintenir en adhérant à l'AFUJ : http://www.joomla.fr/component/compr...ers?Itemid=825

                Commentaire


                • #9
                  Effectivement, j'ai continué mes recherches pendant des jours et des nuits sans m'arrêter

                  Mais tu as raison, la persévérance !

                  Peux-tu me dire comment on met les post en "réglé" ? J'ai essayé de le faire mais je n'ai pas trouvé :s Pour plus tard, on sait jamais...
                  Artistiquement parlant, le web est une grosse mise en scène en fait... Avec ses décors, ses coulisses, son jeu, son interactivité et ses spectateurs...

                  Commentaire


                  • #10
                    Salut Le mome,

                    Envoyé par Le mome Voir le message

                    Peux-tu me dire comment on met les post en "réglé" ? J'ai essayé de le faire mais je n'ai pas trouvé :s Pour plus tard, on sait jamais...
                    Regarde ici : http://forum.joomla.fr/announcement.php?f=87
                    adishatz, érix
                    https://www.agerix.fr/?utm_source=forumjoomlafr- Agerix partenaire du JoomlaDay 2018 : https://www.joomladay.fr/
                    Vous aimez ce forum ? Aidez-nous à le maintenir en adhérant à l'AFUJ : http://www.joomla.fr/component/compr...ers?Itemid=825

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X