Nouveau utilisateur n’est pas dans la liste

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Nouveau utilisateur n’est pas dans la liste

    Bonjour,

    Que je cré un utilisateur ou qu’il s’enregistre lui-même, il n’apparais pas dans la Gestion des utilisateurs !! Alors qu’il peut bien s’identifier et on peut lui attribuer un contact.

    Quelqu’un a-t-il une idée pourquoi ?

    Merci

    jcs
    Dernière édition par tristana à 02/08/2006, 10h05
    Amateur de plantes sauvages et comestibles de la région méditerranéenne.
    http://garrigue-gourmande.fr

  • #2
    Va voir ce post

    http://forum.joomla.fr/showthread.php?t=13113

    A+
    Mon hébergeur
    http://www.jheberge.ch

    Commentaire


    • #3
      Envoyé par mccharlet

      Je reprend :

      « En fait joomla utilise trois tables.
      En mettant seulement la base jos_user, on peut utilisé les comptes, mails ils n'apparaissent pas dans la console de l’admin.
      Il faut aussi prendre les bases jos_core_acl_aro et jos_core_acl_groups_aro_map »

      C’est déjà une piste car effectivement il y avais encore des traces d’un utilisateur que j’avais créé auparavant mais pour une raison inconnue l’enregistrement avait échoué et quand j’ai voulu créé un nouveau utilisateur le formulaire de création était déjà préremplis avec les données de l’utilisateur précédent. Je suis donc aller dans ma base sql et j’ai effacé mon utilisateur dans

      jos_core_acl_aro et jos_user

      pas de trace dans jos_core_acl_groups_aro_map

      Une fois ma basse propre je recré un utilisateur, mon formulaire est alors vide, je le rempli et j’obtient le message Modifications enregistrées pour: testuser mais TOUJOUR PAS d’utilisateur dans ma liste.

      Dans ma basse sql j’ai bien retrouver mon user mais je m’étonne qu’il ai une ID = 0 !

      Il faut aussi avouer que j’ai installé le composant phpbb mais bizarrement les utilisateurs créés avec joomla peuvent aussi se loger au forum alors qu’il parait qu’il devait impérativement s’enregistrer dans phpbb.

      Plus j’apprend, moins je sais.

      jcs
      Amateur de plantes sauvages et comestibles de la région méditerranéenne.
      http://garrigue-gourmande.fr

      Commentaire


      • #4
        On approche de la solution…

        Dans la table « joomlacore_acl_aro » le champ « value » est égal à 0 alors qu’il devrais s’auto agrémenter car il correspond a l’ID de l’utilisateur.
        Dans la table « joomlacore_acl_groups_aro_map » il n’y a pas de ligne renseignant le groupe auquel appartient l’utilisateur.
        Dans la table « joomlausers » le champ ID est égal à 0 alors qu’il devrais correspondre a ID de l’utilisateur.

        Si je renseigne les valeur et le champ manquant à la main dans la basse sql, et voila que miracle mon utilisateur apparaît.

        Conclusion 3 heure de perdue pour ce rendre conte que c’est phpbb qui a foutu la zone avec sa gestion des utilisateurs et que même après ça désinstallation le problème persiste et qu’il faut probable ou certainement réinstaller joomla.

        Merci aux personnes qui mon aidées ou mis sur la voie.

        jcs
        Amateur de plantes sauvages et comestibles de la région méditerranéenne.
        http://garrigue-gourmande.fr

        Commentaire

        Annonce

        Réduire
        1 sur 2 < >

        C'est [Réglé] et on n'en parle plus ?

        A quoi ça sert ?
        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
        Comment ajouter la mention [Réglé] à votre discussion ?
        1 - Aller sur votre discussion et éditer votre premier message :


        2 - Cliquer sur la liste déroulante Préfixe.

        3 - Choisir le préfixe [Réglé].


        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

        2 sur 2 < >

        Assistance au forum - Outil de publication d'infos de votre site

        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

        UTILISER À VOS PROPRES RISQUES :
        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

        Problèmes connus :
        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

        Installation :

        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

        Archive zip : https://github.com/AFUJ/FPA/zipball/master

        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
        et remplacer www. votresite .com par votre nom de domaine


        Exemples:
        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/
        Pour executer le script: http://www..com/fpa-fr.php

        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/cms/
        Pour executer le script: http://www..com/cms/fpa-fr.php

        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
        Voir plus
        Voir moins
        Travaille ...
        X