Joomladay francophone 2018 à Paris 18 et 19 mai

GMAccess : erreur Vous n'êtes pas autorisé(e) à accéder à cette ressource.

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • GMAccess : erreur Vous n'êtes pas autorisé(e) à accéder à cette ressource.

    Bonjour,

    Je suis sous Joomla 1.0.13 avec GMAccess 3.2 (je réalise une base de connaissances pour le support info de Kiabi)

    Depuis que j'ai mis GMAccess j'ai ce message d'erreur qui apparait sur plusieurs articles ou modules

    Vous n'êtes pas autorisé(e) à accéder à cette ressource.
    Vous devez vous connecter.

    Par exemple sur les icônes pdf et mail de Joomla
    Par exemple sur le module DOCman Lister de Docman (il s'affiche mais lorsque je clique sur les liens du module j'ai le message. Pourtant en passant par le composant, j'ai bien accès aux docs)

    Même chose par exemple quand un "Author", publie un article, quand il le valide, il tombe sur ce message au lieu de voir sa procédure et de pouvoir donc directement la modifier (en gros la fonction Author ne marche plus, puisque l'utilisateur peut proposer un article, mais ne peut pas éditer SON article) : pour qu'il puisse le modifier j'ai mis le module mycontent, mais cela permet juste de contourner le problème)

    d'ailleurs je rajoute qu'à propos de Mycontent : quand je clique sur son lien, je vois donc tous les articles que j'ai posté, si je clique sur le petit logo pour modifier ça marche, mais si je clique sur les liens vers les articles, je tome encore une fois sur le message "Vous n'êtes pas autorisé(e) à accéder à cette ressource" alors que par les menus normaux j'ai bien accès aux procédures.

    Tous mes droits sont corrects, a priori en tout cas (mais même en me connectant en tant que superadmin j'ai les même messages et j'ai fait 10x le tour)

    J'ai cherché des heures, essayé pas mal de chose mais rien à faire
    Sur le forum j'ai longuement cherché mais je ne trouve pas la solution, pourtant beaucoup de monde semble concerné

    Pour info quand j'ai désinstallé GMAccess, les icônes mail et pdf par exemple ont de suite refonctionné !! (j'ai réinstallé et de nouveau le message réapparaît)

    Pour moi le bug vient donc bien de GMAccess

    Est ce quelqu'un peut me venir en aide car je ne m'en sors pas du tout

    Sylvain
    Dernière édition par scau à 30/01/2008, 11h45 Raison: info supp

  • #2
    Salut,

    Vérifie que la table gm_group ou quelque chose comme ca ait bien l'id "0" pour "public". C'est un problème connu que l'auteur tente de régler

    Commentaire


    • #3
      re

      Bonjour,

      Merci pour votre réponse mais a priori ça semble correct :

      Table: jos_gm_groupe :

      id_groupe nom_groupe description_groupe access_groupe
      0 **Public** Tous les visiteurs du site = Groupe Joomla "Public... 1
      1 **Membre** Tous les utilisateurs membres = Groupe Joomla "Reg... 1
      3 SGISVP Le Support Informatique Niveau I et Niveau II 1
      4 SGISVP24 Le Support Informatique 24h/24h niveau I 1
      5 PILTEC Le Pilotage Technique Niveau II 1

      C'est bien cela ??

      Sylvain

      Commentaire


      • #4
        C'est bien ca, malheuresement

        Commentaire


        • #5
          salut,

          désolé de faire remonter ce vieux topic mais je suis confronté au même pb.
          j'utilise bien gmaccess 3.2 pour la 1.013 mais malheureusement le "problème connu" semble persister sur mon site.

          merci d'avance de votre aide

          ps: je suis dans le même cas, j'ai bien 0 en ID

          Commentaire


          • #6
            re

            un debut de reponse

            Il semble qu'il faille mettre les droits en priorité sur les menus via GMa et non sur les articles

            Je declare les droits sur les menus et je laisse les articles en Public et presque pas de soucis. Par contre si je met mes articles avec des droits, alors j'ai le message qui revient

            sylvain

            Commentaire


            • #7
              Salut Scau

              Je rencontre le même problème et je n'ai pour le moment aucune solution concernant mon post (http://forum.joomla.fr/showthread.php?t=56931).

              Ta solution a l'air pas mal mais qu'en est-il des articles protégés par leur menu mais que la personne recherche avec la recherche Joomla ? Sont-ils accessibles car "Public" même si le menu est protégé ?

              Merci de ta réponse

              J'espère que l'éditeur trouvera une solution pérenne car je ne trouve aucun autre composant qui gère aussi bien les droits d'accès.

              Commentaire


              • #8
                hello j'ai à peu près le même souci


                j'ai installé my_content et gmaccess mais :
                1- la propagation des droits d'accès ne se fait pas sur mes articles même si je la demande
                2- est-ce normal que joomla ne reste pas sur les droits d'accès demandés ? je veux dire quand on clique dans le bouton radio "oui" pour la demande de propagation puis "absolu", ça revient systématiquement sur non ???

                au résultat : non seulement mes éditeurs ne peuvent pas éditer et corriger leurs articles mais en plus les publishers ne voient même pas les articles qu'ils peuvent publier...

                ça fonctionnait au départ ; pensant que c'était l'installation d'un autre composant qui avait fichu le bazar, j'ai désinstallé ces derniers composants, j'ai même désinstallé my_content et gma et réinstallés ces deux-là

                mais rien de rien...

                Commentaire


                • #9
                  eh bien je pense avoir identifié une partie (une partie seulement) de mon pb :

                  en vérifiant dans ma base, j'ai un membre d'un groupe de publishers qui possède ll'identifiant 68 (table jos_users)
                  quand sur le frontend, j'affiche les articles de ce publisher et ensuite le code source, je vois qu'il a l'identifiant 65, qui est celui d'un créateur d'article qui fait partie du groupe d'éditeurs...
                  et comme l'éditeur n'arrive pas non plus à éditer ses messages il est dans un autre pb...

                  je précise que j'ai bien vérifié les groupes, etc.

                  bon ça résoud rien du tout mais si quelqu'un a une piste... parce que je ne vois pas où déjà se fait la transfo d'id (et pourquoi )

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X