CB : Modif profil impossible + fields en doublon

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • CB : Modif profil impossible + fields en doublon

    Bonjour

    Allez savoir quelle bêtise j'ai encore bien pu faire (à priori moi je ne me souviens pas avoir fait quelque chose de bizarre).
    J'ai voulu tout simplement ajouter un champ d'infos utilisateur dans community builder (dernière version) et après ça je me suis aperçu que "paramètres du forum" (j'utilise également Joomlaboard) était en doublon... Et que les champs qui s'y réfèrent l'étaint aussi ! Et en frontend le profil utilisateur est impossible à modifier (on retombe toujours sur la même config qu'avant que les doublons n'apparraissent et en plus la signature a disparu).

    Une idée de ce qu'il s'est passé ? J'étais tellement contente d'avoir pasé presque un mois sans que mon site ne plante....

    Merci

  • #2
    As tu réglé ton soucis ?
    Parcequ'il m'est arrivé la même chose et j'ai réussi à m'en sortir en passant direct par la BDD.

    Passes par : jos_comprofiler_field_values & jos_comprofiler
    pour trouver les champs en double et les supprmier.

    Commentaire


    • #3
      Non, je n'ai pas réussi. En fait le problème était bien plus iportant, il s'agissait de la compatibilité entre ma version de Joomla (1.0.6 ou 7 à l'époque je crois) et CB... La modification des informations des membres était devenue impossible, et d'autres bugs du même genre. J'ai fini par désinstaller CB, ainsi que Joomlaboard, je suis passé sous un autre forum, et j'ai laisé tomber l'idée de communauté sur mon site pour le moment.

      Vivement Joomla 1.5.

      Commentaire


      • #4
        Hello tout le monde !

        Bon exactement le même problème, tout en double et impossible de modifier en frontend le profil d'un utilisateur. Je commence tout juste à monter mon site en local donc impossible de vous montrer tout ça en détail, mais j'avoue que j'aimerais bien que quelqu'un trouve la solution à (mon) notre problème...

        Par contre, j'ai bien cherché dans les tables comme Patoche le conseillait, mais pas de doublon dans la table ?!? Du coup j'ai préféré supprimer ledit doublon depuis le backend dans l'utilitaire de Joomlaboard

        Merci encore à toute personne qui pourra se pencher là dessus.
        Bon courage

        Commentaire


        • #5
          J'aimerais pouvoir vous aider.....
          Je ne sais pas trop quoi vous dire. En supprimant le composant et en le re-installant ( puis en suivant le tuto d'Hornos ), tout est rentré dans l'ordre. Avez vous bien pensé à synchroniser le module en question avec les utilisateurs déjà enregistrés ? Je précise que je n'ai eu que le soucis des entrées en double et non pas ce soucis de ne pas pouvoir éditer les détails des membres.

          Une nouvelle version de Communuty Builder est sortie récemement :
          http://forge.joomla.org/sf/frs/do/li...der_1_0_stable

          Allez jetter un oeil sur le site de Joomlapolis pour essayer d'installer cette version. On peut toujours espèrer que ce bug ait été corrigé. J'ai jetté un oeil sur le forum mais je n'y ait rien trouvé qui puisse vous aider.
          Dernière édition par Patoche à 25/05/2006, 21h01

          Commentaire


          • #6
            Pas mauvaise idée Patoche, et j'ai donc suivi ton conseil. Désinstallation du composant et des modules, puis réinstallation.

            J'avais fait ma première installation avec la version officielle disponible sur la forge, et en suivant le readme inclus. Dans le doute j'ai re-téléchargé le tout puis recommencé depuis le début tout en visionnant (pour la 3ème fois) le tutoriel de Hornos (sublimement bien fait ceci dit en passant ).

            Et là, c'est le drame ! Le problème n'est pas réglé, mais on a rajouté une couche : des triplons !

            Bon aller, puisque une image est parfois mieux qu'une longue explication...


            Vous remarquerez que les choix disponibles sont en triples (premier problème de doublons + réinstallation = triplons) mais que les champs eux sont en doubles car j'avais supprimé les doublons (doublons - doublons supprimé + réinstallation = doublons)...

            Ma théorie, c'est qu'il existe déjà une intégration prédéfinie entre Community Builder et Joomlaboard et que en suivant la procédure actuelle on réinstalle une couche. Je ne sais pas ce qu'en pense les spécialistes, et si mon hypothèse tient la route, mais je pense que ça vaut le coup de se pencher sur ce soucis.

            En attendant, je crois que je n'ai pas le choix, on va mettre les mains dans le cambouis et essayer de nettoyer les tables pour supprimer les triplons.

            A bientôt
            Fichiers joints
            Dernière édition par Asleeo à 26/05/2006, 22h14

            Commentaire


            • #7
              Pour les triplons, normal....
              chaque fois que tu fais une install il va rajouter les champs. Pour les supprimer de la BDD suis mes indications plus haut.

              A mon avis pour tes chmps en double, c'est un soucis de mauvais désinstallation car je n'ai jamais eu ce soucis. Domage que tu sois en local sinon je t'aurais proposé de prendre la main pour tenter de te faire l'install.

              Mais au fait quelle est ta version de Joomla ? Cela peut être utile de le savoir ?

              Tiens nous au courant !

              Commentaire


              • #8
                Ma version de Joomla est la 1.08 en français, téléchargé sur ce site, donc je ne pense pas qu'il y est de soucis de ce côté là...

                Coup de chance, j'en étais encore au début de la création de mon site web, donc si je ne trouve pas la solution, je pourrais toujours recommencer depuis le début mes installations, y compris Joomla. Mais bon, vu que je ne suis pas sûr que ça résolve le problème, je vais d'abord tenter de nettoyer les tables.

                Je vous tiens au courant, promis,
                A bientôt

                Commentaire


                • #9
                  Dernières infos,
                  J'ai supprimé directement dans les tables les champs en double, mais je sais pas ce que j'ai fait comme fausse manip', mais après ça impossible d'enregistrer un nouvel utilisateur car un message d'erreur empechait d'aller plus loin.

                  C'est pas grave, j'ai tout réinstallé, ça m'entraîne dans la maîtrise de Joomla! , et maintenant je n'ai plus de problèmes

                  Solution :
                  J'ai installé Community Builder avant Joomlaboard, donc dans l'ordre inverse de ma première installation (avec laquelle j'avais les problèmes cités plus haut: doublons et impossible de modifier les profils). Je ne sais pas si c'est de là d'où viens le bug, mais au moins si vous rencontrez le même problème que moi vous aurez une piste à suivre.

                  Pour les spécialistes : lors de l'installation de Community Builder, il faut mettre à jour la base avec Load Sample Data (This will load sample data into the Joomla Community Builder component).
                  Ma question est la suivante, est-il possible de faire l'opération inverse lors d'une désinstallation ?
                  (en vue d'une réinstallation).

                  Merci pour vos réponses et merci à Patoche pour la recherche de solutions
                  A+

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X