Joomfish, l'installation auto ne marche pas

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Joomfish, l'installation auto ne marche pas

    Impossible d'installer Joomfish voilà ce qu'il me met quand j'essaye de l'installer par le menu installer composant :

    ERROR: Could not find an XML setup file in the package.

    Que faire ?
    Dernière édition par Josh Parker à 22/03/2007, 12h05

  • #2
    salut à tous et à toutes,

    dézipper et installer

    note : au cas où, virifie si tu as bien le fichier .xml dedans, peut-être que tu as archive corrumpu...

    cordialement
    Agence web Joomla www.nartconcept.fr spécialisée en création de sites Joomla professionnels http://www.nartconcept.fr/services.html
    RT3 Framework : www.rt3.fr pour Joomla 1.7.x & 2.5

    Commentaire


    • #3
      Alors dézipper et installer : comment ?
      Installer c'est à dire mettre en ftp ? Dans quel répertoire ?

      Merci de la réponse

      Commentaire


      • #4
        Si Joomfish ne fonctionne pas sur la dernière version de Joomla, quelqu'un peut-il me donner un lien sur version plus ancienne ?

        Merci

        Commentaire


        • #5
          re salut,

          joomfish n'a pas de problème avec la dernière version de Joomla, j'ai fait la mise à jour d'un site et joomfish marche sans problème pour l'instant.

          bon, récommensons ;

          - tu l'as trouvé où cette version de joomfish
          - tu l'installes comment?
          - etc...

          explique ce que tu fais et comment

          bien cordialement
          Agence web Joomla www.nartconcept.fr spécialisée en création de sites Joomla professionnels http://www.nartconcept.fr/services.html
          RT3 Framework : www.rt3.fr pour Joomla 1.7.x & 2.5

          Commentaire


          • #6
            jai la version 1.011 de joomla jutilise joomfish je n ai pas de probleme non plus.

            Commentaire


            • #7
              J'ai téléchargé la dernière version de joomla et de joomfish à partir de ce site.
              La seule différence c'est que j'ai fait un clic droit sous windows dans le dossier joomla et désactiver lecture pour pouvoir supprimer ensuite les fichiers en ftp (sinon on ne peut pas supprimer les fichiers).

              Je tente une réinstallation complète. Et je reviens ici

              Commentaire


              • #8
                En téléchargeant depuis certains sites, le zip d'instal est lui même dans un zip. D'où :
                Envoyé par nart
                dézipper et installer
                J'ai jamais compri pourquoi ils font ça, moi aussi je me suis énervé un moment avant de comprendre

                Commentaire


                • #9
                  Non je ne comprend pas le fait de dézipper : à priori l'installation des modules se fait par l'upload d'un pack zippé dans l'admin non ? Si je dézippe j'installe comment ? En mettant en ftp directement ? Dans quel répertoire ?

                  Commentaire


                  • #10
                    Salut,

                    Certain zip sont prêt à l'emploi tel quel.

                    D'autres sont des packs zippés qui contiennent le module, le bot et le composant, alors il faut dézipper ce pack et utiliser les zip à l'intérieur
                    pour chaque composant, module et bot.

                    a+
                    Lenamtl

                    Commentaire


                    • #11
                      Je confirme, il y a un gros soucis d'upload du zip.
                      Si je ne fais pas un clic droit à mon installation de Joomla sous WinXP en désactivant la lecture seule, je n'ai plus de droits sur le serveur, donc plus de possibilités de changer les chmod ou encore plus de possibilité de supprimer les fichiers.

                      Donc je l'installe tel quel après cette modification dernière version disponible en ligne.

                      Je file directement dans l'admin. Je met en chmod 777 tous les répertoires qu'il me dit. Je fais installation de composant, et j'upload Joomfish 1.7.

                      Echec

                      ERROR: Could not find an XML setup file in the package.

                      Je réessaye sans chmod sur le répertoire d'installation

                      Commentaire


                      • #12
                        Est-ce que tu pourrais clarifier : ton serveur joomla est-il bien sous winXP ou sous Linux (chez qui on fait des chmod 777?)

                        Je file directement dans l'admin. Je met en chmod 777 tous les répertoires qu'il me dit.
                        je suppose que tu parles des chemins listés dans l'onglet permissions des infos systèmes ?

                        Je te suggère deux pistes de recherche :
                        1 - dans l'onglet PHP Info des infos systèmes, recherche la valeur de upload_tmp_dir, et vérifie que ce dossier est bien lui-aussi accessible en lecture par joomla
                        2 - dans la "configuration du site", Onglet "serveur", actives les deux zones Permissions de fichiers et Permissions des dossiers. Passe les !!temporairement!! en 777, et vérifie si l'install est possible.

                        Néanmoins, il semble s'agit plutôt d'un problème d'upload, donc la suggestion 2 ne devrait pas aider, car elle ne touche pas le dossier temporaire

                        SI tu es sous linux, il faut aussi penser qu'il ne suffit pas d'avoir les droits en lecture/ecriture pour accéder à un fichier, il faut aussi que le "owner" ou propriétaire ait ce droit d'accès.
                        Je suis toujours le développeur de sh404sef, mais il est désormais distribué par Weeblr. Je ne réponds plus aux MP sur ce composant. Merci de votre compréhension.

                        Commentaire


                        • #13
                          Bonjour Josh,
                          Nouveau venu chez joomla je me retrouve confronté au meme probleme que toi... en suivant les tets de shumisha sur PHP info il se trouve que mon fichier upload_tmp_dir m'indique : no value...
                          est-ce la le probleme ?

                          Commentaire


                          • #14
                            He bien il est possible, suivant les réglages que ton hébergeur a adopté, que cela cause le problème. Si aucune valeur n'est spécifiée pour upload_tmp_dir, alors PHP utilise le dossier temporaire par défaut du système, et il se peut que tu n'y es pas accès. Tu peux également avoir une instruction open_basedir qui te bloque l'accès

                            Attention, il y a une autre valeur qu'il faut vérifier, c'est "upload_files" qui doit être sur ON et non Off : un hébergeur peut bloquer tout upload de cette manière, mais ce serait surprenant quand même. Je ne suis pas sur à 100% que ce soit upload_files, mais ça y ressemble beaucoup.

                            D'une manière générale, tu devrais copier-coller le contenu de l'onglet Infos système (menu Système puis Informations système) dans lequel sont affichées les infos principales
                            Je suis toujours le développeur de sh404sef, mais il est désormais distribué par Weeblr. Je ne réponds plus aux MP sur ce composant. Merci de votre compréhension.

                            Commentaire


                            • #15
                              Ca à l'air bien pourtant, tu as un openbasedir sur /tmp, ce qui laisse à penser que ce répertoire t'es accessible. Il est possible que l'utilisateur apache n'est pas le droit d'y écrire. A ce stade, il faut te rapprocher de ton hébergeur pour voir s'ils peuvent faire quelquechose.

                              Alternativement, tu peux essayer de placer la igne suivante dans ton .htaccess, à la racinde de ton site (tout au début du htaccess si tu en as déjà un):

                              php_flag upload_tmp_dir /home/httpd/vhosts/keymark-km.com/httpdocs/tmp

                              après avoir créé à la racine de ton site un dossier /tmp
                              Suivant les hébergeurs, cela peut ne pas marcher car certains : interdisent de redéfinir les .htacces, ou invalides certaines instructions dans comme registers_globals off. Mais ça vaut le coup d'essayer (après avoir contacté ton hebergeur bien sur!)

                              EDIT : question bête, mais vous avez essayé d'installer d'autres composants ? modules ? mambots ? est-ce que cela fonctionne ou pas ?
                              Je suis toujours le développeur de sh404sef, mais il est désormais distribué par Weeblr. Je ne réponds plus aux MP sur ce composant. Merci de votre compréhension.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X