joomfish : langue EN par default

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • joomfish : langue EN par default

    Bonjour,
    jai site en EN et FR; Et pour cela j utilise joomfish.
    J ai configurer pour que la langue par default soit EN quand on tape l @.
    Mais ca reste tjr en FR.
    regarder comment ca été configurer :
    configuration generale : Cliquez sur l'image pour l'afficher en taille normale

Nom : imprime1.jpg 
Affichages : 1 
Taille : 31,1 Ko 
ID : 1807693
    configuration joomfish : Cliquez sur l'image pour l'afficher en taille normale

Nom : imprime2.jpg 
Affichages : 1 
Taille : 54,8 Ko 
ID : 1807694
    Il me semble que jai bien configurer pour que ce soit tjr en EN . non?
    Voici l url de mon site : www.3design.com/cms





    PB reglé grace à gronado MERCI
    Dernière édition par huynhi à 04/12/2006, 15h06

  • #2
    bon sur un sujet ouvert par un autre utilisateur jai cru comprendre que la langue se mettait en fonction du navigateur du visiteur, cad, qui si il est anglais ben il tombera sur l anglais directement ou si il est francais ben ce sera du francais...
    Mais si ils sont ni l un ni l autre... Quel langue s affichera?

    Commentaire


    • #3
      Re bonjour,
      Je vois que mon sujet n attire pas grand monde lol.

      Je rencontre un souci par rapport à l affichage par default selon le navigateur de la personne.

      C est que jai mis en bandeau sur la page d accueil une anim flash.
      J ai ais un bandeau en EN et FR.

      Voici el script que jai mis pour gerer le bandeau selon la langue:
      <? if ($_GET['lang']==en) { ?>
      <div>
      <script>
      embed_flash("./templates/images/bandeau.swf", 949, 206, 'bandeau' , '#FFFFFF', '', '', 4);
      </script>
      </div>
      <? } else { ?>
      <div>
      <script>
      embed_flash("./templates/images/bandeau_FR.swf", 949, 206, 'bandeau' , '#FFFFFF', '', '', 4);
      </script>
      </div>
      <? } ?>
      Mais le probleme est que quand je tape l adresse du site c est a dire www.3design.com, le parametre "lang" ne s affiche pas. Du coup le bandeau par default qui se mettra par rapport a mon site est le bandeau FR.

      Comment faire pour résoudre ce probleme????

      Merci

      Commentaire


      • #4
        fais un test sur la langue du navigateur aussi, avec ca :

        Code PHP:
        <?php
            
        echo "Vous acceptez les langues suivantes: ".
                 
        $_SERVER["HTTP_ACCEPT_LANGUAGE"]."<br>";
            
        $langs=explode(",",$_SERVER["HTTP_ACCEPT_LANGUAGE"]);
            echo 
        "mais votre langue préférée est: $langs[0]";
        ?>
        Et tu récupères la langue préférée du navigateur, dans mon cas le fr.

        ++
        JoomlaSite Integrateur

        Commentaire


        • #5
          alors jai rajouter dans ma page
          <?php

          $_SERVER["HTTP_ACCEPT_LANGUAGE"]."<br>";
          $langs=explode(",",$_SERVER["HTTP_ACCEPT_LANGUAGE"]);

          ?>
          et

          <? if ($_GET['lang']==fr) and ($langs == FR) { ?>
          <div>
          <script>
          embed_flash("./templates/images/bandeau_FR.swf", 949, 206, 'bandeau' , '#FFFFFF', '', '', 4);
          </script>
          </div>
          <? } else { ?>
          <div>
          <script>
          embed_flash("./templates/images/bandeau.swf", 949, 206, 'bandeau' , '#FFFFFF', '', '', 4);
          </script>
          </div>
          <? } ?>
          Mais jai erreur qui s affiche "parse error"

          Ce n est pas comme cela quil faut fairE?

          Commentaire


          • #6
            heu nan pas trop alors reprenons :

            Tu vas remplacer ca :
            Code PHP:
            <?php

            $_SERVER
            ["HTTP_ACCEPT_LANGUAGE"]."<br>";
            $langs=explode(",",$_SERVER["HTTP_ACCEPT_LANGUAGE"]);

            ?>
            par ca :

            Code PHP:
            <?php
            $langs
            =explode(",",$_SERVER["HTTP_ACCEPT_LANGUAGE"]);
            ?>
            Et ensuite ca :

            Code PHP:
            <? if ($_GET['lang']==fr) and ($langs == FR) { ?>
            <div>
            <script>
            embed_flash("./templates/images/bandeau_FR.swf", 949, 206, 'bandeau' , '#FFFFFF', '', '', 4);
            </script>
            </div>
            <? } else { ?>
            <div>
            <script>
            embed_flash("./templates/images/bandeau.swf", 949, 206, 'bandeau' , '#FFFFFF', '', '', 4);
            </script>
            </div>
            <? ?>
            par ca :

            Code PHP:
            <?php
            if ((isset($_GET['lang']) && $_GET['lang']== "fr") || ($langs[0] == "fr")) {
            ?>
            <div>
            <script>
            embed_flash("./templates/images/bandeau_FR.swf", 949, 206, 'bandeau' , '#FFFFFF', '', '', 4);
            </script>
            </div>
            <?php } else { ?>
            <div>
            <script>
            embed_flash("./templates/images/bandeau.swf", 949, 206, 'bandeau' , '#FFFFFF', '', '', 4);
            </script>
            </div>
            <?php ?>
            Essaye pour voir et dis moi !!!

            Tchusss

            ++
            JoomlaSite Integrateur

            Commentaire


            • #7
              Merci Gonado pour ton aide mais ca ne marche pas :'(
              quand je lance le site je tombe directement sur le Francais avec le bandeau francais, par contre quand je vais en Anglais jai tjr le bandeau francais... Est ce parce qu il se dit que la langue preferé du navigateur est le FR et qu il ne prend pas en compte le parametre lang de lurl?
              Dernière édition par huynhi à 29/11/2006, 08h45

              Commentaire


              • #8
                tu as vidé ton cache pour voir ???
                Tu peux me filer l'index.php de ton template pour que je regarde ???
                Dernière édition par gonado à 29/11/2006, 09h12
                JoomlaSite Integrateur

                Commentaire


                • #9
                  Oui jai bien pensé à vider mon cache a chaque fois .
                  Je viens de t envoyer un mp

                  Commentaire


                  • #10
                    t'as modifier ton option cache dans le menu joomfish?

                    Commentaire


                    • #11
                      ya pas de option cache ds joomfish

                      Commentaire


                      • #12
                        -> le code de langue peut être récupérer dans $_COOKIE['mbfcookie']['lang'],
                        il faut donc penser à supprimer les cookies pour réinitialiser le switch de langues en période de test.

                        Sinon il existe un mambot nommé "Multi lingual abstraction layer bot" installé par défault,il permet de paramétrer la méthode du choix de la langue par défault (notamment en fonction du navigateur ou pas)

                        -----------jmc------------

                        www.ActenGo.com
                        solutions intéractives
                        Dernière édition par actengo à 18/07/2007, 18h51

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X