Joomladay francophone 2018 à Paris 18 et 19 mai

Choix de langue ne s'affiche pas dans le frontend

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Choix de langue ne s'affiche pas dans le frontend

    Bonjour,

    Petit problème : j'ai fait la traduction de mon site avec JoomFish en all et it en backend mais je n'ai pas la liste déroulante qui s'affiche dans le frontend. Donc les visiteurs ne peuvent pas choisir la lange. Pourtant j'ai bien activé les 3 langues (fr, all, it) dans JoomFish.

    Quand je vais sur etat de joomfish j'ai le message d'erreur suivant :
    Warning: Invalid argument supplied for foreach() in /home/www/d67aead650e6ec6a33f40f21689a9a65/web/administrator/components/com_joomfish/admin.joomfish.html.php on line 275

    Alors j'ai télécharger le fichier indiqué et j'ai regardé la ligne 275 et c'est marqué : foreach ($stateRow as $row) {

    Quelqu'un sait ce que je dois remplacer sur cette ligne? Toute autre forme de solution est bienvenue car je ne connais pas du tout le php



    PS: j'ai déjà fait un test en local et tout fonctionnait bien mais en faisant le site sur le serveur je recontre ce problème
    Dernière édition par taydee à 28/02/2008, 07h24

  • #2
    Personne n'a une petite idée? Même si c'en est autre que modifier du code...

    Commentaire


    • #3
      Pour le choix des langues, il faut utiliser un module : mod_jflanguageselection, disponible sur le site de Joomfish.
      Tous les services pour les sites Joomla! : sécurité, nettoyage de sites piratés, hébergement, SEO, applications, migration, compatibilité mobiles, accessibilité, ...

      https://www.betterweb.fr/services

      Commentaire


      • #4
        Merci pour ta réponse. En fait c'était tout simple. Si je l'avais consulté avant je n'aurais pas comis une grande erreur. T'as une pour régler ça?

        ------------------------------------------------------------------------
        Là j'ai encore un plus grand problème! J'ai désinstallé le module joomfish et essayé de le réinstaller et maintenant je peux même plus renter dans l'admin du site. Chque fois que je met mon nu et mdp ça me met l'erreur suivant:

        Warning: require_once(/home/www/d67aead650e6ec6a33f40f21689a9a65/web/administrator/components/com_admin/admin.admin.php) [function.require-once]: failed to open stream: Permission denied in /home/www/d67aead650e6ec6a33f40f21689a9a65/web/administrator/index2.php on line 69

        Help!
        Dernière édition par taydee à 03/12/2007, 12h10

        Commentaire


        • #5
          Je trouve pas "mod_jflanguageselection" ni sur le site de google ni sur le site de joomla. Quelque'un a-t-il un lien pour télécharger ce module?

          Commentaire


          • #6
            Envoyé par taydee Voir le message
            Je trouve pas "mod_jflanguageselection" ni sur le site de google ni sur le site de joomla. Quelque'un a-t-il un lien pour télécharger ce module?
            http://www.joomlafrance.org/telechar.../JoomFish.html

            Salut il est dans le zip "version 1.8",dossier module

            a+
            www.archangelbay.fr
            Photographies de la baie du Mont Saint Michel
            www.afd-dol.fr
            L'histoire du Pays de la Baie

            Commentaire


            • #7
              Re,

              j'ai télécharger le module mais je sais pas quoi faire ensuite...

              Commentaire


              • #8
                Envoyé par taydee Voir le message
                Re,

                j'ai télécharger le module mais je sais pas quoi faire ensuite...
                Quand tu dit j’ai installé le module, tu a fait une réinstallation complète de la 1.8 et tu n’a toujours pas le module JoomFish language selection ?

                Si il est présent contrôle : la publication du module, et dans les paramètres si Show active language est sur yes contrôle aussi Appereance of language selector est sur drop down of names ou sur ul liste of names si en horizontale
                je cherche?
                www.archangelbay.fr
                Photographies de la baie du Mont Saint Michel
                www.afd-dol.fr
                L'histoire du Pays de la Baie

                Commentaire


                • #9
                  En fait au début j'ai créer mon site en local et tout fonctionnait bien. Ensuite je l'ai transférer sur le serveur d'hébergement et j'ai eu ce problème de langues. J'ai réinstallé JoomFish et ça m'a mis bcp d'erreurs alors j'ai reconstruit le site directement sur le serveur mais de nouveau pas de langues. Ensuite j'ai transférer le fichier mod_jflanguageselection sur le serveur au même endroit (ajouter au même fichier) ou il se trouve en local mais tjrs le même problème. J'ai peur en réinstallant JoomFish que ça me remet la même erreur et que je doivent recommencer le site depuis le début..

                  Commentaire


                  • #10
                    Install Joomfish

                    Joomfish, car il fonctionne, est un composant, module, mambot...

                    C'est un ensemble qui doit garder une cohérence....

                    A priori tu as un probléme d'install sur ton serveur distant ?

                    Est tu passé par une copie manuelle (genre FTP) des fichiers de Joomfish sur ton serveur distant ?

                    As tu accés à ton panel d'admin ?

                    Commentaire


                    • #11
                      Oui j'ai accès sur le pannel admin du site et du JoomFish. J'ai passé mes fichiers par FileZilla sur le serveur distant.

                      Quand je vais sur le pannel admin joomfish j'ai un message dans Etat: Warning: Invalid argument supplied for foreach() in /home/www/d67aead650e6ec6a33f40f21689a9a65/web/administrator/components/com_joomfish/admin.joomfish.html.php on line 275
                      Etat de l'extension

                      Warning: Invalid argument supplied for foreach() in /home/www/d67aead650e6ec6a33f40f21689a9a65/web/administrator/components/com_joomfish/admin.joomfish.html.php on line 275

                      Je peux effectuer les traductions sur le pannel admin mais sur le site il n'y a pas d'options pour choisir la langue, c'est automatiquement en français.

                      Noramalement si je désinstaller et réinstalle JoomFish ça devrait corriger le problème? Ou il y a une autre solution?

                      Commentaire


                      • #12
                        tu es probablement chez infomaniak c'est un problème lié aux droits (777) il faut lire la FAQ de infomaniak pour résoudre le problème c'est un script mais c'est pas simple... Car il faudra le faire pour chaque fichier... et c'est long...
                        Dernière édition par HDTV à 29/01/2008, 17h55

                        Commentaire


                        • #13
                          En effet je suis chez infomaniak. Je vais changer les droits d'ici la semaine prochaine et j'indiquerai si ça a fonctionné.

                          Dans tout les cas je te remercie de m'avoir donné une piste

                          Commentaire


                          • #14
                            voici le script

                            tu crée un fichier texte avec BBedit pas word !!!

                            tu mets ceci:
                            Code:
                            <?
                            $old = umask(0000);
                            chmod("web/components/mosjoom/templates/default/tp03.jpg", 0777);
                            umask($old);
                            ?>
                            tu le nomme comme tu veux .php

                            avec ce script tu peux changer les droits d'un dossier ou d'un fichier il suffit de lui dire ou il se trouve et tu le met a la racine de web...

                            Commentaire


                            • #15
                              Alors j'ai créer un fichier php avec dreamweawer en indiquant le chemin. Ensuite j'ai essayé de changer les droits en 777 du dossier et du fichier qui pose problème (d'après le message d'erreur qui s'affiche sur console admin) mais ça ne fonctionne pas car il me remet à chaque fois les droits d'avant. Je comprend pas pourquoi ça n'a pas marché pourtant j'ai suivie correctemnt la démarche..

                              Si je désinstalle et réinstalle le joomfish est-ce que ça pourrait corriger le problème?

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X