joomfish et recherche : quels mambots ?

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • joomfish et recherche : quels mambots ?

    bonjour
    j'ai démarré un site multilingue Joomla 1.08 / Joomfish :
    langue de base : anglais, traductions en français, autres langues à venir

    mon soucis vient des recherches, dont les résultats sont :
    - soit corrects en anglais, mais doublés en français (2 fois chaque entrée)
    c'est quand je laisse les mambots "multi lingual content" et content search publiés

    - soit corrects en français, mais rien en anglais : c'est quand je laisse seulement le mambot "multi lingual content" publié, et aucun autre

    je ne vois pas comment n'avoir les résutats qu'une seule fois

    il me semblait bien avoir testé et que cela fonctionnait au moins en local, mais je n'ai plus la machine sous la main pour vérifier

    je souhaiterais conserver la possibilité de rechercher un terme anglais même depuis le français, tout n'est pas traduit, et certains termes viennent parfois mieux dans la version originale

    avez vous constaté la m^me chose ?
    une idée ?

    merci

  • #2
    ah, ça m'intéresse aussi ça...

    Commentaire


    • #3
      Bonjour
      j'ai le même problème la recherche ne fonctionne pas en version 'de' ou 'uk'
      c'est gênant faut il un bot special? une idée?
      ALSASYS - Intégration & Développement spécifique Joomla - 39, avenue des Champs-Elysées - F-75008 Paris - Tél. 01 53 83 10 63 - www.alsasys.com

      Commentaire


      • #4
        j'ai laissé le mambot recherche activé, en plus de celui de recherche multilangue de joomfish : la recherche marche en anglais (langue principale) et sort les résultats en double pour les autres langues : pas joli, mais celma permet d'attendre

        Commentaire


        • #5
          Problème avec la recherche multilingue (joomfish)

          Bonjour,

          J'ai démarré un site multilingue Joomla 1.10 et j'ai installé Joomfish.
          j'ai également activé le module de recherche (Modules -> Modules du site) et le mambot "multi lingual content searchbot" est bien activé dans la liste des mambots du site.

          En revanche, j'ai le problème suivant, lorsque j'effectue une recherche alors que j'ai sélectionné "English" dans le sélecteur de langues. J'obtiens dans les résultats le titre et texte en français dans la liste des résultats trouvés même si le contenu en question possède une traduction en anglais...

          En revanche, pour les contenus statiques, j'obtiens bien le nom et le texte de l'article en anglais, dans la liste des résultats trouvés.

          Est ce que c'est normal ou est ce qu'il faut effectuer un paramétrage spécifique pour les articles non statiques ?

          Merci d'avance pour vos réponses.

          Commentaire


          • #6
            le bot multilingue (joomfish) dispose du paramètre suivant
            Active language only: Yes

            il faut désactiver les autres bots de recherche (duplication)

            par contre pour la langue par défaut, le bot ne semble pas chercher dans le contenu original. Une solution: il faut introduire une traduction (identique à l'original) en cliquant sur le bouton de copie

            si qqun à une solution plus propre, je suis preneur (peut-etre ai-je mal utilisé joomfish ?)

            bien à vous
            -- christophe

            Commentaire


            • #7
              J'ai aussi tt ces problèmes mais en plus quand je clic sur une des recherches il ne va pas sur la page de l'article mais sur une page qui me di :
              Vous n'êtes pas autorisé(e) à accéder à cette ressource.
              Vous devez vous connecter.
              Vous devez vous identifier.


              Alors que l'article est accessible par le public !!

              Mais sur certain lien il y a pas de problèmes.

              Comment faire?
              Existe-il un composant ou au autre module pour la recherche ?

              Commentaire


              • #8
                Bonjour tomcat5,
                j'ai le même problème... as-tu réussi à le résoudre?

                Commentaire


                • #9
                  Envoyé par baldus Voir le message
                  le bot multilingue (joomfish) dispose du paramètre suivant
                  Active language only: Yes

                  il faut désactiver les autres bots de recherche (duplication)

                  par contre pour la langue par défaut, le bot ne semble pas chercher dans le contenu original. Une solution: il faut introduire une traduction (identique à l'original) en cliquant sur le bouton de copie

                  si qqun à une solution plus propre, je suis preneur (peut-etre ai-je mal utilisé joomfish ?)

                  bien à vous
                  -- christophe
                  Exactement, j'ai du modifier le bot de joomfish : http://forum.joomla.fr/showthread.php?t=45576

                  Mais ce n'est pas très propre ...
                  http://www.telenaro.net
                  http://www.miranda-fr.net
                  http://lieji.net

                  Commentaire


                  • #10
                    Il y aurait moyen, sans abuser de votre generosite, de nous expliquer ce qu'il faut modifier ?
                    J'ai encore quelques soucis lorsqu'il faut plonger dans le code des composants :s

                    Merci encore pour les solutions que vous apportez !

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X