Docman et "error uploading directory"

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Docman et "error uploading directory"

    Je tiens à vous transmettre une astuce qui a marché pour moi conernant le composant Docman.

    Pour infos j'utilise :
    Docman 1.3 RC1
    Hébergeur : 1 and 1

    Comme beaucoup de personnes, je me suis heurté au message suivant "error uploading directory" quand j'ai souhaité uploader un fichier à partir de l'interface administrateur.

    J'avais pourtant bien pris le soin de vérifier deux paramètres :

    - le CHUMOD 777 du dossier dmsdocuments
    - le chemin d'accès au fichier de stockage dans la configuration de docman

    Malgré cela, ça ne marchait toujours pas.

    Et la fin du calvaire arriva enfin en croisant ce thread :


    http://www.mambodocman.com/index.php...6&limitstart=6


    Ainsi, mon problème a été résolu en suivant la manipulation suivante :

    - Aller dans les paramètres de configuration de docman
    - Onglet Upload>Filenames with blanks : mettre "Convert to underscores" à la place de "Allow blanks"


    Et là comme par miracle, ça marche!

  • #2
    Docman upload

    Génial, çà marche aussi pour moi. Super trouvaille !
    Merci Skapout

    Commentaire


    • #3
      Pb Docman

      Envoyé par skapout
      Je tiens à vous transmettre une astuce qui a marché pour moi conernant le composant Docman.

      Pour infos j'utilise :
      Docman 1.3 RC1
      Hébergeur : 1 and 1

      Comme beaucoup de personnes, je me suis heurté au message suivant "error uploading directory" quand j'ai souhaité uploader un fichier à partir de l'interface administrateur.

      J'avais pourtant bien pris le soin de vérifier deux paramètres :

      - le CHUMOD 777 du dossier dmsdocuments
      - le chemin d'accès au fichier de stockage dans la configuration de docman

      Malgré cela, ça ne marchait toujours pas.

      Et la fin du calvaire arriva enfin en croisant ce thread :


      http://www.mambodocman.com/index.php...6&limitstart=6


      Ainsi, mon problème a été résolu en suivant la manipulation suivante :

      - Aller dans les paramètres de configuration de docman
      - Onglet Upload>Filenames with blanks : mettre "Convert to underscores" à la place de "Allow blanks"


      Et là comme par miracle, ça marche!
      Bonjour Skapout,

      J'ai le même pb, mais je n'y arrive pas.

      J'ai:
      - Dossier dmdocuments en 777
      - chemin d'accès: c:/program files/easyphp1-8/www/dmdocuments
      - mis "Convert to underscores" à la place de "Allow blanks"
      - j'ai DOCMan v1.3 RC1
      - j'utilise : "Upload a file from your computer"

      mais ça ne marche pas. J'ai toujours "Error uploading. - Directory problem"

      Je ne vois pas où est mon pb.

      As-tu une idée ?

      Cordialement
      Site d'un artisan : www.bgs-alu.com

      Commentaire


      • #4
        Pb réglé

        Bonjour,

        Grosse bétise de ma part : le chemin d'accès n'est pas celui indiqué bien évidemment.

        Maintenant tout marche bien

        Merci Skapout pour ta trouvaille

        Cordialement
        Site d'un artisan : www.bgs-alu.com

        Commentaire


        • #5
          salut moi sa marche toujours pas
          quelqu' un pourrait m'aider svp??
          Merci

          Commentaire


          • #6
            upload impossible

            Envoyé par skapout Voir le message
            Je tiens à vous transmettre une astuce qui a marché pour moi conernant le composant Docman.

            Pour infos j'utilise :
            Docman 1.3 RC1
            Hébergeur : 1 and 1

            Comme beaucoup de personnes, je me suis heurté au message suivant "error uploading directory" quand j'ai souhaité uploader un fichier à partir de l'interface administrateur.

            J'avais pourtant bien pris le soin de vérifier deux paramètres :

            - le CHUMOD 777 du dossier dmsdocuments
            - le chemin d'accès au fichier de stockage dans la configuration de docman

            Malgré cela, ça ne marchait toujours pas.

            Et la fin du calvaire arriva enfin en croisant ce thread :


            http://www.mambodocman.com/index.php...6&limitstart=6


            Ainsi, mon problème a été résolu en suivant la manipulation suivante :

            - Aller dans les paramètres de configuration de docman
            - Onglet Upload>Filenames with blanks : mettre "Convert to underscores" à la place de "Allow blanks"


            Et là comme par miracle, ça marche!

            bonjour,
            Sans modifier le chmod du répertoire dmdocuments et en appliquant uniquement la méthode (Onglet Upload>Filenames with blanks : mettre "Convert to underscores" à la place de "Allow blanks") l'upload fonctionne désormais en frontend et en backend.
            Merci pour l'info.

            Commentaire


            • #7
              Salut,

              Il y a une règle toute simple pour éviter ce genre de problème, toujours utiliser des noms de fichier:

              - en minuscules
              - sans espaces
              - sans signes diacritiques (caractères accentués)
              - sans caractères spéciaux autres que le tiret et l'underscore (tiret bas)
              Pas de demande de support en MP ou par mail, le forum est là pour ça!
              http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
              http://www.lapatagonie.com : juste pour vous dépayser un peu...

              Commentaire


              • #8
                pfffffff ben chez moi ça ne marche pas !

                J'utilise DOCMan v1.3 RC2 en français,
                mon répertoire (Chemin de stockage des fichiers) est bien celui indiqué dans la config, il est bien en chmod 777,
                j'ai bien demandé que pour les "Noms de fichier comportant des espaces" le transfert se fasse "en convertissant en tirets bas (underschore)
                ...

                et j'ai tjrs ce p***** de message d'erreur, même avec un fichier tout en minuscules !!!


                Help help, please

                Commentaire


                • #9
                  Salut, j'ai rencontré le même erreur. Voici ma solution,
                  Composants -> Docman -> Configuration -> Upload -> Tu vas mettre "Yes" pour l'option "User can upload all file types?".

                  J'espère que cela marche bien avec toi.

                  Commentaire


                  • #10
                    resoudre le probleme de chmod d abord avec docman

                    Moi aussi ca ne marchait pas ni avec docman ni avec jooget.

                    Alors j ai fait ca : Docman : j'ai créé un nouveau repertoire par ftp et j ai mis 777 car le repertoire par defaut ne passe pas. Et j'ai changé le chemin d acces dans le CP. Et je telecharge mes fichiers par ftp. une fois telecharge je vais dans docman et je le vois dans gestions de documents

                    pratique quand on veut mettre nous meme les telechargements sans deamnder de contribuer aux utilisateurs

                    Dans jooget : en fait quand vous regardez le repertoire vous avez file picture etc Donc j ai effacé ses dossiers et recree avec le meme nom. et la je peux a nouveau changer le chmod

                    et pareil je telecharge via le ftp ca marche nickel

                    Commentaire


                    • #11
                      Je suis sous windows, avec un joomla 1.5, et malgré les p'tites astuces données dans ce topic, je n'y arrive toujours pas.

                      Est ce un problème de compatibilité avec joomla 1.5, est ce qu'il y a d'autres réglages à faire ?

                      Merci.

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X