DOCLink

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • DOCLink

    Salut à tous,
    J'aimerais insérer dans des articles des liens vers des documents gérés sous docman : visiblement le bot DOCLink est fait pour ça.
    Sur ma config, l'icone attendue pour rajouter le lien est totalement absente de mon editeur wysiwyg...
    Si quelqu'un à réussi à le faire fonctionner je suis preneur (je sais on peut aussi faire "betement" en copiant le lien du doc, mais bon c pas propre et les utilisateurs du site doivent pouvoir le faire...)

    Voici ma config :
    • Joomla 1.0.11 (editeur tiny standard)
    • bot doclink 1.0 RC 1
    • Docman 1.3.0 RC 1


    Merci d'avance ....

  • #2
    je pense que tu dois insererle bouton dans ton editeur ? Tu utilises quoi comme editeur au fait ?

    Commentaire


    • #3
      comme indiqué plus haut, j'utilise l'éditeur standard présent dans les dernières version de joomla à savoir "TinyMCE WYSIWYG Editor".

      En effet il est possible qu'il faille rajouter le bouton pour lancer la popup de doclink mais je n'ai pas trouvé où, et je n'ai pas trouvé d'aide sur le forum...

      (j'ai uniquement les deux icones de Mosimage et Mospagebreak lorsque j'édite une article)
      Merci ...
      Dernière édition par thelys à 10/09/2006, 19h03

      Commentaire


      • #4
        pour info, j'ai upgradé Docman à la derniere version (DOCMan v1.3 RC2) et le dernier mambot Doclink (1.0 RC2) également : pas mieux ! le bouton n'est toujours pas visible...

        Commentaire


        • #5
          up up up !!

          personne n'a réussi à utiliser doclink ??

          Commentaire


          • #6
            Je ne peux pas vous aider car j'ai malheureusement le même problème
            Si quelqu'un avait une solution ??

            Commentaire


            • #7
              Salut,

              J'ai l'impression que DocLink n'est pas compatible pour tinymce...
              A essayer avec fckeditor ou jce peut-être...

              [Edit]
              Nan j'ai dis une betise (encore)
              Dans le fichier readme, on peut voir
              DOCLink supports :

              1. TinyMCE
              2. HTMLArea3 XTD v1.0 beta
              3. WysiwygPro 2.2.4
              Donc ce n'est pas un problème lié à l'editeur...
              Pour l'installation, nous avons ça:

              DOCLink can be auto-installed and upgrade using DOCMan's 1.3
              auto installer and upgrade functionality. If for some reason
              this doesn't work u can always manual installe DOCLink.

              A. Auto install/upgrade : In DOCMan's backend choose upgrade
              B. Manual install : Use mambo's built in mambot installer.
              Pour ma part j'ai directement utilisé la "Mambo Installation"... et tout comme vous... aucune trace de ce bouton loll
              Je vais continuer à regarder tout ça...

              @+


              [Edit 2]
              Bon bon... alors là je ne vois pas du tout
              Sur le forum de Docman, beaucoup de personnes signalent ce problème... mais il n'y a jamais de réponses ou l'eternelle réponse "avez vous pensez à publier le bot ?" Mais rien de plus...

              Et j'ai essayé de dépublier et republier Tinymce pour voir (sait on jamais) si après il n'integrerai pas le bouton doclink... mais nan toujours au même point et d'ailleurs même dépublier, Tinymce apparait toujours ... (ça doit pas être normale ça non plus).

              En testant la methode de l'auto-install par la fonction "Update" (comme indiquée sur le Quote que j'ai fait), ben ça ne fonctionne même pas pusiqu'il ne me trouve même pas d'update à faire...
              Enfin bref, j'ai encore passé une nuit entière à essayer de résoudre mes soucis... et je me retrouve avec encore + de problemes et de questions

              Je sais pas si c'est moi, mais là par moment, je demande si il n'y a pas des problèmes avec cette version 1.0.11 de Joomla! ... c'est la premiere fois que je rencontre autant de soucis... Elle sort quand la version 1.0.12 ? lollll

              @+
              Dernière édition par Thalyn à 22/10/2006, 04h56

              Commentaire


              • #8
                Salut,
                J'utilise DocLink sans pb sur tinyMCE. Pour faire apparaitre l'icône il y a néamoins une petite ruse.

                1. Va dans Mambots > gestion des mambots : dépublie tous les éditeurs sauf "Aucun éditeur WYSIWYG"
                2. Va dans Gestion du site > configuration du site : tu dois avoir "Aucun éditeur WYSIWYG" dans éditeur wysiwyg par défaut. Clique sur SAUVER.
                3. Edite n'importe quel article (de manière a initialiser le bot "Aucun éditeur WYSIWYG"). Tu peux maintenant annuler l'édition.
                4. Retourne dans Mambots > gestion des mambots : dépublie tous les éditeurs (y compris "Aucun éditeur WYSIWYG) sauf "TinyMCE"
                5. Retourne dans Gestion du site > configuration du site : tu dois maintenant avoir "TinyMCE" dans éditeur wysiwyg par défaut. Clique de nouveau sur SAUVER.
                6. Maintenant l'icône DocLink doit appraitre dans ton éditeur

                A+,
                Manu.
                Développeur de FLEXIcontent : Nouveau système de gestion de contenu et CCK gratuit pour Joomla! 1.5 www.flexicontent.org
                www.vistamedia.fr : Création de sites internet professionnels sous Joomla
                *** Pas de demandes de support en MP ***

                Commentaire


                • #9
                  Salut Manu,

                  Merci, de m'avoir répondu, vu qu'en plus j'ai suivi ton conseil pour installer Docman plutôt que Remository (ICI)
                  Car au départ, je cherchais un moyen pour bien SEFiser lol Remository et en glanant des infos à droite à gauche, j'ai appris que Remository se tournerai plutôt vers Mambo dans l'avenir... Donc vu que je suis toujours en phase de construction de mon site et que maintenant, je ne suis plus à une semaine près pour le sortir... autant installer toute la "suite" Docman pour éviter de possibles déconvenues futures...

                  Sinon, pour fermer cette petite parenthèse, merci pour cette ruse
                  ça fonctionne le petit bouton apparaît bien, je n'avais pas pensé à essayer en dépubliant "aucun éditeur".

                  Bon, malheureusement, ça fait survenir un autre soucis...
                  Lors de l'affichage du popup j'ai un Warning

                  Warning: main(configuration.php): failed to open stream: No such file or directory in /home/heberg/public_html/mambots/editors-xtd/doclink/popups/doclink.conf.php on line 17

                  Fatal error: main(): Failed opening required 'configuration.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/heberg/public_html/mambots/editors-xtd/doclink/popups/doclink.conf.php on line 17
                  Ca me fait penser au même genre de problème que certains, dont moi (bien evidemment lol) , rencontrons avec le bouton "Upload" pour créer des articles en Backend.

                  Code PHP:
                  12   define"_VALID_MOS");
                  13   
                  14   $base_path 
                  "../../../../";
                  15   
                  16   
                  include_once( $base_path."globals.php" );
                  17   require_once( $base_path."configuration.php" );
                  18   require_once( $base_path."includes/mambo.php" );
                  ..
                  ..
                  ..
                  57   //doclink url
                  58  $doclink_url "$mosConfig_live_site/mambots/editors-xtd/doclink"
                  Pourtant en vérifiant encore, je ne vois pas ce qui peut être mal configuré.
                  Dans mon configuration.php à la racine, j'ai bien:
                  Code PHP:
                  $mosConfig_absolute_path '/home/heberg/public_html';
                  $mosConfig_live_site 'http://www.monsite.net'

                  @+ je vous tiens au courant si je trouve quelquechose...
                  Dernière édition par Thalyn à 22/10/2006, 17h53

                  Commentaire


                  • #10
                    Code:
                    12   define( "_VALID_MOS", 1 );
                    13   
                    14   $base_path = "../../../../";
                    15   
                    16   include_once( $base_path."globals.php" );
                    17   require_once( $base_path."configuration.php" );
                    18   require_once( $base_path."includes/mambo.php" );
                    ..
                    ..
                    ..
                    57   //doclink url
                    58  $doclink_url = "$mosConfig_live_site/mambots/editors-xtd/doclink";
                    Essaye de répèter la variable $base_path entre les ligne 16 et 17 :

                    Code:
                    12   define( "_VALID_MOS", 1 );
                    13   
                    14   $base_path = "../../../../";
                    15   
                    16   include_once( $base_path."globals.php" );
                    17   $base_path = "../../../../";
                    18   require_once( $base_path."configuration.php" );
                    19   require_once( $base_path."includes/mambo.php" );
                    ..
                    ..
                    ..
                    58   //doclink url
                    59  $doclink_url = "$mosConfig_live_site/mambots/editors-xtd/doclink";
                    Je n'ai pas testé mais ça devrait le faire.

                    A+, Manu.
                    Développeur de FLEXIcontent : Nouveau système de gestion de contenu et CCK gratuit pour Joomla! 1.5 www.flexicontent.org
                    www.vistamedia.fr : Création de sites internet professionnels sous Joomla
                    *** Pas de demandes de support en MP ***

                    Commentaire


                    • #11
                      Re salut,

                      Oui ça le fait super bien
                      Impeccable, Grand Merci à toi Manu.
                      Dernière édition par Thalyn à 22/10/2006, 17h51

                      Commentaire


                      • #12
                        Bonjour,

                        Quelle tête à cette fameuse icône ?
                        je ne la vois pas, même en ayant fait la manip de vistamedia...

                        merci.

                        Commentaire


                        • #13
                          Salut,

                          C'est celui que j'ai entouré d'un cadre rouge sur l'image ci-dessous:



                          Mais as tu pensé à le publier ?
                          Après avoir installé DocLink, es-tu allé sur "Mambots" --> "Site Mambots" et d'avoir publié le bot "Dotclink" (Il ne doit pas être coché en rouge)...

                          @+
                          Dernière édition par Thalyn à 27/10/2006, 17h12

                          Commentaire


                          • #14
                            C'est exactement.. ce que j'avais pas fait ;-)

                            Merci !

                            Commentaire


                            • #15
                              je rencontre cette fois un autre prob : j'ai pu uploader un fichier, j'ai créé une catégorie, mais comment mettre ce fichier dans cette catégorie ??
                              j'ai cherché, mais n'ai pas trouvé..

                              Merci.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X