Joomladay francophone 2018 à Paris 18 et 19 mai

Docman et caractères bizarres !

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Docman et caractères bizarres !

    Bonjour,
    J'ai téléchargé la dernière version bêta de Docman, qui me paraît très bien faite, mais j'ai des caractères bizarres qui s'affiche tant dans l'administration qu'en frontend : " " en haut de page, des caractères accentués, remplacés dans le fichier de langue, apparaissent sous forme "é" dans les listes déroulantes de l'administration...
    Quelqu'un aurait-il une idée de la cause de ces bizarreries ?
    Merci d'avance,
    Robert
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

  • #2
    la cause oui.. La solution non.

    Donc la cause très probable : une mauvaise configuration charset (qui devrait être ISO-8859-1). Je ne connais pas docman, soit il est possible de le modifier via l'admin, soit dans la page d'index de docman...
    ETRE VIVANT
    www.petiteagora.net

    Commentaire


    • #3
      Ces caractères n'apparaîssentt qu'en frontend et sur certaines pages du paramétrage où d'autres infos sont bien accentuées !
      Le problème est que Docman comporte une sacrée quantité de fichiers : j'en ai exploré déjà pas mal sans trouver...
      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

      Commentaire


      • #4
        J'ai aussi testé cette version et j'ai rencontré le même souci...

        J'ai commencé à le règler déjà en passant les fichiers de langues française en ANSI plutôt qu'en UTF-8 (sous notepad, faire enregistrer sous, format ANSI), et du coup je n'ai plus de souci d'affichage des carctères...

        A part ce petit " " qui apparait en front comme en back, et que je n'arrive pas à trouver null par dans les fichiers...
        Celui là j'avoue que je ne comprends pas d'ou il sort, mais bon, comme de toute façon c'est encore une version beta, j'attendrai pour l'utiliser
        Christophe
        Joomla newb but Joomla fan

        Commentaire


        • #5
          J'ai tenté ce réenregistrement, sans succès...
          Pour les caractères "", il est étonnant que la séquence soit en double sur la page de paramétrage de DOCman et en triple sur la page affichée par le composant !

          Edit : la séquence n'apparaît plus qu'une seule dois en backend... et en double en frontend ! Il y a du progrès.
          Dernière édition par RobertG à 13/09/2007, 14h46
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

          Commentaire


          • #6
            Bonjour à tous,
            j'ai le même soucis !

            j'ai mis tout mes charsets en iso-8859-1 et ce  est toujours là !

            Commentaire


            • #7
              Essayez de faire une recherche sur  (ou approchant) dans le forum.
              La question a déjà été posée (mais pas sur DocMan).
              MWIP pour les intimes

              M. W. I. Prod. (Documentations et téléchargements pour Joomla!)

              Commentaire


              • #8
                Bon pour faire avancer le Chmilblik :

                je suis revenu sur le version "com_docmanV1.3-RC-2.zip" => plus de problème!

                je sui convaincu que c'est un problème avec des fichiers de formats différents : UTF8 et latin1..... comme je n'ai pas envie de faire des iconv partout : je reviens sur la version antérieure qui elle ne contient pas de traduction Fr => pas de pb d'accentuation... même si les titres de documents contiennent des accents.

                au fait, j'avais fait un copier/coller du fameux ï... depuis la page du mon site vers un éditeur, ensuite je me suis amusé à changer les formats d'affichage.... eh bien cette chaine bizarre a été traduite en ".." !! j'en perd mon latin.

                Commentaire


                • #9
                  jeanpaul,

                  Si tu souhaites avoir l'ancienne version en français, tu entrouveras de bonnes traduction sur le site de Sharky, et un package d'installation modifié (corrigé) sur le dépôt de joomlagora...

                  Personnellement, j'en reste à la 1.3RC2 en attendant une version stable de la 1.4
                  Christophe
                  Joomla newb but Joomla fan

                  Commentaire


                  • #10
                    merci !
                    c'est l'occasion de remercier dans son ensemble la communauté Joomla !

                    je "joomlatise" depuis début septembre au boulot et je suis impressionné !...

                    Commentaire


                    • #11
                      Regardez si la discussion suivante http://forum.joomla.fr/showthread.php?t=43225 ne résoud pas le problème.
                      Bye.

                      Commentaire


                      • #12
                        Pour info, j'ai mis des fichiers que j'ai moi-même corrigés sur le même fil de discussion http://forum.joomla.fr/showthread.ph...319#post213319
                        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                        Commentaire


                        • #13
                          Vous pouvez utiliser la version du composant sur le site suivant : http://www.mwiprod.com/

                          J'ai fait le test et je n'ai plus les fameux "", ni en front, ni en back.
                          Grand merci à M.W.I Prod qui m'a évité de défaire mon installation et revenir sur version ultérieure.
                          Samsam

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X