Header en gif animé sous Safari (Max os X)

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Header en gif animé sous Safari (Max os X)

    Hello la joomla french Team !

    Je rencontre un drôle de problème :
    J'ai opté pour un gif animé en tant qu'image de mon header.
    Ça ne pose pas de problème, il tourne bien sous IE et Explorer.

    Par contre, Safari (je suis sur Mac) ne lit pas l'animation. Il reste bloqué à la première image... Ce qui est d'autant plus étonnant que si on ne lit que l'image dans Safari (pas importée dans Joomla, je veux dire) et bien elle se lit sans problème.

    C'est donc l'interaction Joomla/Safari qui semble problématique pour le gif animé.

    J'aimerais trouver une solution à ça parce que Safari est le navigateur le plus utilisé sur Mac (même si les macs eux-même représentent seulement 5% du marché) ça me tient à coeur...

    Quelqu'un a-t-il déjà rencontré ce problème ?
    Dernière édition par smattern à 08/09/2006, 09h54
    http://www.faubourg44.com

  • #2
    et Firefox ?

    Pourquoi ne pas passer sous Firefox ? Cela résoudrait pas mal de problème lié à Safari..
    Chabi
    Chabi01 - http://www.xlformation.com

    Commentaire


    • #3
      Ben oui, évidemment...

      Mais mon problème n'est pas la façon dont moi je vois le site, mais bien que les utilisateurs puissent tous visualiser le bandeau...
      http://www.faubourg44.com

      Commentaire


      • #4
        safari et arrière plan

        D'après ce que je viens de voir, Safari ne sait pas animer les images en arrière plan.. Comment l'as-tu inséré ? As-tu fait le test sur une autre machine ? Versions du système et du logiciel ?
        Chabi01 - http://www.xlformation.com

        Commentaire


        • #5
          Ah bon ?

          Ça paraît fou...

          C'est une image d'arrière-plan de mon <div> :
          #header { background: url("../images/headerAnim.gif") no-repeat bottom center;}
          http://www.faubourg44.com

          Commentaire


          • #6
            test a faire

            Tu peux faire un test : en affichant la même image en premier plan (pas en background), est-elle animée ? Si oui, ton problème ne sera pas résolu aujourd'hui sous Safari : va falloir attendre une Maj.. Mais comme les développeurs ne se foulent pas trop pour ce qui est de Safari, tu ne l'as pas encore.
            Tu as encore une autre soluce sous Mac : as-tu testé Camino ?
            http://www.caminobrowser.org/
            Dans ce cas là, tes "lecteurs Mac" peuvent passer dessus (tu leur fournis le lien, et l'install est super simple sous Mac).

            Si tu fais le test, donne moi la réponse : ça m'intéresse (j'ai des personnes avec qui je travaille qui sont uniquement sur Mac..)
            Chabi

            EDIT : peux-tu me donner l'adresse de ton site pour que je puisse lire le code ?
            Dernière édition par chabi01 à 17/05/2006, 17h05
            Chabi01 - http://www.xlformation.com

            Commentaire


            • #7
              Bien sûr qu'elle est animée si elle n'est pas en arrière-plan...

              Pour Camino, mon problème, c'est que le site en question est un site d'une société, et dont les utilisateurs ne sont pas identifiables, c'est pour du grand public, donc, on a aucun moyen de transmettre l'info du changement de navigateur en particulier aux utilisateurs Mac...

              Pour l'adresse du site, je ne peux te la donner pour l'instant (ou plutôt je peux, mais elle est protégée par un pass tant que le site est en construction :www.taocityguide.com) mais sa mise en ligne definitive ne devrait pas tarder normalement.

              Merci de ton intérêt pour ce problème en tout cas.
              http://www.faubourg44.com

              Commentaire


              • #8
                J'attend alors..

                Bon, ben si je ne peux pas voir ta page, j'attendrai que tu signales le moment où celle-ci devient accessible !
                Juste une question (je ne vois pas ta page !) : pourquoi faut-il absolument mettre ton image en arrière plan ? Cela pose t-il un problème si elle est en premier plan ?

                Si la seule solution pour animer l'image est qu'elle soit en premier plan, alors peut-être que reprendre l'organisation du template va être nécessaire.

                Si tu postes le template, ce sera plus facile de t'aider.. Je suppose qu'une simple réorganisation de l'affichage des éléments dans ton template pourrait régler le problème..
                Chabi01 - http://www.xlformation.com

                Commentaire


                • #9
                  Je sais bien...
                  Ben je peux te dire que j'ai essayé !!!

                  Mais j'ai pris au départ un template (kubrick) que j'ai modifié au fur et à mesure, et maintenant que je me rends compte à quel point il est mal foutu, je peux plus faire marche arrière !!!

                  Je n'arrive pas à placer ce header en image sans tout foutre en l'air la disposition... c'est pourquoi j'i juste changé le code existant qui chargeait une image d'arrière-plan...

                  De plus, le fichier template_css.css ne contient en fait qu'un appel vers 3 autres css (mambo, layer et menu qui gère le topmenu) je n'ai jamais vu ça auparavant, et ça complique encore un peu !

                  Bref, le Template est en pièce jointe, si tu as 2 minutes pour y jeter un oeil, je t'en serais éternellement reconaissant, chabi !

                  Merci encore pour ton aide.

                  S.
                  Fichiers joints
                  http://www.faubourg44.com

                  Commentaire


                  • #10
                    Bon, t'as raison sur un point : si je dois mettre les mains dans le cambouis (euh..le template), je perdrais moins de temps à le refaire de rien que d'essayer de le modifier. Par contre, si je te le recode, je ne recoderai pas le menu (je peux te recode le template, pas le css - trop long vu la taille des fichiers css à relire) : il faudra que tu utilises un menu "amélioré" (composant ou module) si tu veux repartir d'un nouveau template.. C'est toi qui me dit..
                    Chabi01 - http://www.xlformation.com

                    Commentaire


                    • #11
                      Quelle gentillesse, Chabi !

                      Et bien figure-toi que le problème est réglé !!!

                      En fait, j'avais testé le template en question uniquement à mon boulot... et hier, alors que je suis plutôt sur Firefox chez moi, j'ai commencé à trravailler depuis Safari... et j'ai vu l'anim !!!

                      La différence : la version du logiciel système et donc de Safari !!! Je suis en Tiger chez moi et en Jaguar au boulot...

                      La mise à jour de Safari dont nous parlions a donc déjà eu lieu !


                      Merci encore mille fois, je suis ravi qu'il existe encore des gens compétants, passionnés et prêts à servir comme tu l'as fait.

                      À l'avenir, que me conseille tu pour travailler sur un nouveau projet de site ? Y a-t-il un template reconnu "propre" dont je pourrais partir ou bien faut-il le créer de toutes pièces ?

                      D'ailleurs, aurais-tu un site que je puisse y jeter un oeil ?
                      http://www.faubourg44.com

                      Commentaire


                      • #12
                        Je suis heureux que tu sois..heureux !

                        Pour ta question sur la création de template, personnellement, je préfère faire mes templates moi-même ; j'obtiens exactement ce que je veux, je peux le reprendre à volonté, faire les modifs graphiques comme je le sens ! Je trouve plus difficile de réutiliser la logique de création de quelqu'un que de créer moi même !
                        Si tu veux te lancer dans ce (gratifiant) travail de création, j'ai réalisé un tuto pour faire son template que tu pourras trouver ici :
                        http://www.xlformation.sup.fr
                        Enregistres-toi, dans la section Téléchargement tu as une section "Création Web", cherche "Créer un tuto avec des logiciels gratuits" + template.zip + template.svg.zip,Télécharges-les, bouquine et crée !!! Cela va t'éclater de pouvoir faire exactement ce que tu veux ou ce que l'on te demande !!

                        Fais moi part de tes commentaires sur le tuto (ça m'interesse !) et n'oublie de poster un lien sur ce post dès que tu as réalisé quelque chose !
                        A bientôt !
                        Chabi01 - http://www.xlformation.com

                        Commentaire


                        • #13
                          salut,

                          n'oublie pas d'utlisé le préfixe "réglé" ,une fois que ton problème est réglé.

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X